Auteur Sujet: Ubuntu: Installation des codecs non libres  (Lu 11607 fois)

0 Membres et 1 Invité sur ce sujet

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« le: 23 avril 2016 à 14:58:41 »
Ubuntu 16.04 : Installation des codecs non libres, via "Supplèments restreints Ubuntu"
Ou comment installer des  codecs et applications couramment utilisées, mais restreintes par des droits d'auteur donc non intégré dans Ubuntu (mp3, avi, mpeg, TrueType, Java, Flash, Codecs).


Un seul paquet ubuntu-restricted-extras permet de tout installer simplement et rapidement.

1/ Ouvrir un terminal avec le raccourci "ctrl" + "alt" + t
2/ Coller la commande suivante : sudo apt install ubuntu-restricted-extras
3/ Votre mot de passe vous est demandé.
4/ On vous demandera également de valider la licence Microsoft pour l’installation des polices de caractères Windows : descendez le curseur sur le <OK> :

5/ Déplacez le curseur sur la gauche pour sélectionnez <Oui> et appuyez sur entrée (en cas de refut, les polices Microsoft ne sont pas installées)



Si vous utilisez Lubuntu : sudo apt install lubuntu-restricted-extras
Si vous utilisez Xubuntu : sudo apt install xubuntu-restricted-extras
Si vous utilisez Kubuntu : sudo apt install kubuntu-restricted-extras
Si vous utilisez  Ubuntu GNOME, Ubuntu MATE, Edubuntu, Mythbuntu, Ubuntu Kylin, ou Ubuntu Studio : sudo apt install ubuntu-restricted-extras



Quels sont les paquets installés par ubuntu-restricted-extras ?

- flashplugin-installer : Programme d'installation de l'extension Adobe Flash pour Mozilla
Télécharge et installe le plugin Adobe Flash Player. Le plugin Adobe Flash Player fonctionne avec une gamme de navigateurs Web: Firefox, Chromium, SeaMonkey, Iceweasel, Iceape, Galeon, Epiphany, Konqueror
L'installation de ce paquet Ubuntu provoque le téléchargement du plugin Adobe Flash Player à partir du site Web d'Adobe.

- gstreamer1.0-fluendo-mp3 : Installe le plugin GStreamer qui permet de décoder le MP3 (MPEG 1 audio layer III)

- gstreamer1.0-libav : Installe les plugins GStreamer qui permettent de décoder un grand nombre de formats de compression audio et vidéo : Encodage dans plus de 40 formats de compression (MPEG, DivX, MPEG4, AC3, DV, ...), décodage dans de plus de 90 formats de compression (AVI, MPEG, OGG, Matroska, ASF, ...), démultiplexage dans plus de 30 formats de compression différents. Plus d'informations sur https://www.libav.org/

- gstreamer1.0-plugins-bad : Installe les plugins GStreamer Bad pour les codecs mms, wavpack, quicktime, musepack. "Bad", car c'est un ensemble de greffons qui ne sont pas aussi bons que les autres. Ils peuvent être d'assez bonne qualité, mais ils leur manque quelque chose - comme une bonne relecture de code, de la documentation, une série de tests, un vrai mainteneur actif ou une utilisation répandue. Codecs pour lire les formats mp3, sid, mpeg1, mpeg2, AC-3, DVD (non chiffrés)

- gstreamer1.0-plugins-ugly : Installation des codecs pour lire les formats mp3, sid, mpeg1, mpeg2, AC-3, DVD (non chiffrés). Ce paquet contient des greffons venant de la série « ugly », une série de greffons de bonne qualité qui pourraient poser des problèmes de distribution.

- libavcodec-extra : Codecs supplèmentaires pour FFmpeg

- ttf-mscorefonts-installer : Ce paquet permet d'installer facilement les polices de caractères système Microsoft True Type pour le web, dont : Andale Mono Arial Black Arial (Gras, Italique, Italique Gras) Comic Sans MS (Gras) Courier New (Gras, Italique, Italique Gras) Georgia (Gras, Italique, Italique Gras) Impact Times New Roman (Gras, Italique, Italique Gras) Trebuchet (Gras, Italique, Italique Gras) Verdana (Gras, Italique, Italique Gras) Webdings Vous aurez besoin d'une connexion Internet pour télécharger ces polices de caractères si vous ne les avez pas déjà.
REMARQUE : le paquet fonts-liberation contient des variantes libres des polices Times, Arial et Courier. Il est préférable d'utiliser celles-ci à la place, sauf si vous avez spécifiquement besoin d'une des autres polices de ce paquet.

- unrar : Unrar peut extraire des fichiers à partir d'archives .rar. Si vous voulez créer des archives .rar, installez le paquet rar.

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #1 le: 23 avril 2016 à 15:19:23 »
Ce qui est installé en fonction de la distribution :

- Ubuntu : ubuntu-restricted-extras : installe tous les paquets décrits
- Xubuntu : xubuntu-restricted-extras : installe tous les paquets décrits
- Kubuntu : kubuntu-restricted-extras : installe tous les paquets décrits sauf le plugin GStreamer MP3
- Lubuntu lubuntu-restricted-extras : installe Adobe Flash, les Codecs supplèmentaires pour FFmpeg, les polices de caractères système Microsoft True Type et Unrar



Si vous souhaitez ne pas installer les codecs suplèmentaires pour FFmpeg, les polices de caractères système Microsoft True Type et Unrar vous pouvez utiliser :

- Ubuntu : ubuntu-restricted-addons : installe Adobe Flash, les plugins GStreamer MP3, libav, bad et ugly
- Xubuntu : xubuntu-restricted-addons : installe Adobe Flash, les plugins GStreamer MP3, libav, bad et ugly
- Kubuntu : kubuntu-restricted-addons : installe Adobe Flash, les plugins GStreamer libav, bad et ugly
- Lubuntu : lubuntu-restricted-addons : installe uniquement Adobe Flash



Liste des paquets installés par ubuntu-restricted-extras :

cabextract chromium-codecs-ffmpeg-extra flashplugin-installer freepats gstreamer1.0-fluendo-mp3 gstreamer1.0-libav gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers gstreamer1.0-plugins-ugly gstreamer1.0-plugins-ugly-amr i965-va-driver liba52-0.7.4 libaacs0 libass5 libavcodec-extra libavcodec-ffmpeg-extra56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2 libavutil-ffmpeg54 libbdplus0 libbluray1 libbs2b0 libchromaprint0 libcrystalhd3 libdc1394-22 libdca0 libde265-0 libdvdnav4 libdvdread4 libfaad2 libflite1 libfluidsynth1 libgme0 libgsm1 libgstreamer-plugins-bad1.0-0 libgtkglext1 libkate1 libmad0 libmimic0 libmjpegutils-2.1-0 libmms0 libmodplug1 libmp3lame0 libmpeg2-4 libmpeg2encpp-2.1-0 libmpg123-0 libmplex2-2.1-0 libmspack0 libofa0 libopenal-data libopenal1 libopencore-amrnb0 libopencore-amrwb0 libopencv-calib3d2.4v5 libopencv-contrib2.4v5 libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4v5 libopencv-imgproc2.4v5 libopencv-legacy2.4v5 libopencv-ml2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 libopenjpeg5 libpostproc-ffmpeg53 libschroedinger-1.0-0 libshine3 libsidplay1v5 libsnappy1v5 libsodium18 libsoundtouch1 libsoxr0 libspandsp2 libsrtp0 libssh-gcrypt-4 libswresample-ffmpeg1 libswscale-ffmpeg3 libtbb2 libtwolame0 libva1 libvdpau1 libvo-aacenc0 libvo-amrwbenc0 libwildmidi-config libwildmidi1 libx264-148 libx265-79 libxvidcore4 libzbar0 libzmq5 libzvbi-common libzvbi0 mesa-vdpau-drivers oxideqt-codecs-extra ttf-mscorefonts-installer ubuntu-restricted-addons ubuntu-restricted-extras unrar va-driver-all vdpau-driver-all vdpau-va-driver

Nh3xus

  • Réseau Deux Sarres (57)
  • Client K-Net
  • *
  • Messages: 1 635
  • Sarrebourg (57)
Ubuntu: Installation des codecs non libres
« Réponse #2 le: 23 avril 2016 à 15:30:55 »
Ubuntu a renommé le paquet avconv ?

Vu que c'est un fork de ffmpeg

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #3 le: 23 avril 2016 à 15:38:22 »
FFmpeg original est revenu (la cause d'un passage de quelques version d'Ubuntu sur Avconv est le fait du mainteneur Debian qui a basculé sur Avconv. Depuis Ubuntu 15.04 les deux sont disponibles et FFmpeg est utilisé par défaut)


Lire des DVD sous Ubuntu 16.04 (avec des logiciels tel que VLC, SMplayer, Totem,...)

1/ Ouvrir un terminal avec le raccourci "ctrl" + "alt" + t
2/ Coller la commande suivante : sudo apt install libdvd-pkg
3/ Votre mot de passe vous est demandé.
4/ Appuyer sur entrée pour valider <Ok> :


5/ Appuyer sur entrée pour valider <Oui> :


Exemple de résultat avec le DVD "La Bête Humaine" (film en noir et blanc) avec le lecteur vidéo Totem, installé par défaut sous Ubuntu :


Vous pouvez lire les DVD. Si les menu de votre DVD ne sont pas bien lu par votre lecteur vidéo, testez VLC (installation depuis la logithèque)

Exemple de résultat avec le DVD "La Bête Humaine" avec le lecteur vidéo VLC :

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #4 le: 23 avril 2016 à 16:00:15 »
Utiliser Netflix ou Canal Play sous Ubuntu 16.04



Netflix et CanalPlay ne fonctionne sous Linux qu'avec Google Chrome (ils ne fonctionnent pas avec Chromium, Firefox ou un autre navigateur)

Il faut donc installer Google Chrome depuis le site de Google : https://www.google.fr/chrome/

Google Chrome n'est disponible pour Linux que en 64bits : si vous avez un Ubuntu 32bits, il n'y a pas de solution sans ré-installer Ubuntu en 64bits (il n'existe pas de mise à jour 32bits vers 64bits)

Téléchargez le fichier .deb et double cliquez-dessus pour l'installer (votre mot de passe vous sera demandé)



Note : Flash 21 est incorporé à Google Chrome. Aucune action n'est nécessaire pour l'obtenir ou le mettre à jour.

hell0

  • Expert
  • Client SFR fibre FTTH
  • *
  • Messages: 716
  • Paris (75)
Ubuntu: Installation des codecs non libres
« Réponse #5 le: 23 avril 2016 à 19:55:27 »
Merci vivien pour ce super tuto !

willemijns

  • Client Free adsl
  • *
  • Messages: 1 112
Ubuntu: Installation des codecs non libres
« Réponse #6 le: 24 avril 2016 à 20:35:50 »
Ubuntu 16.04 : Installation des codecs non libres, via "Supplèments restreints Ubuntu"
Ou comment installer des  codecs et applications couramment utilisées, mais restreintes par des droits d'auteur donc non intégré dans Ubuntu (mp3, avi, mpeg, TrueType, Java, Flash, Codecs).

sur lubuntu 14.04LTS il m'a demandé a l'installation CD de tyout installer les codecs non libres, mais "sudo apt install lubuntu-restricted-extras" que tu proposes en donne un peu plus.... j'ai pas trop compris....

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #7 le: 24 avril 2016 à 21:02:23 »
Touts les dérivés d'Ubuntu proposent d'installer certains codecs non libres lors de l'installation. Cela ne comprends pas les codecs supplèmentaires pour FFmpeg, ni les polices de caractères système Microsoft True Type (qui demandent de valider la licence Microsoft), ni UnRar

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #8 le: 24 avril 2016 à 22:38:26 »
Autre chose que vous pouvez chercher : Installer des pilotes propriétaire pour des périphériques non ou mal pris en charge nativement par Linux.

C'est de moins en moins nécessaire, car les fabricant travaillent pour que leur pilotes soient intégrées directement dans le noyaux Linux (et donc ils font un effort pour aider à avoir une version Open source du pilote, car il n'est pas possible d'intégrer de base un pilote propriétaire dans le noyau Linux). On peut citer AMD dont le pilote propriétaire ( fglrx) a été retiré avec Ubuntu 16.04, car le pilote open source rempli maintenant son rôle.

Pour installer un pilote de propriétaire :
1/ Dans le menu tout en haut à droite, cliquez sur Paramètres système... puis dans Logiciels & Mises à jour
2/ Dans l'onglet Pilotes additionnels attendez que le système détecte vos périphériques.
3/ Il vous propose les périphérisques pour lesquels un pilote propriétaire est disponible. Il y a généralement le Microcode pour le microprocesseur Intel / AMD qui est proposé (inutile de l'activer) et éventuellement un ou deux périphériques comme cette carte WiFi Broadcom ci-dessous :

4/ Cliquez sur Utilisation de ..... puis sur Appliquer les changements pour installer le pilote. Votre mot de passe vous sera demandé.

vivien

  • Administrateur
  • *
  • Messages: 27 449
    • Twitter LaFibre.info
Ubuntu: Installation des codecs non libres
« Réponse #9 le: 24 avril 2016 à 22:46:25 »
Installation du logiciel propriétaire Microsoft Skype

1/ Dans le menu tout en haut à droite, cliquez sur Paramètres système... puis dans Logiciels & Mises à jour

2/ Dans l'onglet Autres logiciels cochez les deux cases (votre mot de passe vous est demandé)



3/ Ouvrir un terminal avec le raccourci "ctrl" + "alt" + t

4/ Coller la commande suivante : sudo apt install skype

On vous propose d'installer de nombreux bibliothèques 32bits (i386), car Microsoft Skype n'existe pas en version 64bits :


5/ Appuyez sur O pour lancer l'installation

6/ Skype se trouve dans le lanceur Unity en tapant Skype :


7/ Validez les conditions d’utilisation de Skype :


8/ C'est la version 4.3, mais elle prend en charge les comptes Skype (pseudonymes) comme les comptes Microsoft (adresse mail) :


La double authentification avec envoi de SMS est aussi géré :


L’interface de la version Linux est, contrairement à la version Windows, épurée au maximum et sans aucune publicité :


Skype fonctionne parfaitement sous Linux.

Tinnyrex

  • Client Orange Fibre
  • *
  • Messages: 23
  • Lyon - 8ème
Ubuntu: Installation des codecs non libres
« Réponse #10 le: 25 avril 2016 à 00:00:54 »
Un skype à l'ancienne, ça fait plaisir à voir !

Free_me

  • Client Free adsl
  • *
  • Messages: 387
Ubuntu: Installation des codecs non libres
« Réponse #11 le: 28 avril 2016 à 17:09:43 »
marrant quand meme qu'en 2016 il faille toujours autant s'emmerder pour faire des truc de base sous linux.

 

Mobile View