Sondage

Quel dispositif routeur utilisez vous pour tirer toute la substantifique moelle de votre accès FTTH Orange 2Gbps ?

Un Mikrotik CCR2004-1G-12S+2XS, parce que ça juste marche.
6 (11.8%)
Un Mikrotik CCR2004-16G-2S+, je n'ai pas trouvé de 12S+2XS.
2 (3.9%)
Un Mikrotik CCR2004-16G-2S+PC, j'ai voulu un modèle passif.
4 (7.8%)
Un Mikrotik  CCR2004-1G-2XS-PCIe, car tant qu'à faire, autant tout mettre sur l'hyperviseur.
0 (0%)
Un Mikrotik CCR2116-12G-4S+ parce qu'il faut savoir voir loin.
3 (5.9%)
Un Mikrotik RB5009UG+S+IN ou RB5009UPr+S+IN parce qu'ils sont trop stylés.
11 (21.6%)
Une appliance en VM dans un hyperviseur, avec une carte BMC57810s insérée avec PCI Passthrough, chez moi, j'ai même un autel pour vénérer @stevebrush.
1 (2%)
Opensense ou rien, en VM. La liberté n'est pas une condition négociable.
3 (5.9%)
PFsense, en VM, quitte à galérer, parce que FreeBSD rulez da world.
3 (5.9%)
Une VM CHR RouterOS de Mikrotik. La liberté, c'est bien, mais RouterOS, c'est bien, quand même.
1 (2%)
Un MacchiatoBin DoubleShot sous OpenWRT.
1 (2%)
OpenWRT, avec module bnx2x.ko patché, toujours, depuis 2006 et mon vieux Linksys WRT54G
2 (3.9%)
Linux Iptables, bien sûr, vils manants... Espèce de gens !
4 (7.8%)
Mes VMs, c'est Unraid
0 (0%)
Mes VMs, c'est Proxmox
0 (0%)
Mes VM, c'est VMWare
0 (0%)
Mdr une VM, moi, c'est Docker
0 (0%)
Je surfe la vague, alors j'ai opté pour la solution MiniPC x86 R86S - N5105/N6005 - 3x2.5G+2x10G (SFP+) d'ochbob
1 (2%)
Je suis encore en Livebox V5, et je me tâte à sauter le pas.
3 (5.9%)
Je suis enfin, et, qui sait, toujours en Livebox V6 2,5Gbps, et je me tâte encore.
4 (7.8%)
Je suis en Dual Wan Livebox devant un routeur Fortigate, je suis, je suis.... ?
2 (3.9%)

Total des votants: 51

Vote clôturé: 26 janvier 2023 à 21:26:48

Auteur Sujet: La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+  (Lu 568246 fois)

0 Membres et 1 Invité sur ce sujet

Asclèpios

  • Abonné Orange Fibre
  • *
  • Messages: 184
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4068 le: 12 novembre 2022 à 14:18:21 »
j'ai test de flasher un firmware carlitox puis un huawei sur un onu fs.com et ca fonctionne sans fail dans les 2 cas, ca règle le pb de PSU fail aléatoire.

Ce serait génial, cela fait combien de temps que ton routeur fonctionne avec l’ONU fs.com Carlitoxx sans avoir été redémarrer ? Quels est le modèle de ton routeur, et la version active de RouteurOS ?
(Une petite capture écran ?)

J'imagine que ca veut dire que le problème vient du firmware d'origine sur les fs.com (faudrait le flasher sur un huawei ou alcatel pour être certain :) )

Il faudrai un lien vers l’image du fs.com, j’ai des Huawei MA5671A sur lesquels je pourrais tester pour faire un retour ici ;)



Je garde ca comme ca. On verra dans le temps.

Il me tarde d’avoir ton retour ;) merci à toi

tidalf

  • Abonné Orange Fibre
  • *
  • Messages: 13
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4069 le: 12 novembre 2022 à 14:47:49 »
ca fait 24h (en tout avec les 2, sur un ccr2004 en 7.7beta6, la dernière) faut un peu plus de temps pour être sur :)

La c'est le fs.com avec un fw huawei qui tourne. (j'ai toujours le même pb de diff d'upload depuis mon mac sur le carlitox)

les firmware fs.com ont l'air d'être la https://hack-gpon.github.io/ont-fs-com-gpon-onu-stick-with-mac/
on peut les dumper en suivant les indications la : https://github.com/akhamar/orange-2500mbps-G010SP#backup-lonu-g-010s-p-avant-flash

Le flash du carlitox ca a marché impec via ssh, celui de huawei il a fallu passer par le serial pour réparer, je conseillerai pas sans adapteur serial :)


Asclèpios

  • Abonné Orange Fibre
  • *
  • Messages: 184
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4070 le: 12 novembre 2022 à 16:35:53 »
ca fait 24h (en tout avec les 2, sur un ccr2004 en 7.7beta6, la dernière) faut un peu plus de temps pour être sur :)
Ha oui mince en effet c’est trop court 24h ont ne pourra crier victoire, qu’au bout de 48h-72h, moi il crash au plus tard à 1j 12h … si on passe se délais sa veut dire résolu ;) ;) ;) Victoire !!! Sinon ;(
Par ailleurs il faudrait essayer avec RouterOS 7.6 (stable) pour être absolument certain ;)


La c'est le fs.com avec un fw huawei qui tourne. (j'ai toujours le même pb de diff d'upload depuis mon mac sur le carlitox)

Entendu à voir …

les firmware fs.com ont l'air d'être la https://hack-gpon.github.io/ont-fs-com-gpon-onu-stick-with-mac/
on peut les dumper en suivant les indications la : https://github.com/akhamar/orange-2500mbps-G010SP#backup-lonu-g-010s-p-avant-flash
Je vais tester ça aussi comme ça on aura plusieurs retour :) avec différents matériels ;)

Le flash du carlitox ca a marché impec via ssh, celui de huawei il a fallu passer par le serial pour réparer, je conseillerai pas sans adapteur serial :)
En effet pour ceux qui sont intéressé j’ai d’ailleurs des Huawei MA5671A ;) flash sous Carlitoxx du coup aucun problème de débit avec les bons paramètres ;)
« Modifié: 13 novembre 2022 à 22:52:59 par Asclèpios »

Atmis

  • Abonné Orange Fibre
  • *
  • Messages: 22
  • Lot (46)
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4071 le: 13 novembre 2022 à 22:36:36 »
Bonjour à tous,

Je me permets de solliciter les experts de ce forum pour un problème d'upload avec le GPON-ONU-34-20BI de chez FS.com.

Pendant un peu plus de 2 ans, j'ai tourné au bureau avec un Mikrotik RB3011 et un ONT Huawei fournit par Orange sur une offre Pro. Ça fonctionne, c'est fiable, c'est ce que devrait être une box pro. Pas besoin de COS6 par chez nous, ça simplifie aussi les choses  :D

Lors de la pose de la fibre à mon domicile il y a 2 mois, j'ai pris également une offre Orange Pro. Et j'en ai profité pour migrer sur une installation identique au bureau et à domicile : RB5009 + CRS305 + GPON-ONU-34-20BI.

Ça fonctionne plutôt très bien, et je peux même me passer du CRS305 depuis RouterOS 7.7beta4, puisqu'on peut à présent négocier à 2.5Gbps sur le port SFP.

Cependant il me manque une partie de mon upload, et je n'arrive pas à comprendre pourquoi.

Je m'explique. Mon offre est donc une offre Orange Pro 2Gbps / 1Gbps.

En branchant mon PC directement sur la Livebox 6, j'obtiens le débit de l'offre. (~2096Mbps/952Mbps). Si je mets la Livebox en double NAT avec le RB5009, idem, j'ai le bon débit.
En revanche, dès que je passe par l'ONU, (branché sur le CRS305 ou le RB5009, pas de différence), j'ai le bon débit en down (~2Gbps), mais mon up est amputé. Il monte rapidement à ~700Mbps, avant de redescendre entre 500 et 600Mbps. Impossible d'atteindre et dépasser 900Mbps comme avec la box.

Au bureau, j'ai exactement le même problème d'upload qu'à domicile avec le GPON-ONU-34-20BI (2Gbps down, entre 500 et 600Mbps up). Si je rebascule sur l'ONT Huawei en Ethernet (Je n'ai pas de LB6 au bureau), mon down est bien sûr bloqué à 1Gbps (~950Mbps), mais mon up remonte bien au-dessus de 900Mbps.

J'en déduis donc que le goulot d'étranglement de ne se trouve pas au niveau du Mikrotik et de sa configuration, mais bel est bien de l'ONU.

Est-ce que quelqu'un a constaté ces problèmes d'upload avec le GPON-ONU-34-20BI de chez FS.com ?

Merci !

tidalf

  • Abonné Orange Fibre
  • *
  • Messages: 13
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4072 le: 14 novembre 2022 à 07:45:27 »
Est-ce que quelqu'un a constaté ces problèmes d'upload avec le GPON-ONU-34-20BI de chez FS.com ?
Non mais avec d'autre firmwares oui (j'ai un peu moins de débit montant sur mon mac avec un carlitox qu'avec un fs.com), mais je plafonne a 600 avec mon offre.

Je confirme le fix pour les ccr2xxxx, en flashant les fs.com avec un carlitox ou un firmware huawei, les psu fail 1 et 2 disparaissent !

Atmis

  • Abonné Orange Fibre
  • *
  • Messages: 22
  • Lot (46)
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4073 le: 15 novembre 2022 à 21:54:17 »
J'ai la chance de ne pas être impacté par les problèmes de PSU étant sur des RB5009 et CRS305 :)

Il est vrai aussi que je n'aurai peut-être pas fait attention à ce problème sur une offre grand public (l'up étant limité à 600Mbps) ; il faut une offre pro pour atteindre 1Gbps en upload.

pinomat

  • Abonné Orange Fibre
  • *
  • Messages: 140
  • THIONVILLE 57
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4074 le: 17 novembre 2022 à 19:00:30 »
La c'est le fs.com avec un fw huawei qui tourne. (j'ai toujours le même pb de diff d'upload depuis mon mac sur le carlitox)

les firmware fs.com ont l'air d'être la https://hack-gpon.github.io/ont-fs-com-gpon-onu-stick-with-mac/
on peut les dumper en suivant les indications la : https://github.com/akhamar/orange-2500mbps-G010SP#backup-lonu-g-010s-p-avant-flash

Je suis en train de tester le firmware GPON-ONU-34-20BI sur le Huawei MA5761A et ça marche génial (pas de problème psu sur mon ccr2116 ni de perf download/upload) MAIS !!!! j'ai des flux IPTV qui tourne tout le temps (qui consomme 100Mbps en Tx+Rx) c'est très bizarre.
EDIT : Oups, après une nuit, le CCR2116 ne répondait plus, le routeur était en fault (mais pas les PSU)....

Pour le firmware Carlitoxx, comme je te l'ai dit Asclèpios, j'ai plein de micro déconnexion et ça ne semble vraiment pas stable sur ma connexion, à voir ce qu'on peut faire.

Quelqu'un a déjà vu ce phénomène ?
« Modifié: 18 novembre 2022 à 09:08:47 par pinomat »

Aize147

  • Abonné OVH
  • *
  • Messages: 964
  • Orange FTTH 2G/800M - Free FTTH 8G/700M - OVH FTTH
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4075 le: 17 novembre 2022 à 19:39:46 »
Pour info :

https://wiki.banana-pi.org/Banana_Pi_BPI-R3

Il est disponible depuis pas longtemps.

pinomat

  • Abonné Orange Fibre
  • *
  • Messages: 140
  • THIONVILLE 57

norabs

  • Abonné Orange Fibre
  • *
  • Messages: 20
  • Niort (79)
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4077 le: 18 novembre 2022 à 10:19:41 »
Bonjour à tous,

Pour diverses raisons j'avais mis en stand-by mon projet de remplacement de LB6 par un ensemble GPON-ONU-34-20BI + CRS305 + CCR2004-16G-2S.
J'avais juste pu tester en juin dernier que cela fonctionnait bien en 1Gbps à l’époque n'ayant pas de matériel coté PC compatible 2.5Gbps.

A l'occasion d'un passage en offre Orange fibre pro, et suite à l'achat de matos 2.5Gbps, j'ai eu envie de remettre en fonction le fs.com + mikrotik.

Le problème c'est que je reste mystérieusement bloqué a 1GBps sur cette config, alors que cela fonctionne en 2Gbps avec la LB6:

Setup 1: LB6 -> 10Gb SFP+ RJ45 -> [ QNAP QSW-2104-2S -> RJ45 -> Zyxel MG-105 -> PC ]

      Server: ORANGE FRANCE - Bordeaux (id: 29542)
         ISP: Orange
Idle Latency:     7.87 ms
    Download:  1986.16 Mbps
      Upload:   924.15 Mbps

Setup 2:  GPON-ONU-34-20BI -> CRS305 -> (DAC/SFP1) -> CCR2004-16G-2S+ -> (DAC/SFP2) -> [ QNAP QSW-2104-2S -> RJ45 -> Zyxel MG-105 -> PC ]

      Server: ORANGE FRANCE - Bordeaux (id: 29542)
         ISP: Orange
Idle Latency:     7.97 ms
    Download:  1029.41 Mbps
      Upload:   913.23 Mbps

Les tests sont effectués avec un Linux (NIC: Intel I225-V), et tout est synchronisé au max selon le matériel (10Gbps-full / 2.5Gbps-full).
Si je retire les switchs et branche le PC en direct sur le CCR2004-16G-2S+ (via le SFP+ RJ45), c'est pareil, cela reste bloqué à 1 Gbps.

Je peux poster les config du CRS et du CCR si besoin, mais c'est grosso modo ce que j'ai trouvé dans le post initial de ce thread.

Quelqu'un a t'il une idée, ou un setup fibre Orange 2Gbps fonctionnel avec le CCR2004-16G-2S+ ?

Merci!

« Modifié: 18 novembre 2022 à 10:51:22 par norabs »

Mackila

  • Abonné Bbox fibre
  • *
  • Messages: 345
  • 33
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4078 le: 18 novembre 2022 à 11:11:07 »
Le CRS305 est à jour ? le support du 2.5G en SFP est récent, et nécessite de forcer explicitement la vitesse.

norabs

  • Abonné Orange Fibre
  • *
  • Messages: 20
  • Niort (79)
La fibre Orange à 2Gbps, sur un routeur MikroTik 10Gbps CCR2004, via un ONT SFP+
« Réponse #4079 le: 18 novembre 2022 à 11:35:45 »
Oui le CSR305 est à jour (RouterOS 7.6):

# nov/18/2022 08:28:23 by RouterOS 7.6
# software id = Y2DJ-6BC0
#
# model = CRS305-1G-4S+
# serial number = ******
/interface bridge
add frame-types=admit-only-vlan-tagged ingress-filtering=no name=br-wan protocol-mode=none vlan-filtering=yes
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] advertise=2500M-full auto-negotiation=no rx-flow-control=auto speed=2.5Gbps tx-flow-control=auto
set [ find default-name=sfp-sfpplus2 ] advertise=10000M-full
/interface ethernet switch
set 0 l3-hw-offloading=yes
/interface bridge port
add bridge=br-wan interface=sfp-sfpplus1
add bridge=br-wan interface=sfp-sfpplus2
/interface bridge vlan
add bridge=br-wan tagged=sfp-sfpplus2,sfp-sfpplus1 vlan-ids=832
/interface ethernet switch rule
add dst-port=67 mac-protocol=ip new-vlan-priority=6 ports=sfp-sfpplus2 protocol=udp switch=switch1
add dst-port=547 mac-protocol=ipv6 new-vlan-priority=6 ports=sfp-sfpplus2 protocol=udp switch=switch1
...

J'ai pu aussi vérifier sur l'interface web du CRS305 que tout était bien reconnu sur le SFP1 (vitesse, modèle du fs.com, serial ...)
« Modifié: 18 novembre 2022 à 11:57:15 par norabs »