Auteur Sujet: Fibre 1G: mauvaises performances & connections TCP simples  (Lu 1431 fois)

0 Membres et 1 Invité sur ce sujet

vivien

  • Administrateur
  • *
  • Messages: 32 171
    • Twitter LaFibre.info
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #12 le: 30 juillet 2019 à 08:11:21 »
Je ne pourrais pas t'aider sur l'EdgeRouter, mais quand ton PC fait directement le PPPoE à la place du routeur OVH, je suis étonné des performances : c'est le CPU qui sature ?

Je suis étonné que PPPoE qui est assez simple prenne autant de ressources, surtout sur un CPU 4 cœurs HT.

nittch

  • Client OVH
  • *
  • Messages: 6
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #13 le: 09 août 2019 à 17:17:54 »
Nouveaux tests réalisés, en fait je pense que c'est l'implèmentation de windows 10 de PPPoE qui est à la ramasse... Avec une installation fraiche de Debian avec le package pppoe, utilisation CPU à 0% (sur la même machine) et exactement les mêmes perfs qu'avec l'Edgerouter... Ca ne semble pas venir de mon seetup donc.

kaktuss77

  • Client OVH
  • *
  • Messages: 272
  • OVH FTTH 1G/500M
    • @kaktuss77
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #14 le: 14 août 2019 à 10:28:23 »
Salut,

Je constate la même chose, Giga sur multi-co mais 200 240mbps sur une simple connexion http

Setups testé :

ONT Huawei + ERL-3 (gère le PPPoE)                 = 200-240mbps sur 1 Co / 946 en multi
ONT Huawei + Mikrotik CRS309 (gère le PPPoe) = 200-240mbps sur 1 Co / 946 en multi
ONT SFP Sercomm + ERL-3 (gère le PPPOe)       = 200-240mbps sur 1 Co / 946 en multi
ONT SFP Sercomm + Stormshield U250S (PPPoE)= 200-240mbps sur 1 Co / 946 en multi
ONT Huawei + MikroTik CRS309 PPPoE + Stormshield = 200-240mbps sur 1 Co / 946 en multi (config actuelle)

Machines qui ont servies pour les tests.

PC1 : I9-9900k + 32Go RAM + SSD NVMe
PC2 : VM I5-8400 + 8Go RAM + VHD sur SSD NVMe
PC3 : ThreadRipper 2950x + 32Go RAM + SSD NVMe

Par contre en FTP, j'arrive bien a monté au giga, cependant ce n'est pas stable. (avant avec ma ligne Orange, pas de soucis, je maintenant le giga sans soucis depuis la même source en ftp)

KOSC ne libre pas en VLAN coté ethernet de l'ONT mais je pense qu'il y a en 1 entre l'ONT et l'ONT,

Voila si ca peu aider


Edit : J'avais les tests début juillet, je viens de faire un test je suis entre 300 et 500Mbps en simple connexion.

Edit 2 : Ajout de la config actuelle
« Modifié: 14 août 2019 à 12:03:22 par kaktuss77 »

vivien

  • Administrateur
  • *
  • Messages: 32 171
    • Twitter LaFibre.info
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #15 le: 14 août 2019 à 11:37:42 »
Merci kaktuss77 pour ces tests.

Il confirme qu'un test mono-connexion est primordial pour vérifier la qualité d'un accès (mais qu'un test multi-connexion est important pour voir le débit du tuyau)

Il manque dans la description de tes tests le/les serveurs utilisés et surtout le système d’exploitation du client.

Certains systèmes de Microsoft n'activent pas les Timestamps TCP, ce qui pose des problèmes dans certains cas pour la montée en débit (forte latence ou paquets dé-séquencés).

Les serveurs sont généralement sous Linux, mais on en trouve avec Timestamps déactivé, car c'est ce que propose nPerf dans https://wiki.nperf.com/nperf-server/tcp-stack-tuning

Oui les Timestamps prennent 8 octets dans chaque paquets, mais ils peuvent aider. Cf https://tools.ietf.org/html/rfc1323

kaktuss77

  • Client OVH
  • *
  • Messages: 272
  • OVH FTTH 1G/500M
    • @kaktuss77
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #16 le: 14 août 2019 à 11:56:49 »
Merci pour les infos,

En effet j'ai oublié de précisé,

L'OS sur toutes les machines est Windows 10 v1809 à jour.

Les serveurs de speedtest sont Orange Paris, OVH Graveline, et le Online SAS Vitry (speedtest.net). (je constante les même débit à 50Mbps près)

L'Upload est également mauvais en mono-co ~250Mbps sur 500.

Je vais tester avec un Ubuntu en live pour voir ce que ca donne en MONO et je reviens vers le fofo

J'ai constaté quelque chose aussi concernant l'Upload, je suis a 500Mbps sur un serveur orange, sfr et ovh en multi-co, mais il semble que je suis "bridé" à 300Mbps vers le serveur Bouygues AnyCAST

Edit : J'utilise mon Pool IP fournie par OVH et non l'IP fournie par le PPPoE

Je joint une capture.


Hugues

  • AS57199 MilkyWan
  • Expert
  • *
  • Messages: 7 332
  • Paris (15ème)
    • Twitter
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #17 le: 14 août 2019 à 11:56:51 »
ONT Huawei + Mikrotik CRS309 (gère le PPPoe) = 200-240mbps sur 1 Co / 946 en multi
Pourquoi vouloir faire du routage sur un switch... :(

kaktuss77

  • Client OVH
  • *
  • Messages: 272
  • OVH FTTH 1G/500M
    • @kaktuss77
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #18 le: 14 août 2019 à 12:01:27 »
@Hugues, j'ai fais ça en catastrophe avant de partir en vacance pour 3 semaine, je savais que le MikroTik ne me ferait pas faux bond :)

Faut que je me re-penche sur l'infra, en même temps ça fait le Job, de plus , mon FW Stormshield ne gère par IPv6 sur les dialer PPPoE et j'avais pas envie d’utiliser autre chose pour le moment.

Je voulais également limité le nombre l'appareil allumé

ONT + RtR + FW + SW la j'ai le RtR en moins pour le moment

vivien

  • Administrateur
  • *
  • Messages: 32 171
    • Twitter LaFibre.info
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #19 le: 14 août 2019 à 12:55:23 »
Intéressant ton problème d'upload.

Il y a visiblement une différence dans la configuration qui doit expliquer ça.
Il est possible que cela soit visible dans l'initialisation de la connexion.

Cela serait possible de faire une capture Wireshark de Bouygues et Orange ?

Il me faut le début de la connexion pour voir les paquet [SYN].
La connexion sera difficile a exploiter si tu capture tout : je propose de démarrer la capture avant de cliquer sur le bouton "Lancer le test" puis l’arrêter après 1 seconde de test en download.

Si tu souhaites tu peut filtrer sur l'IP du serveur en question, je n'ai pas besoin du trafic annexe.
Pour Bouygues Telecom l'IP est 89.84.1.226

kaktuss77

  • Client OVH
  • *
  • Messages: 272
  • OVH FTTH 1G/500M
    • @kaktuss77
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #20 le: 14 août 2019 à 14:03:25 »
Ok Vivien je vais faire ça, par contre c'est normal que le testdebit.info me fasse pointer directement vers un serveur OVH plutot que le Anycast? j'avais pas ce genre de comportement avec ma connexion Orange

@Vivien, voici le fichier de capture Wireshark filtré sur le serveur en question, test intégrale.

https://das-cube.me/sharing/txJ7adLG6

vivien

  • Administrateur
  • *
  • Messages: 32 171
    • Twitter LaFibre.info
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #21 le: 14 août 2019 à 15:31:00 »
Avant, le test nPerf sur testdebit.info était limité aux serveurs que je gère.

Maintenant il prend le serveur censé être le pus performant pour l'opérateur testé.
Un avantage par rapport au test sur le site officiel de nPerf : J'ai mémoire qu'il consommait moins de CPU que celui de nPerf, donc pour une machine limité par le CPU, c'est intéressant.

Je télécharge ta capture de 2,4 Go, mais j'ai besoin d'une capture avec un autre opérateur en référence, par exemple Orange ou SFR. (SVP : seul le début, le plus important c'est le début de la connexion)

kaktuss77

  • Client OVH
  • *
  • Messages: 272
  • OVH FTTH 1G/500M
    • @kaktuss77
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #22 le: 14 août 2019 à 15:33:40 »
Oups j'avais compris que tu voulais le test complet, et le stop 1 sec après la fin. Je peux refaire la capture si besoin.

Pour l'autre opérateur, je suppose qu'il faut une Fibre aussi?

vivien

  • Administrateur
  • *
  • Messages: 32 171
    • Twitter LaFibre.info
Fibre 1G: mauvaises performances & connections TCP simples
« Réponse #23 le: 14 août 2019 à 15:41:59 »
Le stop une seconde après le début.

Wireshark est très lent au-dessus d'un fichier de 500 Mo.

Là je vais découvrir (je télécharge)

Edit: Wireshark arrive a ouvrir le fichier mais a la moindre opération c'est un temps interminable et dans certains cas plantage.

Bref, je veut bien deux petites captures pour voir ce qui est négocié à l'ouverture de la connexion TCP.

 

Mobile View