Auteur Sujet: IPv6 Orange Pro... toujours pas ?  (Lu 4219 fois)

0 Membres et 1 Invité sur ce sujet

nscheffer

  • Client Orange Fibre
  • *
  • Messages: 125
  • Chavenay (78)
IPv6 Orange Pro... toujours pas ?
« Réponse #36 le: 31 mars 2020 à 09:53:38 »
Peux-tu partager la configuration ? Merci !

Avec plaisir :
# mar/30/2020 07:46:36 by RouterOS 6.47beta49
# software id = PLK7-FUWK
#
# model = 960PGS
# serial number = AD8A0A404F4B
/interface bridge
add admin-mac=74:4D:28:6D:F7:AC auto-mac=no comment=defconf name=bridge
/interface vlan
add interface=ether1 name=vlan832 vlan-id=832
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip dhcp-client option
add code=60 name=vendor-class-identifier value=0x736167656d
add code=77 name=userclass value=0x2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7834
add code=90 name=authsend value=0x00000000000000000000001a0900000558010341010d6674692FXXXXXXX
/ip pool
add name=dhcp ranges=192.168.88.2-192.168.88.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge name=defconf
/ipv6 dhcp-client option
add code=11 name=authentication value=0x00000000000000000000001a0900000558010341010d6674692FXXXXXXX
add code=15 name=user-class value=0x002b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e6c697665626f7834
add code=16 name=vendor-class value=0x0000040e0005736167656d
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge comment=defconf interface=ether4
add bridge=bridge comment=defconf interface=ether5
add bridge=bridge comment=defconf interface=sfp1
/ip neighbor discovery-settings
set discover-interface-list=LAN
/ipv6 settings
set accept-router-advertisements=yes
/interface ethernet switch rule
add dst-port=67 mac-protocol=ip new-vlan-priority=6 ports=switch1-cpu protocol=udp src-mac-address=YY:YY:YY:YY:YY:YY/FF:FF:FF:FF:FF:FF switch=switch1
add mac-protocol=ipv6 new-vlan-priority=6 ports=switch1-cpu src-mac-address=YY:YY:YY:YY:YY:YY/FF:FF:FF:FF:FF:FF switch=switch1
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=ether1 list=WAN
/ip address
add address=192.168.88.1/24 comment=defconf interface=ether2 network=192.168.88.0
/ip dhcp-client
add dhcp-options=vendor-class-identifier,userclass,authsend disabled=no interface=vlan832
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 comment=defconf name=router.lan
/ip firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related
add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="NAT LAN to WAN" out-interface=vlan832
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www-ssl disabled=no
set api disabled=yes
set winbox disabled=yes
set api-ssl disabled=yes
/ipv6 address
add address=::1 from-pool=pool_REN_6 interface=bridge
/ipv6 dhcp-client
add add-default-route=yes dhcp-options=authentication,user-class,vendor-class interface=vlan832 pool-name=pool_REN_6 request=prefix
/ipv6 firewall address-list
add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
add address=::1/128 comment="defconf: lo" list=bad_ipv6
add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
add address=100::/64 comment="defconf: discard only " list=bad_ipv6
add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
add address=::224.0.0.0/100 comment="defconf: other" list=bad_ipv6
add address=::127.0.0.0/104 comment="defconf: other" list=bad_ipv6
add address=::/104 comment="defconf: other" list=bad_ipv6
add address=::255.0.0.0/104 comment="defconf: other" list=bad_ipv6
/ipv6 firewall filter
add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="defconf: accept UDP traceroute" port=33434-33534 protocol=udp
add action=accept chain=input comment="defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=udp src-address=fe80::/10
add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=input comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=input comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=input comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" hop-limit=equal:1 protocol=icmpv6
add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=icmpv6
add action=accept chain=forward comment="defconf: accept HIP" protocol=139
add action=accept chain=forward comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=ipsec-ah
add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=ipsec-esp
add action=accept chain=forward comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
add action=drop chain=forward comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN
add action=accept chain=input comment="allow dhcpv6 replies on WAN" dst-port=546 in-interface=vlan832 protocol=udp src-address=fe80::/10
add action=accept chain=input comment="accept ICMPv6" protocol=icmpv6
add action=accept chain=input comment="accept established, related, untracked" connection-state=established,related,untracked
add action=accept chain=forward comment="accept ICMPv6" protocol=icmpv6
add action=accept chain=forward comment="accept established, related, untracked" connection-state=established,related,untracked
add action=drop chain=forward comment="forward drop everything else" in-interface=vlan832
add action=drop chain=input comment="input drop everything else" in-interface=vlan832
/system clock
set time-zone-name=Europe/Paris
/system package update
set channel=testing
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN

C'est la version avec les switch rules sur un Mikrotik hEX PoE avec l'ONT d'origine Huawei qui est branché sur le port ether1.
Tu n'as plus qu'a ajouter ton login en hexa sans le fti/ au niveau des XXXX
Puis les YYYY c'est la MAC de ton port ether1 sur le Mikrotik.
Pour IPv6 ca marche mais c'est pas optimal car tout le trafic passe en Priorité 6, je pense qu'il y a un bug actuellement dans les switch rules.

C'est tout.


cyayon

  • Client Orange vdsl
  • *
  • Messages: 148
  • haute-savoie 74
IPv6 Orange Pro... toujours pas ?
« Réponse #37 le: 13 septembre 2020 à 08:28:23 »
Hello, j’utilise un routeur Linux et j’ai réussi à tout faire marcher (dhclient). Je suis en ip fixe (ipv4), est ce que le prefix IPv6 l’est aussi ? J’ai l’impression qu’entre 2 tests de config espacés d’une semaine, le prefix à changer. J’ai rêvé ou bien ? Sinon comment on s’aperçoit qu’il y a pb de priorité sur le traffic IPv6 ou ipv4 ? Des lenteurs ? Je voudrais valider ma config. Merci bcp.

buddy

  • Expert
  • Client Bbox fibre FTTH
  • *
  • Messages: 11 754
  • Alpes Maritimes (06)
IPv6 Orange Pro... toujours pas ?
« Réponse #38 le: 13 septembre 2020 à 09:05:01 »
Bonjour,

il me semble que l'IPv6 est bien fixe.
Pour la priorité du traffic IPv6 sur le traffic IPv4 c'est ton PC (tes périphériques) qui gèrent çà.
En FTTH IPv4+v6 chez Orange il y  4 ans, je n'avais pas noté de soucis de lenteurs ou autres.

jeremyp3

  • Pau Broadband Country (64)
  • Client Orange Fibre
  • *
  • Messages: 509
  • FTTH 1Gb/s sur Pau (64)
IPv6 Orange Pro... toujours pas ?
« Réponse #39 le: 13 septembre 2020 à 09:18:10 »
hello,

@buddy, je pense qu'il voulait parler de la priorité nécessaire parfois pour obtenir une ip sur le dhcp do'range :)

en gros, si ton setup fonctionne, c'est que tu as tout bien conf. dans le cas contraire, tu n'aurais pas de réponse a tes demande de solicitation de dhcp si la priorité n'était pas bonne. :)

Jerem

buddy

  • Expert
  • Client Bbox fibre FTTH
  • *
  • Messages: 11 754
  • Alpes Maritimes (06)
IPv6 Orange Pro... toujours pas ?
« Réponse #40 le: 13 septembre 2020 à 09:25:45 »
hello,

@buddy, je pense qu'il voulait parler de la priorité nécessaire parfois pour obtenir une ip sur le dhcp do'range :)
Ha oui :/ Je ne suis pas réveillé ..

cyayon

  • Client Orange vdsl
  • *
  • Messages: 148
  • haute-savoie 74
IPv6 Orange Pro... toujours pas ?
« Réponse #41 le: 13 septembre 2020 à 15:52:09 »
Merci les gars. Donc il

cyayon

  • Client Orange vdsl
  • *
  • Messages: 148
  • haute-savoie 74
IPv6 Orange Pro... toujours pas ?
« Réponse #42 le: 13 septembre 2020 à 15:53:53 »
Oups message tronqué. Je disais donc merci les gars. En cas de priorité mal paramètrée, il ne peut y avoir de lenteur de téléchargement ou de débit moindre ? Pas de truc dans genre ? C’est juste pour bien valider ma config :)

buddy

  • Expert
  • Client Bbox fibre FTTH
  • *
  • Messages: 11 754
  • Alpes Maritimes (06)
IPv6 Orange Pro... toujours pas ?
« Réponse #43 le: 13 septembre 2020 à 15:57:50 »
je crois que is tu fais passer tout le traffic en COS 6, tu peux être limiter oui.

jeremyp3

  • Pau Broadband Country (64)
  • Client Orange Fibre
  • *
  • Messages: 509
  • FTTH 1Gb/s sur Pau (64)
IPv6 Orange Pro... toujours pas ?
« Réponse #44 le: 13 septembre 2020 à 16:06:09 »
je crois que is tu fais passer tout le traffic en COS 6, tu peux être limiter oui.

en effet, mais généralement, c'est une limitation que tu vois très vite, parce que ton débit ne dépasse pas quelques mbps dans les deux sens.

Jerem

cyayon

  • Client Orange vdsl
  • *
  • Messages: 148
  • haute-savoie 74
IPv6 Orange Pro... toujours pas ?
« Réponse #45 le: 13 septembre 2020 à 17:32:35 »
Ok merci, je vais tout de même faire un petit test pour valider :) en fait tout doit être en COS 0 sauf le dhcp client qui doit être en COS 6, c’est bien ça ?

nscheffer

  • Client Orange Fibre
  • *
  • Messages: 125
  • Chavenay (78)
IPv6 Orange Pro... toujours pas ?
« Réponse #46 le: 14 septembre 2020 à 06:01:43 »
Bonjour,

J'ai actuellement une Livebox 5 en 2Gb/600Mb et une Livebox Pro 5 en 1Gb symétrique, il y a quelques mois j'avais fait pas mal de test pour remplacer les deux livebox 5 par un Mikrotik, si je me souviens bien :
- La livebox 5 Pro est juste un firmware différent sur un hardware de livebox identique à la livebox 5
- la config d'une livebox 5 Pro est identique à celle de la livebox 5 (sauf les options pro spécifiques)
- Pour Ipv4 seul un Set Cos 6 pour le dhcp request
- Pour Ipv6 j'avais pas réussi et je faisais un Set Cos 6 pour tout le trafic (je sais performance catastrophique) mais ca marchait

J'avais pas poussé plus loin la partie IPv6, j'ai posté plusieurs fois mes tests et mes configs...je pense que c'était juste une limitation ou bug du Mikrotik, ca doit surement être résolu aujourd'hui.

 

Mobile View