Auteur Sujet: Double délégation de préfixe et DNS vide  (Lu 232 fois)

0 Membres et 1 Invité sur ce sujet

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 618
Double délégation de préfixe et DNS vide
« le: 22 septembre 2022 à 20:44:46 »
Bonjour,

Suite de cette discussion : https://lafibre.info/remplacer-livebox/remplacement-de-la-livebox-par-un-routeur-openwrt-18-dhcp-v4v6-tv/msg973584/#msg973584

Je me demandais s'il était possible d'avoir une double délégation de préfixe automatique. Je voudrais déléguer GUA et ULA à partir de mon openwrt.

En l'état, si la délégation de préfixe à l'air de fonctionner en arrière plan (l'interface LAN récupère bien les deux préfixes et s’attribue deux adresses), il n'y a que la GUA qui est annoncée et je suis obligé d'ajouter manuellement la ULA (qui d'ailleurs sans ajout d'ip virtuelle, ne fait qu'annoncer une route contrairement à pfsense).

D'autre part si je mets opnsense en intermédiaire je rencontre un problème étrange avec les requêtes DNS sur mon domaine interne : Mon DNS répond, mais l'enregistrement A est vide... alors même que la réponse le contient bien. Pour que ça fonctionne il faut que j’annonce mon DNS directement.

En faisant une capture de paquets, les deux requêtes sont identiques à l'exception du bit à 1 pour Accept DNSSEC security RRs avec OPNsense. Serait-ce juste ça qui fait déconner ?

Merci
« Modifié: 24 septembre 2022 à 15:14:10 par renaud07 »

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 618
Double délégation de préfixe et DNS vide
« Réponse #1 le: 30 septembre 2022 à 19:33:21 »
Après des jours de recherche, j'ai fini par trouver le coupable pour la partie DNS : l'activation par défaut de la protection DNS rebinding, qui interdit les ip privées...  >:(