Auteur Sujet: Iperf pas perf :)  (Lu 687 fois)

0 Membres et 1 Invité sur ce sujet

Empereur

  • Client Orange Fibre
  • *
  • Messages: 242
  • SOSH 300/300 - SFR 1000/60 - Elancourt (78)
Iperf pas perf :)
« le: 22 juillet 2018 à 10:58:03 »
Hello,

Je tente de faire fonctionner Iperf3.1.3 pour tester un changement d'AP wifi. Malheureusement je n'atteins que 350mbps-420mbps, alors que même speedtest m'indique entre 600/650mbps
Je n'ai aucun paramétré de spécifique:
serveur: iperf3 -s -i 1
client: iperf3 -c 192.168.1.11 -i 1 -d -t 10 (j'ai tenté 3600 mais la durée ne change rien au pb)

Des idées ?

Du point de vue de mon pc portable :
[  4]   0.00-10.00  sec   432 MBytes   362 Mbits/sec                  sender
[  4]   0.00-10.00  sec   504 MBytes   423 Mbits/sec                  receiver


vivien

  • Administrateur
  • *
  • Messages: 29 703
    • Twitter LaFibre.info
Iperf pas perf :)
« Réponse #1 le: 22 juillet 2018 à 11:02:29 »
Speedtest utilise 16 connexions TCP en parallèle.

iPerf3 permet d'avoir le même comportement avec l'option -P 16

Dans un mode parfait, le débit est identique avec une connexion simultanée et plusieurs mais dés qu'il y a des pertes de paquets, une connexion TCP va voir son débit diminuer.

1 connexion TCP => plus proche du ressenti utilisateur
16 connexions TCP en // => permet d'avoir le débit du tuyau.

Empereur

  • Client Orange Fibre
  • *
  • Messages: 242
  • SOSH 300/300 - SFR 1000/60 - Elancourt (78)
Iperf pas perf :)
« Réponse #2 le: 22 juillet 2018 à 12:22:47 »
Merci de l'explication Vivien,

Effectivement avec -P16 j'ai désormais :

[SUM]   0.00-10.00  sec   603 MBytes   506 Mbits/sec
[SUM]   0.00-10.00  sec   783 MBytes   656 Mbits/sec

vivien

  • Administrateur
  • *
  • Messages: 29 703
    • Twitter LaFibre.info
Iperf pas perf :)
« Réponse #3 le: 22 juillet 2018 à 12:29:13 »
Tu peut réaliser un test UDP avec iperf3 (argument -u, il faut indiquer un débit car UDP n'est pas en mesure de s'adapter)

Je pense que tu découvriras des pertes de paquets importantes.

Exemple pour tester à 200Mb/s rajouter les arguments -u -b 200m

Paul

  • Client FAI autre
  • *
  • Messages: 4 062
  • Montréal, QC (CA)
    • Twitter
Iperf pas perf :)
« Réponse #4 le: 22 juillet 2018 à 18:13:59 »
Si tu testes en WiFi ça me parait excellent, ça m'étonnerait que tu atteignes plus. Chez moi en Ethernet, j'ai bien 940 Mb/s.

Empereur

  • Client Orange Fibre
  • *
  • Messages: 242
  • SOSH 300/300 - SFR 1000/60 - Elancourt (78)
Iperf pas perf :)
« Réponse #5 le: 29 juillet 2018 à 17:08:53 »
Hello, logique d'avoir moins de perte avec un -u -b 900 qu'un -b 700 ???  :o

[ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
[  4]   0.00-10.00  sec   830 MBytes   696 Mbits/sec  0.048 ms  18434/106215 (17%)

[ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
[  4]   0.00-10.00  sec   827 MBytes   694 Mbits/sec  0.223 ms  17416/105898 (16%)

[ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
[  4]   0.00-10.00  sec   832 MBytes   698 Mbits/sec  0.047 ms  15382/106504 (14%)

[ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
[  4]   0.00-10.00  sec  1.05 GBytes   898 Mbits/sec  0.032 ms  5952/137027 (4.3%)

[ ID] Interval           Transfer     Bandwidth       Jitter    Lost/Total Datagrams
[  4]   0.00-10.00  sec  1.05 GBytes   898 Mbits/sec  0.112 ms  11523/136983 (8.4%)

 

Mobile View