Auteur Sujet: Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée  (Lu 1195 fois)

0 Membres et 1 Invité sur ce sujet

Feneck91

  • Client K-Net
  • *
  • Messages: 66
  • Saint-Germain Lès Arpajon (91)
Gros gros soucis pour ma part.
J'héberge mon forum et hier matin il n'était plus accessible.
Après recherches (je pensais que ça venait de la migration fibre de ma ville), on m'a aiguillé vers ce fil.
J'ai donc demandé un IP full stack et modifié mon @IP chez Gangi qui gère mon nom de domaine.
J'ai réussi à redémarrer ma freebox à distance (je ne suis pas chez moi),  grâce à une VM Windows 10 embarqué sur mon NAS Synology qui lui est resté accessible.
La freebox a bien changé d'adresse, mon NAS aussi, le forum (domaine) aussi, pour autant, le site web reste désespérément inaccessible (DNS_PROBE_FINISHED_NXDOMAIN) !

Je suis un peu perdu....

buddy

  • Expert
  • Client Bbox fibre
  • *
  • Messages: 13 045
  • Alpes Maritimes (06)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #1 le: 01 décembre 2019 à 13:39:16 »
Bonjour,
possible d'avoir le domaine ?

un DIG sur le domaine renvoie bien l'ip de la Freebox ?

Feneck91

  • Client K-Net
  • *
  • Messages: 66
  • Saint-Germain Lès Arpajon (91)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #2 le: 01 décembre 2019 à 13:51:31 »
www.arthrodese-lombaire.fr

mon ip : 82.64.214. soixante huit

buddy

  • Expert
  • Client Bbox fibre
  • *
  • Messages: 13 045
  • Alpes Maritimes (06)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #3 le: 01 décembre 2019 à 13:55:26 »
C'est un problème de DNS ...Tu es sur qu'il est bien configuré chez Gandi ?
arthrodese-lombaire.fr renvoie bien la bonne IP
tandis que
www.arthrodese-lombaire.fr ne renvoie rien... ni IPV4, ni IPV6 ...
( https://dnschecker.org/#A/www.arthrodese-lombaire.fr )
( https://dnschecker.org/#AAAA/www.arthrodese-lombaire.fr )

Citer
<<>> DiG 9.10.6 <<>> www.arthrodese-lombaire.fr
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 11096
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;www.arthrodese-lombaire.fr.   IN   A

;; Query time: 2020 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sun Dec 01 13:55:00 CET 2019
;; MSG SIZE  rcvd: 55

Si la configuration des DNS est bien faite chez Gandi, environ 10 minutes max après ta modif dans ton espace client, tu devrais obtenir des réponses au niveau des DNS

NB : peut être qu'un modo peut mettre ces posts ailleurs que dans l'épuisement des IP v4 RIPE..

Catalyst

  • Client FAI autre
  • *
  • Messages: 185
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #4 le: 01 décembre 2019 à 15:09:24 »
la résolution de www.arthrodese-lombaire.fr tourne en boucle sans résultat, du fait de l'avant-dernière ligne :

dig www.arthrodese-lombaire.fr +trace
;; global options:  printcmd
.                       518400  IN      NS      a.root-servers.net.
...
.                       518400  IN      NS      m.root-servers.net.
;; Received 228 bytes from (mon serveur) in 36 ms

fr.                     172800  IN      NS      d.ext.nic.fr.
...
fr.                     172800  IN      NS      g.ext.nic.fr.
;; Received 352 bytes from 2001:503:ba3e::2:30#53(a.root-servers.net) in 32 ms

arthrodese-lombaire.fr. 172800  IN      NS      ns-216-a.gandi.net.
arthrodese-lombaire.fr. 172800  IN      NS      ns-190-b.gandi.net.
arthrodese-lombaire.fr. 172800  IN      NS      ns-148-c.gandi.net.
;; Received 122 bytes from 2001:500:2e::2#53(d.ext.nic.fr) in 17 ms

www.arthrodese-lombaire.fr. 10800 IN    CNAME   ns.arthrodese-lombaire.fr.
ns.arthrodese-lombaire.fr.  86400 IN    NS      ns.arthrodese-lombaire.fr.
;; Received 91 bytes from 2001:4b98:aaaa::d9#53(ns-216-a.gandi.net) in 20 ms

Et la trace du ns :
dig ns.arthrodese-lombaire.fr +trace
.                       518400  IN      NS      a.root-servers.net.
...
.                       518400  IN      NS      m.root-servers.net.
;; Received 228 bytes from (mon serveur) in 3 ms

fr.                     172800  IN      NS      e.ext.nic.fr.
...
fr.                     172800  IN      NS      d.ext.nic.fr.
;; Received 351 bytes from 2001:503:ba3e::2:30#53(a.root-servers.net) in 32 ms

arthrodese-lombaire.fr. 172800  IN      NS      ns-190-b.gandi.net.
arthrodese-lombaire.fr. 172800  IN      NS      ns-216-a.gandi.net.
arthrodese-lombaire.fr. 172800  IN      NS      ns-148-c.gandi.net.
;; Received 121 bytes from 2a00:d78:0:102:193:176:144:22#53(e.ext.nic.fr) in 18 ms

ns.arthrodese-lombaire.fr. 86400 IN     NS      ns.arthrodese-lombaire.fr.
;; Received 73 bytes from 2001:4b98:aaab::bf#53(ns-190-b.gandi.net) in 20 ms

dig: Couldn't find server 'ns.arthrodese-lombaire.fr': Temporary failure in name resolution

vivien

  • Administrateur
  • *
  • Messages: 38 370
    • Twitter LaFibre.info
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #5 le: 01 décembre 2019 à 17:31:32 »
Effectivement il faut supprimer le CNAME qui pointe vers ns.arthrodese-lombaire.fr.

IL faut mettre un enregistrement A avec l'IPv4 publique de ta Freebox et un enregistrement AAAA avec l'IPv6 (qu'il faut rendre fixe, le plus simple étant de la configurer à la main) de ton serveur.

David75

  • Client Orange Fibre
  • *
  • Messages: 1 100
  • FTTH Orange sur Versailles (78)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #6 le: 01 décembre 2019 à 18:46:01 »
J'avais choisi une ip full stack il y a des années sur une de mes freebox. Et la semaine dernière, bascule en IP partagée...
J'ai du refaire ce choix dans mon espace abonné et il y a eu un changement d'ip du coup.

Le problème ici pourrait être lié où pas ?

Feneck91

  • Client K-Net
  • *
  • Messages: 66
  • Saint-Germain Lès Arpajon (91)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #7 le: 01 décembre 2019 à 21:44:52 »
Je ne comprend rien.
Voici ma configuration Gandi :
Citer
@ 10800 IN SOA ns1.gandi.net. hostmaster.gandi.net. 1575232530 10800 3600 604800 10800
@ 10800 IN A 82.64.214.68
@ 10800 IN MX 10 spool.mail.gandi.net.
@ 10800 IN MX 50 fb.mail.gandi.net.
@ 10800 IN TXT "v=spf1 include:_mailcust.gandi.net ?all"
_dmark 86400 IN TXT "v=DMARC1, p=none"
blog 10800 IN CNAME blogs.vip.gandi.net.
mail 86400 IN A 88.181.134.103
mail 86400 IN MX 10 mail.arthrodese-lombaire.fr.
mail 86400 IN TXT "v=spf1 a mx ip4:88.181.134.103 ~all"
mailkey._domainkey 86400 IN TXT "t=s; p=xxxxxxxxxxxxxxxxxxxxxx etc etc .........xxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
ns 86400 IN A 88.181.134.103
ns 86400 IN NS ns.arthrodese-lombaire.fr.
webmail 10800 IN CNAME webmail.gandi.net.
www 10800 IN CNAME ns.arthrodese-lombaire.fr.
J'avais changé le premier A qui devait être l'ancienne IP de ma box : 217.70.184.38 en 82.64.214.68
Je n'ai aucune idée de ce que peut-être l'adresse IP 88.181.134.103 présents dans ns et mail !!

Par contre, le site web est hébergé pas un synology derrière ma box, mais elle héberge aussi mon propre serveur de mail.
Or il m'est impossible d'envoyer des mails à gmail (refusé par gmail) si je suis en IPV6 => j'ai donc désactivé lIPV6 sur la carte réseau du synology pour que le serveur de mail fonctionne correctement et donc uniquement en IPV4. Si on se connecte en IPV6, cette adresse IP sera utilisé par le serveur de mail et aucun mail ne pourra être envoyé à une adresse gmail !

Voilà je suis perdu.

vivien

  • Administrateur
  • *
  • Messages: 38 370
    • Twitter LaFibre.info
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #8 le: 01 décembre 2019 à 21:49:10 »
Sur ce forum, j’envoie les mails en IPv6 quand c'est possible et j'ai eu des pb quand lafibre.info ne pointait plus vers l'IPv6 utilisée pour envoyer des mails à Gmail.

Il est donc important pour envoyer des mails que le site web de ton domaine soit configuré en IPv6 et pointe vers la même IP que celle qui va envoyer des mails. C'est un moyen pour ne pas avoir de pb avec Gmail.

buddy

  • Expert
  • Client Bbox fibre
  • *
  • Messages: 13 045
  • Alpes Maritimes (06)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #9 le: 01 décembre 2019 à 22:18:45 »
Il faut 
www 10800 IN CNAME arthrodese-lombaire.fr.  (sans le NS)
Et pas
www 10800 IN CNAME ns.arthrodese-lombaire.fr.

Feneck91

  • Client K-Net
  • *
  • Messages: 66
  • Saint-Germain Lès Arpajon (91)
Free: Pb pour héberger un site site suite au passage sur une IPv4 mutualisée
« Réponse #10 le: 01 décembre 2019 à 22:42:37 »
J'ai un peu configuré à l'arrache ce truc y'a un moment... Mais un ami qui travaille dans un grande école et qui administre le réseau est venu faire du ménage dans ma config domaine de Gandi, il m'a dit que c'était un peu le foutoir !

Bon, c'est réparé, il faudra un jour qu'on se penche sur le problème gmail...

Merci à tous...