Auteur Sujet: VPN : Débit faible avec Windows, mais pas Linux  (Lu 8329 fois)

0 Membres et 1 Invité sur ce sujet

pasbefri

  • Client FAI autre
  • *
  • Messages: 98
  • Hagondange (57)
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #12 le: 27 juillet 2014 à 09:36:38 »
Il ont unifé 2008 Server R2 et Windows 7 & 8  a ce niveau?

Hormis des restrictions commerciales de type un share CIFS c'est max. XXX connections sur les versions client et illimité en version serveur...
En revanche, les réglages par défaut sont différents quand les clés de registre ne sont pas là
Sinon, le kernel et la pile TCP/IP sont les mêmes selon la logique : 2008R2 = 7, 2012=8, 2012R2 = 8.1 (en version 64-bit évidemment puisque depuis 2008R2 il n'y a plus de version serveur 32-bit).

Sinon je suppose qe la machine a été redemarrée depuis moins de 248 jours ;-) (cf. http://support.microsoft.com/kb/2553549/en-US )




kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #13 le: 27 juillet 2014 à 11:36:54 »
Alors j'ai tester avec du 7 64bit version pro, du 8.1 Version Pro en 64bits également, j'ai pas tester avec 2012 Server, je monte la VM et vous tiens au jus.

kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #14 le: 28 juillet 2014 à 12:09:45 »
j'ai réalisé les capture wireshark, Linux distant vers Windows local (plein débit) et Windows distant vers Windows local (limité à 1Mbps)

IP du Linux distant : 172.16.20.100
IP du Windows distant : 172.16.0.10
IP du Windows local : 192.168.0.115

les captures hébergées sur mon cloud

edit : J'oubliais, tests réalisés avec Iperf avec la commande suivante : iperf -c 192.168.0.115 -i 2 -t 20

kgersen

  • Client Bouygues FTTH
  • Modérateur
  • *
  • Messages: 6 280
  • FTTH 1Gb/s sur Paris (75)
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #15 le: 29 juillet 2014 à 19:03:01 »
oula y'a énormèment de perte on dirait. La capture Windows montre déjà que l'ouverture de session n'a pas été acquittée (syn->syn-ack->perdu) et donc a du attendre 3 secondes (le timeout de TCP) avant de reprendre: ca fait deja 3 secondes sur 20s de test de perdu et ca n'est que le début.

Il faudrait faire des tests en UDP (avec iperf sur au moins une minute) pour mesurer le taux d'erreurs. et voir si c'est a peu près le meme suivant la machine en face (linux ou windows).

pour bien comparer,il faudrait aussi 2 captures non pas sur une durée commune mais sur un volume commun: genre un ftp ou un http du même fichier.

kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #16 le: 30 juillet 2014 à 19:25:24 »
genre le transfère d'un fichier de 15Mo ça devrait le faire. bah je vais refaire le test en UDP alors
je vous poste ça des que c'est fait. en plus je suis pas chez moi alors tout ce fait en bureau a distance lol

corrector

  • Invité
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #17 le: 30 juillet 2014 à 20:29:50 »
A une époque (je ne sais pas si c'est encore le cas avec les Windows moderne), les timestamps ne s'activaient pas a cause d'un bug.
Heu sous Vista les timestamps TCP marchent mais je crois qu'ils sont désactivés par défaut.

kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #18 le: 30 juillet 2014 à 21:39:19 »
Je viens de réaliser quelques tests en UDP avec Iperf (toujours avec les options i 2 et t 20) bah 1.05Mbit/s que ce soit avec le Linux distant ou le Windows Distant.

Log Iperf du windows distant :

[  3] local 172.16.0.10 port 55465 connected with 192.168.0.115 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0- 2.0 sec   257 KBytes  1.05 Mbits/sec
[  3]  2.0- 4.0 sec   256 KBytes  1.05 Mbits/sec
[  3]  4.0- 6.0 sec   256 KBytes  1.05 Mbits/sec
[  3]  6.0- 8.0 sec   256 KBytes  1.05 Mbits/sec
[  3]  8.0-10.0 sec   257 KBytes  1.05 Mbits/sec
[  3]  0.0-10.0 sec  1.25 MBytes  1.05 Mbits/sec
[  3] Sent 893 datagrams
[  3] WARNING: did not receive ack of last datagram after 10 tries.

Log du Linux distant :

------------------------------------------------------------
Client connecting to 192.168.0.115, UDP port 5001
Sending 1470 byte datagrams
UDP buffer size:  208 KByte (default)
------------------------------------------------------------
[  3] local 172.16.20.100 port 58587 connected with 192.168.0.115 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0- 2.0 sec   257 KBytes  1.05 Mbits/sec
[  3]  2.0- 4.0 sec   256 KBytes  1.05 Mbits/sec
[  3]  4.0- 6.0 sec   256 KBytes  1.05 Mbits/sec
[  3]  6.0- 8.0 sec   257 KBytes  1.05 Mbits/sec
[  3]  8.0-10.0 sec   256 KBytes  1.05 Mbits/sec
[  3] 10.0-12.0 sec   256 KBytes  1.05 Mbits/sec
[  3] 12.0-14.0 sec   257 KBytes  1.05 Mbits/sec
[  3] 14.0-16.0 sec   256 KBytes  1.05 Mbits/sec
[  3] 16.0-18.0 sec   256 KBytes  1.05 Mbits/sec
[  3] 18.0-20.0 sec   257 KBytes  1.05 Mbits/sec
[  3]  0.0-20.0 sec  2.50 MBytes  1.05 Mbits/sec
[  3] Sent 1785 datagrams
[  3] WARNING: did not receive ack of last datagram after 10 tries.

C'est quand même bizarre cette histoire de perte de paquets car depuis chez moi (donc en passant par mon agrégation de VPN) lorsque je fais un pingtest sur pingtest.net, packet loss j'ai 0% par contre j'ai pas mal de gigue.


De plus, lors de téléchargements de fichiers en provenance d'internet (http, ftp ou autre) je n'ai aucun soucis pour saturer mon agrégation de liens. (soit environ 11Mbps) cf : Fichier joint

Bon je m'en vais de se pas faire les capture wireshark d'un fichier de quelque Mo pour faire le test.


kgersen

  • Client Bouygues FTTH
  • Modérateur
  • *
  • Messages: 6 280
  • FTTH 1Gb/s sur Paris (75)
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #19 le: 30 juillet 2014 à 22:03:44 »
manque la fin de tes iperfs pour voir le bilan loss/out of order (bien mettre -u des 2 cotés).

par exemple:

Client connecting to XX.XX.XX.XX, UDP port 5001
Sending 1470 byte datagrams
UDP buffer size: 64.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.1.42 port 62828 connected with XX.XX.XX.XX port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-10.0 sec  1.25 MBytes  1.05 Mbits/sec
[  3] Sent 893 datagrams
[  3] Server Report:
[  3]  0.0-10.0 sec  1.25 MBytes  1.05 Mbits/sec   8.551 ms   39/  893 (4.4%)
[  3]  0.0-10.0 sec  39 datagrams received out-of-order

la on voit 4.4% de perte.

en mode UDP iperf envoi par défaut a 1Mbps. le but c'est pas de mesurer le débit mais les pertes.

Pour 'foncer' en UDP, utilises l'option -b. par exemple '-b 100M' pour envoyer a 100Mbps.

Attention aussi en UDP, le client peut marcher meme si le serveur est eteint ou pas pres. bien verifier la presence de 'server report' ou avoir les 2 écrans sous les yeux. Et faire les tests dans l'autre sens aussi (ou avec -r).

kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #20 le: 30 juillet 2014 à 22:29:06 »
Super, merci pour ta réponse :),

je vais tester le débit en UDP pour voir.

Oui j'ai les deux consoles de l'Iperf serveur et client sous le nez. J'ai bien activé l'option -u des deux cotés. (pas facile de débug un soucis chez soit quand on est a plus de 800km de son domicile lol)

Voila les captures Les nouvelles captures + traceroute

J'ai aussi testé le débit lorsque je passe par l'IP publique de mon Linux distant (ce qui me fait passer par la passerelle du datacenter. La capture est jointe.

J'ai fait 3 traceroute :

Windows Local --> Windows distant
Windows Local --> Linux distant (patte LAN)
Windows Local --> Linux distant (patte WAN)

EDIT : J'ai ajouter une capture, DL du fichier 20Mo.dat depuis le Linux distant vers un PC depuis une vraie connexion ADSL 14Mbps, histoire de comparer.

aller pour la route un petit Iperf depuis le Linux distant (VM dans un ESX) vers le serveur Iperf de lafibre.info
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 3.testdebit.info, TCP port 5001
TCP window size: 22.9 KByte (default)
------------------------------------------------------------
[  5] local 212.83.147.104 port 53580 connected with 89.84.127.55 port 5001
[ ID] Interval       Transfer     Bandwidth
[  5]  0.0- 2.0 sec   213 MBytes   894 Mbits/sec
[  5]  2.0- 4.0 sec   217 MBytes   910 Mbits/sec
[  5]  4.0- 6.0 sec   217 MBytes   912 Mbits/sec
[  5]  6.0- 8.0 sec   217 MBytes   910 Mbits/sec
[  5]  8.0-10.0 sec   218 MBytes   915 Mbits/sec
[  5] 10.0-12.0 sec   218 MBytes   915 Mbits/sec
[  5] 12.0-14.0 sec   218 MBytes   916 Mbits/sec
[  5] 14.0-16.0 sec   218 MBytes   915 Mbits/sec
[  5] 16.0-18.0 sec   218 MBytes   913 Mbits/sec
[  5] 18.0-20.0 sec   218 MBytes   915 Mbits/sec
[  5]  0.0-20.0 sec  2.12 GBytes   911 Mbits/sec
[  4] local 212.83.147.104 port 5001 connected with 89.84.127.55 port 57109
[  4]  0.0- 2.0 sec   203 MBytes   853 Mbits/sec
[  4]  2.0- 4.0 sec   215 MBytes   903 Mbits/sec
[  4]  4.0- 6.0 sec   215 MBytes   901 Mbits/sec
[  4]  6.0- 8.0 sec   218 MBytes   913 Mbits/sec
[  4]  8.0-10.0 sec   215 MBytes   904 Mbits/sec
[  4] 10.0-12.0 sec   216 MBytes   908 Mbits/sec
[  4] 12.0-14.0 sec   214 MBytes   899 Mbits/sec
[  4] 14.0-16.0 sec   216 MBytes   908 Mbits/sec
[  4] 16.0-18.0 sec   216 MBytes   907 Mbits/sec
[  4] 18.0-20.0 sec   215 MBytes   900 Mbits/sec
[  4]  0.0-20.0 sec  2.09 GBytes   899 Mbits/sec
« Modifié: 30 juillet 2014 à 23:22:50 par kaktuss77 »

kaktuss77

  • Client OVH
  • *
  • Messages: 341
  • OVH FTTH 1G/500M
    • @kaktuss77
VPN : Débit faible avec Windows, mais pas Linux
« Réponse #21 le: 03 septembre 2014 à 01:20:16 »
Hello tout le monde,

je pense que je vais me répondre tout seul concernant mon soucis de débit depuis ma machine Windows.

Je viens de voir lors de test de débit depuis lafibre.info que j'ai une fenêtre TCP de 8192, (au départ c'était pour trouver le meilleurs compromis MSS - MTU à travers les VPN OpenVPN (il semblerait que de forcé la MSS à 900 n'impact pas sur les performances, bien au contraire j'ai gagné sur mon cumule de débit (basé sur 10 tests) je suis en train de voir pour forcé un MTU a 1400 avec mon UTM, mais je pense que ca ne changera rien.

Bref quoi qu'il en soit, devant se TCPdump en ligne de commande (retour affichage sur l'écran) je décide de lancer un test depuis mon windows (pour voir si la MSS a jouer sur ce probleme) et la je vois un Windows size à 65834, je vais baisser la fenetre de mon client windows.

car j'ai cru comprendre qu'une grande taille de WinTCP + gros ping faisait pas bon ménage.
On vera bien :)

 

Mobile View