Auteur Sujet: 2 accès internet (livebox +Fibre sur même LAN): bridage débit réseau!  (Lu 479 fois)

0 Membres et 1 Invité sur ce sujet

nono50

  • Client K-Net
  • *
  • Messages: 62
  • TEILLEUL 50
Bonjour,
 
Il y a quelques mois, j'ai relié mes deux accès internet sur mon réseau gigabits.
 
J'ai procédé comme suit, désirant conserver un accès à mes périphériques connectés sur le même réseau.
 
routeur 2 : Accès VDSL2 LIVEBOX Play : j'ai conservé le dhcp (activé) 192.168.1.2 avec une plage d'adresses entre 192.168.1.3 et 192.168.1.99
routeur 1 : Accès Fibre optique 1gb Knet : dhcp activé 192.168.1.1 avec une plage d'adresses entre 192.168.1.100 et 192.168.1.254
 
Chacun relié en LAN.
 
Jusque là, ça fonctionnait : j'avais bien accès à mes périphériques sur tout le réseau (sur les 2 plages) : plusieurs Nas, caméras (sur wifi de la livebox), imprimante réseau. 
Chaque PC connecté l'étant sur le routeur 1 ou routeur 2 selon les cas (exemple: PCs des enfants sur le routeur 2 livebox avec gestion des plages horaires propres à la livebox d'Orange). 
 
Il y a quelques temps, en faisant un speedtest, je me suis aperçu que j'étais bridé à 100/100 (alors qu'auparavant sans avoir rien changé ni à ma config PC (connecté sur l'ip du routeur 1)).
 
J'ai d'abord pensé à un bridage d'un des switch puis à un problème de câblage.
 
J'ai procédé par élimination et je récupère mon 800/200 mb/s que lorsque je déconnecte ma livebox (ce débit est celui auquel je peux m'attendre théoriquement via knet et le réseau de mon département d'habitation (200 mbs sont réservés pour la TV)).
 
Si je rebranche celle-ci, je repasse aussitôt à 100/100... Je précise que le débit change sans que je modifie les paramètres de ma machine de test ni ne redémarre.
 
J'ai changé le câble livebox (au cas où avec plusieurs câbles qui laissent bien passer le gigabits lors de tests avec la box fibre), rien n'y fait (je précise que je n'ai pas changé de câble depuis mes essais d'il y a quelques mois).
 
Quelqu'un pourrait il m'aider dans ce problème qui semble provenir de la livebox ou d'un réglage qui a changé quelque part? 
 
Sinon, comment faire pour avoir les 2 accès internet indépendants sur le même réseau et éviter ce bridage?
 
Merci de votre aide.
 

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 874
  • Toulouse (31)
Si je comprends bien tu as deux serveurs DHCP sur le meme reseau ? si c'est le cas arrete en un.

Je te conseille de garder celui de l'acces le plus rapide, pour les ordis de tes enfants il faut mettre des IP fixes en mettant en passerelle l'ip de ta livebox

zoc

  • Client Orange Fibre
  • *
  • Messages: 2 179
  • Antibes (06)
Comme ça, a vu de nez, je dirais que quand la Livebox est connectée elle balance ses Router Advertisements pour IPv6 et du coup tous les postes font leur speedtest en IPv6 (et passent par la Livebox)...

M'enfin bon, la solution choisie pour faire du multi-wan n'est pas vraiment l'état de l'art en la matière, il ne faut donc pas s'étonner qu'à un moment ça "merdouille"...


nono50

  • Client K-Net
  • *
  • Messages: 62
  • TEILLEUL 50
REbonjour,
 
je me réponds à moi même car je crois avoir trouvé le bug:
 
En fait, dans mes paramètres, j'avais activé dans les propriétés l'ipv6 et comme seule la livebox travaille sur cette couche, c'est apparemment celle-ci qui l'emportait en se positionnant sur le LAN commun.. 
 
Je l'ai désactivé sur ma machine et le débit reste stable (plus proche des 800mbs que du 90mbs...
 
J'espère qu'il s'agissait bien de cela. 
 
Je suis étonné que le ipv6 ait été coché entre-temps car je n'ai pas le souvenir de cela.

@ tivoli: merci de ta réponse. C'est en effet une variante qui pourrait être intéressante.

nono50

  • Client K-Net
  • *
  • Messages: 62
  • TEILLEUL 50
Comme ça, a vu de nez, je dirais que quand la Livebox est connectée elle balance ses Router Advertisements pour IPv6 et du coup tous les postes font leur speedtest en IPv6 (et passent par la Livebox)...

M'enfin bon, la solution choisie pour faire du multi-wan n'est pas vraiment l'état de l'art en la matière, il ne faut donc pas s'étonner qu'à un moment ça "merdouille"...

A priori, tu as vu juste car comme je l'écrivais ci-dessus, c'est en otant l'ipv6 que j'ai solutionné ce probleme.

Hugues

  • AS57199 MilkyWan
  • Expert
  • *
  • Messages: 6 323
  • Lyon & Paris
    • MilkyWan
Je l'ai désactivé sur ma machine et le débit reste stable (plus proche des 800mbs que du 90mbs...
Pfff... Faut pas couper IPv6... Ni avoir 2 DHCP/Routeurs avec RA dans le même LAN...

nono50

  • Client K-Net
  • *
  • Messages: 62
  • TEILLEUL 50
Je ne savais pas qu'ipv6 était indispensable.

Concernant les deux routeurs, je dois avouer que c'est la solution que j'ai trouvé et qui a fonctionné quand je me suis intéressé au probleme (arrivée de la fibre en conservant la livebox).

Promis, un jour je ferai cela propre ;)

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 232
Si tu as un vieux PC qui traîne et 3 cartes réseaux, tu peux t'amuser avec pfsense à faire du multi-wan "intelligent" càd soit du load balancing soit du failover (on réparti entre les deux ou l'un prend le relais de l'autre en cas de panne). Par contre pas sûr que ça tienne les débit si le matériel est un peu âgé (genre un pentium 4 on oublie, un core i3 est à mon avis le minimum)

Un exemple de config : https://www.provya.net/?d=2017/11/24/11/31/31-pfsense-configurer-un-dual-wan-plusieurs-connexions-internet

Il y aussi la solution MPTCP (MultipathTCP), qui agrège les débits, mais c'est beaucoup plus difficile à mettre en place (faut aimer bidouiller les lignes de commandes) et c'est encore au stade "beta" via OpenMPTCProuter mais bon avec presque le gigabit atteint sur la fibre k-net, ça sert pas à grand chose ou alors il faudrait un LAN en 10 Gbps pour pourvoir réellement en profiter. Par contre niveau prix... faut vraiment en avoir envie  ;D

doctorrock

  • Client Orange Fibre
  • *
  • Messages: 161
  • Courbevoie 92
Original comme installation je dois dire  ;D

En mode propre, ca donne simplement 2 VLANs avec une passerelle chacun et un bon routeur au milieu du tout avec une patte dans chaque réseau.

 

Mobile View