Auteur Sujet: MDS: Nouvelle vague de vulnérabilités d'exécution spéculative dans les CPU Intel  (Lu 6521 fois)

0 Membres et 1 Invité sur ce sujet

galixte

  • Client Free vdsl
  • *
  • Messages: 4
  • VDSL 40 Mb/s | Marseille 13, La Plaine
    • Communauté EzCom
J’ai partagé des informations utiles pour suivre l’avancement de la parution des nouveaux microcodes et sur l’impact sur certaines performances causées par l’installation de ces mesures de prévention : https://lafibre.info/serveurs/mises-a-jour-des-microcodes-intel-et-amd/msg763239/#msg763239;

vivien

  • Administrateur
  • *
  • Messages: 37 332
    • Twitter LaFibre.info
Nouvelle mise à jour des microcode Intel sous Ubuntu

Découverte en janvier 2020, la vulnérabilité CacheOut - également connue en tant que L1D Eviction Sampling - a évolué en SGAxe pour briser les extensions de sécurité des processeurs Intel permettant de faire tourner des applications dans des enclaves. Les processeurs Intel de 9e génération Coffee Lake Refresh sont notamment affectés.



- CVE-2020-0543 : Il a été découvert que le contenu de la mémoire précédemment stocké dans des registres spéciaux microarchitecturaux après les opérations de lecture RDRAND, RDSEED et SGX EGETKEY sur le client Intel et les processeurs Xeon E3 peut être brièvement exposé à des processus sur le même ou des cœurs de processeur différents. Un attaquant local pourrait l'utiliser pour exposer des informations sensibles.

- CVE-2020-0548 : Il a été découvert que sur certains processeurs Intel, des valeurs partielles de données précédemment lues à partir d'un registre vectoriel sur un noyau physique peuvent être propagées dans des parties inutilisées du tampon de stockage. Un attaquant local pourrait éventuellement l'utiliser pour exposer des informations sensibles.

- CVE-2020-0549 : Il a été découvert que sur certains processeurs Intel, les données de la ligne de cache de données L1 modifiée (L1D) peut être propagées dans un tampon de remplissage L1D inutilisé (non valide). Un attaquant local pourrait éventuellement l'utiliser pour exposer des informations sensibles.



Version 3.20200609.0ubuntu0.20.04.0 :

  * SECURITY UPDATE: New upstream microcode datafile 2020-06-09
    (includes updates from 2020-05-08 and 2020-05-20)
    + Updated Microcodes:
      sig 0x000206d6, pf_mask 0x6d, 2020-03-04, rev 0x0621, size 18432
      sig 0x000206d7, pf_mask 0x6d, 2020-03-24, rev 0x071a, size 19456
      sig 0x000306c3, pf_mask 0x32, 2019-11-12, rev 0x0028, size 23552
      sig 0x000306d4, pf_mask 0xc0, 2019-11-12, rev 0x002f, size 19456
      sig 0x00040651, pf_mask 0x72, 2019-11-12, rev 0x0026, size 22528
      sig 0x00040661, pf_mask 0x32, 2019-11-12, rev 0x001c, size 25600
      sig 0x00040671, pf_mask 0x22, 2019-11-12, rev 0x0022, size 14336
      sig 0x000406e3, pf_mask 0xc0, 2020-04-27, rev 0x00dc, size 104448
      sig 0x00050653, pf_mask 0x97, 2020-04-24, rev 0x1000157, size 32768
      sig 0x00050654, pf_mask 0xb7, 2020-04-24, rev 0x2006906, size 34816
      sig 0x00050656, pf_mask 0xbf, 2020-04-23, rev 0x4002f01, size 52224
      sig 0x00050657, pf_mask 0xbf, 2020-04-23, rev 0x5002f01, size 52224
      sig 0x000506e3, pf_mask 0x36, 2020-04-27, rev 0x00dc, size 104448
      sig 0x000706e5, pf_mask 0x80, 2020-03-12, rev 0x0078, size 107520
      sig 0x000806e9, pf_mask 0x10, 2020-04-27, rev 0x00d6, size 103424
      sig 0x000806e9, pf_mask 0xc0, 2020-04-27, rev 0x00d6, size 103424
      sig 0x000806ea, pf_mask 0xc0, 2020-04-27, rev 0x00d6, size 103424
      sig 0x000806eb, pf_mask 0xd0, 2020-04-27, rev 0x00d6, size 103424
      sig 0x000806ec, pf_mask 0x94, 2020-04-23, rev 0x00d6, size 103424
      sig 0x000906e9, pf_mask 0x2a, 2020-04-23, rev 0x00d6, size 103424
      sig 0x000906ea, pf_mask 0x22, 2020-04-27, rev 0x00d6, size 102400
      sig 0x000906eb, pf_mask 0x02, 2020-04-23, rev 0x00d6, size 103424
      sig 0x000906ec, pf_mask 0x22, 2020-04-27, rev 0x00d6, size 102400
      sig 0x000906ed, pf_mask 0x22, 2020-04-23, rev 0x00d6, size 103424
    - CVE-2020-0543 Special Register Buffer Data Sampling (SRBDS), INTEL-SA-00320
    - CVE-2020-0548 Vector Register Sampling, INTEL-SA-00329
    - CVE-2020-0549 L1D Eviction Sampling, INTEL-SA-00329
    - Microcode fixes include update for 0x00050654 to address lockups on certain Skylake processors (LP: #1854764)
  * Remaining changes:
    - Ship tmpfiles.d snippet to attempt late loading of microcode during boot, in case early loading of microcode did not happen. Early microcode loading might not happen if booting without initramfs or a missbuilt one.
    - debian/initramfs.hook: Do not override preset defaults from auto-exported conf snippets loaded by initramfs-tools.

Marco POLO

  • Client Free fibre
  • *
  • Messages: 2 242
  • FTTH 1 Gb/s sur Paris (75)
Nouvelle mise à jour des microcode Intel sous Ubuntu

Version 3.20200609.0ubuntu0.20.04.0 :...
Salut Vivien,
Et pour Windows ? 

alain_p

  • Client Free fibre
  • *
  • Messages: 11 345
  • Delta S 10G-EPON sur Les Ulis (91)
Cela me rappelle une violente réaction de Linus Torvalds au sujet d'un patch venant d'AWS pour réparer une faille des CPU Intel, concernant la virtualisation, 'CPU Snoop Attack', qu'il a déclaré "plus que stupide" parce que ce patch serait susceptible de dégrader les performances pour toutes les applications :

Citer
Linus Torvalds rejects 'beyond stupid' AWS-made Linux patch for Intel CPU Snoop attack

Linux kernel developers debate a controversial patch to address potential leaks of secrets from a CPU's cores
...
But, as spotted by Phoronix, Torvalds believes the patch will allow applications that opt in to the patch to degrade CPU performance for other applications.

https://www.zdnet.com/article/linus-torvalds-rejects-stupid-aws-made-linux-patch-for-intel-cpu-snoop-attack/
https://www.phoronix.com/scan.php?page=news_item&px=Linux-Blasts-L1d-Flushing

 

Mobile View