Auteur Sujet: débit en local assez faible  (Lu 4423 fois)

0 Membres et 1 Invité sur ce sujet

vivien

  • Administrateur
  • *
  • Messages: 32 817
    • Twitter LaFibre.info
débit en local assez faible
« Réponse #12 le: 25 juin 2014 à 07:42:38 »
Voici les tests que j'ai fait avec mon Celeron 600 Mhz alors que j'ai déjà téléchargé le fichier une premier fois pour qu'il soit en cache disque :

$ wget -O /dev/null http://192.168.1.29/1000Mo.dat
100%[======================================>] 125 000 000 37,0M/s   ds 3,2s   
2012-05-28 12:27:20 (37,0 MB/s) - «/dev/null» sauvegardé [125000000/125000000]
=> 37,0 Mio/s de moyenne soit 326 Mb/s

Il faudrait faire le test sur un petit fichier (max 1/3 de la ram de ton PC) afin de voir si le débirt est meilleur une fois qu'il est dans le cache disque.
Là je passe par la carre réseau et il est probable que ce soit le bus PCI qui limite mon débit. la commande linux lspci devrait te permettre de voir si la carte Ethernet intégrée est sur bus PCI ou PCI-express.

Avec un Pentium IV qui a une carte Ethernet 1Gb/s intégrée sur bus PCI-Express, j'arrive à 1 Gb/s sans aucun souci.

Journée Nostalgie : J'ai remis en service le premier serveur qui hébergeait ce forum en 2007.

J'ai profité de ce lundi de pentecôte pour pour sortir mes vieilleries.

Sur la table un PC Compaq Pentium 200 Mhz MMX ouvert (dopé avec une barrette de 32 Mo de ram et 2 barrette des 16 Mo) qui est au dessus d'un Pentium II plus petit fermé.
Au second plan l'ancien serveur de ce forum (mini-tour ouverte).
Au fond mon PC habituel (seul l'écran est visible)
Par terre des cartes diverses et des disques dur (à partir de 20 Mo le disque dur, pas d'erreur c'est bien 20 Mo, l'équivalent de 56 disquettes de 360ko  ;D )



Les caractéristiques de ce serveur !
- CPU : Celeron 600 Mhz (Socket 370 - génération pentium III)
- Ram : 512 Mo (168-pin DIMM sockets)
- Disque dur : 40 Go ide
- Carte mère MSI 2000 "815E PRO"
    - Intel® 815E (544BGA) Chipset (AGP 4x/2x universal slot, Supports 66/100/133MHz FSB)
    - Intel® ICH2 (241BGA) Chipset (AC'97 Controller Integrated, 2 full IDE channels, up to ATA100, Low pin count interface for SIO)
    - PCI 2.2 32-bit Master PCI Bus slots.
    - IDE controller on the ICH2 chipset provides IDE HDD/CD-ROM with PIO, Bus Master and Ultra DMA 66 / 100 operation modes.

Mon serveur en situation en 2007 dans le POP rue Cauchy (Paris 15ème) de citéFibre, avec une connexion 100 Mb/s symétrique à l'époque  :


J'ai juste remplacé la carte Ethernet 100 Mb/s par une carte 1 Gb/s (SMC 9452TX) et connexion sur mon réseau local via un switch 1 Gb/s.


Ubuntu server 12.04 (2012) + Apache 2.2
Un système d'exploitation de 2012 sur une machine de 12ans d'age !


Installation neuve d'Ubuntu serveur 12.04 (noyau 3.2) avec Apache 2.2.22 (mode Worker, je n'ai pas mis PHP)
Depuis un autre PC je télécharge mes fichiers de test.

Test du 1er téléchargement du fichier de 1Gb soit 119,21 Mio :

$ wget -O /dev/null http://192.168.1.29/1000Mo.dat
100%[======================================>] 125 000 000 28,3M/s   ds 4,3s   
2012-05-28 12:27:03 (27,8 MB/s) - «/dev/null» sauvegardé [125000000/125000000]
=> 27,8 Mio/s de moyenne soit 245 Mb/s

2ème téléchargement (fichier en cache disque) :

$ wget -O /dev/null http://192.168.1.29/1000Mo.dat
100%[======================================>] 125 000 000 37,0M/s   ds 3,2s   
2012-05-28 12:27:20 (37,0 MB/s) - «/dev/null» sauvegardé [125000000/125000000]
=> 37,0 Mio/s de moyenne soit 326 Mb/s

Test du 1er téléchargement du fichier de 10 Gb soit 1192,1 Mio :

$ wget -O /dev/null http://192.168.1.29/1000Mo.dat
100%[====================================>] 1 250 000 000 27,9M/s   ds 43s     
2012-05-28 12:28:27 (27,8 MB/s) - «/dev/null» sauvegardé [1250000000/1250000000]
=> 27,8 Mio/s de moyenne soit 245 Mb/s.

Test de débit avec IPERF :
(en premier mon PC envoie vers mon serveur et ensuite les rôles sont inversés)
$ iperf -c 192.168.1.29 -i 2 -r
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 85.3 KByte (default)
------------------------------------------------------------
------------------------------------------------------------
Client connecting to 192.168.1.29, TCP port 5001
TCP window size:  113 KByte (default)
------------------------------------------------------------
[  5] local 192.168.1.62 port 59800 connected with 192.168.1.29 port 5001
[ ID] Interval       Transfer     Bandwidth
[  5]  0.0- 2.0 sec  73.8 MBytes   309 Mbits/sec
[  5]  2.0- 4.0 sec  74.9 MBytes   314 Mbits/sec
[  5]  4.0- 6.0 sec  75.0 MBytes   315 Mbits/sec
[  5]  6.0- 8.0 sec  74.1 MBytes   311 Mbits/sec
[  5]  8.0-10.0 sec  74.6 MBytes   313 Mbits/sec
[  5]  0.0-10.0 sec   372 MBytes   312 Mbits/sec
[  4] local 192.168.1.62 port 5001 connected with 192.168.1.29 port 46597
[  4]  0.0- 2.0 sec  61.1 MBytes   256 Mbits/sec
[  4]  2.0- 4.0 sec  61.5 MBytes   258 Mbits/sec
[  4]  4.0- 6.0 sec  61.5 MBytes   258 Mbits/sec
[  4]  6.0- 8.0 sec  61.2 MBytes   257 Mbits/sec
[  4]  8.0-10.0 sec  61.1 MBytes   256 Mbits/sec
[  4]  0.0-10.0 sec   306 MBytes   257 Mbits/sec


=> Je suis étonné des très bonnes performances de ce disque dur de 40 Go IDE récupéré sur un PC premier prix acheté en supermarché.
Je n'aurais jamais imaginé un tel débit en usage réel.

=> Apache2 a un débit supérieur à IPERF en émission (326 Mb/s pour IPERF contre 257 Mb/s pour IPERF) alors que IPERF ne fait qu'envoyer des paquets remplis de "0000000000000000000" et apache envoie un vrai fichier qu'il va récupérer sur le cache disque.


Ralph

  • Client Bbox adsl
  • *
  • Messages: 295
  • Ex-FTTH 1Gb/s Lille, ADSL 2Mb/s Wervicq-sud
débit en local assez faible
« Réponse #13 le: 25 juin 2014 à 09:25:04 »
Juste au passage, j'ai on arrive largement à gérer des débits entrants + sortant de l'ordre d'un gigabit avec le P4, je le faisais avec des F500-6 il y a presque 10 ans... Reste que la CM est de meilleure qualité que la plupart des CM grand public (PCI-X entre autre).

jeremyp3

  • Pau Broadband Country (64)
  • Client Orange Fibre
  • *
  • Messages: 439
  • FTTH 1Gb/s sur Pau (64)
débit en local assez faible
« Réponse #14 le: 30 juin 2014 à 16:49:30 »
bonjour,

petite question anex, pour savoir ce que vous en pensez, j'utilise openvpn avec du tls et j'ai l'impréssion que mon petit pentiom 4 a du mal a décripter le tls parce que je gagne 2 MO/s facilement sans sécurité, qu'avec du tls a 1024 byte ça dois  être

jerem

 

Mobile View