Auteur Sujet: load average du serveur lafibre.info : +2 (causes de I/O inconnues)  (Lu 6126 fois)

0 Membres et 1 Invité sur ce sujet

vivien

  • Administrateur
  • *
  • Messages: 29 672
    • Twitter LaFibre.info
Depuis presque une semaine, la charge du serveur LaFibre.info est passée de 0,4 à 2,4



J'ai cherché mais l'utilisation du CPU, du disque ou de la carte réseau n'a pas bougé.
J'ai pensé à un process bloqué mais vmstats indique :
r: Nombre de processus en compétition pour le temps CPU. => 1
b: Nombre de processus dormants. => 0
bi: Blocs lus par seconde sur des périphériques orientés bloc. => 3
bo: Blocs écrits par seconde sur des périphériques orientés bloc => 16

Donc la cause du load average semble être lié bo de 16


# vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 1  0  14288 330984 333880 14494236    0    0     3    16    0    0  3  0 97  0  0


Concrètement je n'arrive pas a savoir ce que c'est que ces 16 bloc écrits chaque seconde.

Voici d'autres stats qui elles n'ont pas bougées :

Le disque dur :


Le CPU :


La carte réseau :


La mémoire :


Apache2 :

Optix

  • AS203679 NEWSOO
  • Expert
  • *
  • Messages: 689
  • Strasbourg (67)
    • Newsoo
load average du serveur lafibre.info : +2 a cause de I/O inconnues
« Réponse #1 le: 02 mai 2016 à 22:48:35 »
Que donne un :
# swapoff -a

?

PhilippeMarques

  • Expert
  • *
  • Messages: 859
  • SomeWhere
load average du serveur lafibre.info : +2 a cause de I/O inconnues
« Réponse #2 le: 03 mai 2016 à 00:09:46 »
Le swap est une piste, mais essaye de regarder tout ce qui en Avg > Cur.

vivien

  • Administrateur
  • *
  • Messages: 29 672
    • Twitter LaFibre.info
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #3 le: 03 mai 2016 à 09:14:31 »
J'ai fais un reboot et...



Il a refusé de redémarer, ce qui explique la coupure de ce matin.

Il répondait toujours au ping : les deux process bloquaient le redémarrage du serveur et comme tous les autres services avaient déja été coupés, Lionel a du faire un reboot hard du serveur...

Merci à lui.

Pour le swap, je monitor la chose, c'est pas la cause de load average élevé :

vivien

  • Administrateur
  • *
  • Messages: 29 672
    • Twitter LaFibre.info
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #4 le: 03 mai 2016 à 09:26:55 »
Plus de problème de Load average après le reboot :

$ uptime
 09:24:18 up 15 min,  1 user,  load average: 0,27, 0,46, 0,50

# vmstat
procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 1  0      0 15066712  82056 672004    0    0    95    15   92  236  3  0 94  3  0


bi / bo sont élevés, mais après un reboot, il faut faire pas mal d’accès disque pour toutes les demandes (plus tard elle seront dans le cache vu que le serveur est bien doté en ram)

Hugues

  • AS57199 MilkyWan
  • Expert
  • *
  • Messages: 6 535
  • Paris (15ème)
    • MilkyWan
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #5 le: 03 mai 2016 à 09:30:38 »
Tu l'as mis à jour sur Ubuntu 16.04 Server au fait ?

vivien

  • Administrateur
  • *
  • Messages: 29 672
    • Twitter LaFibre.info
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #6 le: 03 mai 2016 à 09:37:37 »
Non, car SMF n'est pas compatible PHP 7. (et il aurait été compatible j'aurais un peu attendu)

La charge a brutalement augmenté le lundi 25 avril vers 11h30. Je ne m'étais pas connecté au serveur le jour même ou les jours précédents.

Ma précédente connexion datait du 21 avril pour faire un traceroute : Transit entre Orange et NETPLEX

petrus

  • Expert AS206155
  • Expert
  • *
  • Messages: 807
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #7 le: 03 mai 2016 à 13:55:18 »
regarde du coté de perf(1) si tu peux trouver des pistes pour savoir d'où ça vient.

Le blog de Brendan Gregg sur le sujet est très bien : http://www.brendangregg.com/perf.html.

Il y a également http://www.brendangregg.com/linuxperf.html.


vivien

  • Administrateur
  • *
  • Messages: 29 672
    • Twitter LaFibre.info
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #8 le: 03 mai 2016 à 15:39:56 »
Merci, si le problème se reproduit, je ferais plus attention...

Le load avrage est repassé à 0,4 :

jack

  • Professionnel des télécoms
  • *
  • Messages: 1 564
  • La Madeleine (59)
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #9 le: 03 mai 2016 à 16:18:48 »
Supprime le swap, ce n'est pas ton ami

mirtouf

  • Client Bbox fibre FTTH
  • *
  • Messages: 531
  • FTTH (ByTel) sur Chelles (77)
    • L'antre de la bête
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #10 le: 03 mai 2016 à 17:22:26 »
Tout de suite les grands remèdes !  ::)

Hugues

  • AS57199 MilkyWan
  • Expert
  • *
  • Messages: 6 535
  • Paris (15ème)
    • MilkyWan
load average du serveur lafibre.info : +2 (causes de I/O inconnues)
« Réponse #11 le: 03 mai 2016 à 19:46:05 »
On se raconte que le Swap mange des bébés chatons la nuit et s'autoradicalise.  ::) ::)

 

Mobile View