Auteur Sujet: Problème avec un ERL  (Lu 628 fois)

0 Membres et 1 Invité sur ce sujet

Vampire142

  • Client Orange vdsl
  • *
  • Messages: 16
  • Altkirch (68)
Problème avec un ERL
« le: 23 avril 2017 à 12:33:27 »
Bonjour, je poste un message à la va vite, j'écris depuis mon téléphone portable, du fait que mon ERL me crée des soucis...

En effet donc j'avais configurer le routeur fraîchement arrivé comme suit :

Eth0 WAN 192.168.2.2/24 avec une livebox (192.168.2.1)
Eth1 DMZ  192.168.0.1/24
Eth2 LAN  192.168.1.1/24 avec un hotspot pour de la wifi ac (193.168.1.250)

La livebox étant configurer pour considérer L'ERL comme une DMZ.

Donc jusqu'ici tout fonctionnait quand tout à coup hier soir en plein milieu d'une conversation skype plus d'Internet...

Je regarde tout le système box n'a pas crash et mon routeur aussi, mais cependant la box ne voit plus l'ERL et dans son interface il apparaît comme déconnecté...

Je redémarre la box et le routeur... Toujours rien, je branche un câble sur le routeur (port eth0 vers la box) et j'essaye de me connecter au routeur depuis ce port, pas de réponse, ni sur l'interface web, ssh ou même ping... Mais depuis un PC connecté sur eth2 je peux voir distinctement sur l'interface web si le câble est branché ou non, donc je doute d'un défaut matériel...

Puis, après 2 heures en ayant quasiment abandonné, tout refonctionne sans dire pourquoi ni comment...

Mais depuis ce matin au réveil... Le problème est revenu et persiste.

Avez vous une idée/solution ?

(Si sa peut être utile je suis sur la mise à jour 1.9.1 de EdgeOS)
« Modifié: 23 avril 2017 à 14:07:40 par Vampire142 »

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 868
  • Toulouse (31)
Problème avec un ERL
« Réponse #1 le: 23 avril 2017 à 12:38:04 »
Connecte toi en ssh et fais un show log
poste le contenu on verra peut etre quelquechose

Les ERL ont la facheuse tendance à  avoir la cle usb interne qui tombe en panne

Vampire142

  • Client Orange vdsl
  • *
  • Messages: 16
  • Altkirch (68)
Problème avec un ERL
« Réponse #2 le: 23 avril 2017 à 13:33:45 »
Cette clef fonctionne, du moins, apparemment normalement je l'ai déjà tester avec fsck sous Linux et reflasher avec un logiciel de flash fait pour, mais voici tout de même le log :

Welcome to EdgeOS

By logging in, accessing, or using the Ubiquiti product, you
acknowledge that you have read and understood the Ubiquiti
License Agreement (available in the Web UI at, by default,
http://192.168.1.1) and agree to be bound by its terms.

Linux ERL3 3.10.20-UBNT #1 SMP Fri Dec 2 02:30:08 PST 2016 mips64
Welcome to EdgeOS
Last login: Sun Apr 23 09:59:17 2017 from 192.168.1.2
Vampire142@ubnt:~$ show log
Apr 23 11:54:18 ERL3 rsyslogd: set SCM_CREDENTIALS failed on '/dev/log': Protocol not available
Apr 23 11:54:18 ERL3 kernel: Linux version 3.10.20-UBNT (root@ubnt-builder2) (gcc version 4.7.0 (Cavium Inc. Version: SDK_3_1_0_p2 build 34) ) #1 SMP Fri Dec 2 02:30:08 PST 2016
Apr 23 11:54:18 ERL3 kernel: CVMSEG size: 2 cache lines (256 bytes)
Apr 23 11:54:18 ERL3 kernel: Checking for the multiply/shift bug... no.
Apr 23 11:54:18 ERL3 kernel: Checking for the daddiu bug... no.
Apr 23 11:54:18 ERL3 kernel: Zone ranges:
Apr 23 11:54:18 ERL3 kernel:  DMA32    [mem 0x00400000-0xefffffff]
Apr 23 11:54:18 ERL3 kernel:  Normal   [mem 0xf0000000-0x41fbfffff]
Apr 23 11:54:18 ERL3 kernel: Movable zone start for each node
Apr 23 11:54:18 ERL3 kernel: Early memory node ranges
Apr 23 11:54:18 ERL3 kernel:  node   0: [mem 0x00400000-0x00a8ffff]
Apr 23 11:54:18 ERL3 kernel:  node   0: [mem 0x00c00000-0x07ffffff]
Apr 23 11:54:18 ERL3 kernel:  node   0: [mem 0x08200000-0x0fdfffff]
Apr 23 11:54:18 ERL3 kernel:  node   0: [mem 0x410000000-0x41fbfffff]
Apr 23 11:54:18 ERL3 kernel: Primary instruction cache 32kB, virtually tagged, 4 way, 64 sets, linesize 128 bytes.
Apr 23 11:54:18 ERL3 kernel: Primary data cache 16kB, 64-way, 2 sets, linesize 128 bytes.
Apr 23 11:54:18 ERL3 kernel: Secondary unified cache 128kB, 8-way, 128 sets, linesize 128 bytes.
Apr 23 11:54:18 ERL3 kernel: Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 125887
Apr 23 11:54:18 ERL3 kernel: Kernel command line:  bootoctlinux $loadaddr coremask=0x3 root=/dev/sda2 rootdelay=15 rw rootsqimg=squashfs.img rootsqwdir=w mtdparts=phys_mapped_flash:512k(boot0),512k(boot1),64k@1024k(eeprom) console=ttyS0,115200
Apr 23 11:54:18 ERL3 kernel: Checking for the daddi bug... no.
Apr 23 11:54:18 ERL3 kernel: SCSI subsystem initialized
Apr 23 11:54:18 ERL3 kernel: octeon_pci_console: Console not created.
Apr 23 11:54:18 ERL3 kernel: /proc/octeon_perf: Octeon performance counter interface loaded
Apr 23 11:54:18 ERL3 kernel: Bootbus flash: Setting flash for 4MB flash at 0x1f800000
Apr 23 11:54:18 ERL3 kernel: phys_mapped_flash: Swapping erase regions for top-boot CFI table.
Apr 23 11:54:18 ERL3 kernel: number of CFI chips: 1
Apr 23 11:54:18 ERL3 kernel: 3 cmdlinepart partitions found on MTD device phys_mapped_flash
Apr 23 11:54:18 ERL3 kernel: Creating 3 MTD partitions on "phys_mapped_flash":
Apr 23 11:54:18 ERL3 kernel: 0x000000000000-0x000000080000 : "boot0"
Apr 23 11:54:18 ERL3 kernel: 0x000000080000-0x000000100000 : "boot1"
Apr 23 11:54:18 ERL3 kernel: 0x000000100000-0x000000110000 : "eeprom"
Apr 23 11:54:18 ERL3 kernel: scsi 0:0:0:0: Direct-Access              USB DISK 2.0     PMAP PQ: 0 ANSI: 6
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] 7831552 512-byte logical blocks: (4.00 GB/3.73 GiB)
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] Write Protect is off
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] No Caching mode page found
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] No Caching mode page found
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] No Caching mode page found
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
Apr 23 11:54:18 ERL3 kernel: sd 0:0:0:0: [sda] Attached SCSI removable disk
Apr 23 11:54:18 ERL3 kernel: Algorithmics/MIPS FPU Emulator v1.5
Apr 23 11:54:18 ERL3 kernel: ubnt_platform: module license 'Proprietary' taints kernel.
Apr 23 11:54:18 ERL3 kernel: Disabling lock debugging due to kernel taint
Apr 23 11:54:18 ERL3 kernel: octeon-ethernet 2.0
Apr 23 11:54:18 ERL3 kernel: Interface 0 has 3 ports (RGMII)
Apr 23 11:54:18 ERL3 NSM[582]:  NSM-6: Initializing memdbg: ptr=0x6929d4 history-size=1024 memdbg-size=143552
Apr 23 11:54:18 ERL3 RIB[585]:  RIB-6: Initializing memdbg: ptr=0x586a04 history-size=1024 memdbg-size=143552
Apr 23 11:54:19 ERL3 NSM[583]:  NSM-6: 1000 MB
Apr 23 11:54:19  NSM[583]: last message repeated 2 times
Apr 23 11:54:19 ERL3 NSM[583]:  NSM-4: Could not create VRF table with identifier 1 in the MPLS Forwarder
Apr 23 11:54:19 ERL3 RIB[586]:  RIB-6: RIBd (1.2.0) starts
Apr 23 11:54:19 ERL3 kernel: ip_set: protocol 6
Apr 23 11:54:21 ERL3 rl-system.init: Checking/creating SSH host keys.
Apr 23 11:54:23 ERL3 IMI[580]:  IMI-6: imi_server_send_config called (PM 42)
Apr 23 11:54:24 ERL3 IMI[580]:  IMI-6: imi_server_send_config called (PM 1)
Apr 23 11:54:26 ubnt rsyslogd: set SCM_CREDENTIALS failed on '/dev/log': Protocol not available
Apr 23 09:54:26 ubnt rsyslogd: set SCM_CREDENTIALS failed on '/dev/log': Protocol not available
Apr 23 09:54:41 ubnt kernel: eth0: 1000 Mbps Full duplex, port 0
Apr 23 09:54:46 ubnt kernel: eth2: 1000 Mbps Full duplex, port 2
Apr 23 09:54:50 ubnt kernel: eth1: 1000 Mbps Full duplex, port 1
Apr 23 09:54:57 ubnt ntpd[1290]: ntpd 4.2.6p2@1.2194-o Fri Jul 29 23:29:38 UTC 2016 (1)
Apr 23 09:54:57 ubnt ntpd[1291]: proto: precision = 48.422 usec
Apr 23 09:54:58 ubnt ntpd[1291]: ntpd exiting on signal 15
Apr 23 09:55:00 ubnt ntpd[1345]: ntpd 4.2.6p2@1.2194-o Fri Jul 29 23:29:38 UTC 2016 (1)
Apr 23 09:55:00 ubnt ntpd[1346]: proto: precision = 47.901 usec
Apr 23 09:55:02 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 09:55:02 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 09:55:02 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 09:55:02 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 09:55:07 ubnt dhcpd:
Apr 23 09:55:07 ubnt dhcpd: No subnet declaration for eth0 (192.168.2.2).
Apr 23 09:55:07 ubnt dhcpd: ** Ignoring requests on eth0.  If this is not what
Apr 23 09:55:07 ubnt dhcpd:    you want, please write a subnet declaration
Apr 23 09:55:07 ubnt dhcpd:    in your dhcpd.conf file for the network segment
Apr 23 09:55:07 ubnt dhcpd:    to which interface eth0 is attached. **
Apr 23 09:55:07 ubnt dhcpd:
Apr 23 09:56:24 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 09:56:44 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 09:57:04 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 09:57:24 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 09:57:39 ubnt dhcpd: WARNING: Host declarations are global.  They are not limited to the scope you declared them in.
Apr 23 09:57:39 ubnt dhcpd:
Apr 23 09:57:39 ubnt dhcpd: No subnet declaration for eth0 (192.168.2.2).
Apr 23 09:57:39 ubnt dhcpd: ** Ignoring requests on eth0.  If this is not what
Apr 23 09:57:39 ubnt dhcpd:    you want, please write a subnet declaration
Apr 23 09:57:39 ubnt dhcpd:    in your dhcpd.conf file for the network segment
Apr 23 09:57:39 ubnt dhcpd:    to which interface eth0 is attached. **
Apr 23 09:57:39 ubnt dhcpd:
Apr 23 09:58:41 ubnt dhcpd: WARNING: Host declarations are global.  They are not limited to the scope you declared them in.
Apr 23 09:58:41 ubnt dhcpd:
Apr 23 09:58:41 ubnt dhcpd: No subnet declaration for eth0 (192.168.2.2).
Apr 23 09:58:41 ubnt dhcpd: ** Ignoring requests on eth0.  If this is not what
Apr 23 09:58:41 ubnt dhcpd:    you want, please write a subnet declaration
Apr 23 09:58:41 ubnt dhcpd:    in your dhcpd.conf file for the network segment
Apr 23 09:58:41 ubnt dhcpd:    to which interface eth0 is attached. **
Apr 23 09:58:41 ubnt dhcpd:
Apr 23 09:59:05 ubnt kernel: eth0: Link down
Apr 23 09:59:26 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 09:59:26 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 09:59:26 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 09:59:26 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 10:03:28 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 10:03:28 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 10:03:28 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 10:03:28 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 10:11:31 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 10:11:31 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 10:11:31 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 10:11:31 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 10:16:42 ubnt kernel: eth0: 1000 Mbps Full duplex, port 0
Apr 23 10:17:07 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 10:17:27 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 10:17:47 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 10:18:07 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 10:34:30 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 10:34:50 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 10:35:10 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 10:35:30 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 10:51:53 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 10:52:13 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 10:52:33 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 10:52:53 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 11:09:16 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 11:09:36 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 11:09:56 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 11:10:16 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Apr 23 11:26:39 ubnt ntpd_intres[1349]: host name not found: 0.ubnt.pool.ntp.org
Apr 23 11:26:59 ubnt ntpd_intres[1349]: host name not found: 1.ubnt.pool.ntp.org
Apr 23 11:27:19 ubnt ntpd_intres[1349]: host name not found: 2.ubnt.pool.ntp.org
Apr 23 11:27:39 ubnt ntpd_intres[1349]: host name not found: 3.ubnt.pool.ntp.org
Vampire142@ubnt:~$

Et voici mon fichier config.boot (sans l'identifiant et le MDP  ;) ) :
firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-name WANv6_IN {
        default-action drop
        description "WAN inbound traffic forwarded to LAN"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    ipv6-name WANv6_LOCAL {
        default-action drop
        description "WAN inbound traffic to the router"
        enable-default-log
        rule 10 {
            action accept
            description "Allow established/related sessions"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
        rule 30 {
            action accept
            description "Allow IPv6 icmp"
            protocol ipv6-icmp
        }
        rule 40 {
            action accept
            description "allow dhcpv6"
            destination {
                port 546
            }
            protocol udp
            source {
                port 547
            }
        }
    }
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable
    name WAN_IN {
        default-action drop
        description "WAN to internal"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address 192.168.2.2/24
        description WAN
        dhcpv6-pd {
            pd 0 {
                interface eth1 {
                    host-address ::1
                    prefix-id :1
                    service slaac
                }
                interface eth2 {
                    host-address ::1
                    prefix-id :2
                    service slaac
                }
                prefix-length /56
            }
            rapid-commit enable
        }
        duplex auto
        firewall {
            in {
                ipv6-name WANv6_IN
                name WAN_IN
            }
            local {
                ipv6-name WANv6_LOCAL
                name WAN_LOCAL
            }
        }
        speed auto
    }
    ethernet eth1 {
        address 192.168.0.1/24
        description DMZ
        duplex auto
        speed auto
    }
    ethernet eth2 {
        address 192.168.1.1/24
        description LAN
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
port-forward {
    auto-firewall enable
    hairpin-nat enable
    lan-interface eth1
    lan-interface eth2
    wan-interface eth0
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN1 {
            authoritative enable
            subnet 192.168.0.0/24 {
                default-router 192.168.0.1
                dns-server 192.168.0.1
                lease 86400
                start 192.168.0.38 {
                    stop 192.168.0.243
                }
                static-mapping Vampire142-PC {
                    ip-address 192.168.0.250
                    mac-address 98:e7:f4:60:65:2f
                }
            }
        }
        shared-network-name LAN2 {
            authoritative enable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 192.168.1.1
                lease 86400
                start 192.168.1.100 {
                    stop 192.168.1.200
                }
            }
        }
        use-dnsmasq disable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on eth1
            listen-on eth2
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    gateway-address 192.168.2.1
    host-name ubnt
    login {
        user  {
            authentication {
                encrypted-password
                plaintext-password ""
            }
            level admin
        }
    }
    name-server 8.8.8.8
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}


/* Warning: Do not remove the following line. */
/* === vyatta-config-version: "config-management@1:conntrack@1:cron@1:dhcp-relay@1:dhcp-server@4:firewall@5:ipsec@5:nat@3:qos@1:quagga@2:system@4:ubnt-pptp@1:ubnt-util@1:vrrp@1:webgui@1:webproxy@1:zone-policy@1" === */
/* Release version: v1.9.1.4939093.161214.0705 */
« Modifié: 24 avril 2017 à 02:30:01 par Vampire142 »

Vampire142

  • Client Orange vdsl
  • *
  • Messages: 16
  • Altkirch (68)
Problème avec un ERL
« Réponse #3 le: 25 avril 2017 à 19:09:47 »
J'ai configurer via le CLI (via le port eth2) l'interface eth0 pour la forcer en full duplex mais pour la vitesse impossible d'utiliser 1000Mbits, obliger d'aller a 100Mbits :
Vampire142@ERL3# set interfaces ethernet eth0 duplex
auto  full  half
[edit]
Vampire142@ERL3# set interfaces ethernet eth0 duplex full
[edit]
Vampire142@ERL3# set interfaces ethernet eth0 speed
10    100   1000  auto
[edit]
Vampire142@ERL3# set interfaces ethernet eth0 speed 1000
speed 1000 is not supported

Value validation failed
Set failed
[edit]
Vampire142@ERL3# set interfaces ethernet eth0 speed 100
[edit]
Vampire142@ERL3#
Quelqu'un a une idée, bug logiciel propre a la version 1.9.1 de EdgeOS ou problème matériel ?

Car maintenant en forçant la connexion en 100 Mbits j'ai de nouveau internet correctement, c'est a n'y rien comprendre
« Modifié: 25 avril 2017 à 19:34:40 par Vampire142 »

 

Mobile View