Auteur Sujet: [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn  (Lu 16603 fois)

0 Membres et 1 Invité sur ce sujet

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 936
  • Toulouse (31)
Connections physique:
- eth0 : reseau local
- eth1 : ONT
- eth2 : Management (optionnel)

Se connecter a l'ERL
Configurer son PC en 192.168.1.2 255.255.255.0 192.168.1.1
se connecter en ssh a 192.168.1.1
login : ubnt
password : ubnt

Configurer l'ERL
idealement remplacez votre email dans la 6eme ligne et faites un copier/coller
configure
set interfaces ethernet eth2 address 192.168.2.1/24
set interfaces ethernet eth2 description MGMT
set interfaces ethernet eth0 description LAN
set interfaces ethernet eth1 description WAN
set interfaces ethernet eth1 address dhcp
set interfaces ethernet eth1 dhcp-options client-option "send vendor-class-identifier "neufbox6-votre.email@email.com";"
set service  dhcp-server shared-network-name mgmt subnet 192.168.2.0/24  start 192.168.2.2 stop 192.168.2.10
set service  dhcp-server shared-network-name lan subnet 192.168.1.0/24 start 192.168.1.2 stop 192.168.1.100
set service  dhcp-server shared-network-name lan subnet 192.168.1.0/24 ntp-server 192.168.1.1
set service  dhcp-server shared-network-name lan subnet 192.168.1.0/24 dns-server 192.168.1.1
set service  dhcp-server shared-network-name lan subnet 192.168.1.0/24 default-router 192.168.1.1
set service nat rule 5000 type masquerade
set service nat rule 5000 description "Masquerade"
set service nat rule 5000 outbound-interface eth1
set service dns forwarding listen-on eth1
set service dns forwarding listen-on eth0
set firewall name WAN_LOCAL description "packets from internet to the router"
set firewall name WAN_LOCAL default-action drop
set firewall name WAN_LOCAL enable-default-log
set firewall name WAN_LOCAL rule 5 action accept
set firewall name WAN_LOCAL rule 5 description "Allow Multicast"
set firewall name WAN_LOCAL rule 5 destination address 224.0.0.0/4
set firewall name WAN_LOCAL rule 10 description "allow established sessions"
set firewall name WAN_LOCAL rule 10 action accept
set firewall name WAN_LOCAL rule 10 state established enable
set firewall name WAN_LOCAL rule 10 state related enable
set firewall name WAN_LOCAL rule 10 state invalid disable
set firewall name WAN_LOCAL rule 10 state new disable
set firewall name WAN_LOCAL rule 10 protocol all
set firewall name WAN_LOCAL rule 20 description "drop invalid state"
set firewall name WAN_LOCAL rule 20 action drop
set firewall name WAN_LOCAL rule 20 state established disable
set firewall name WAN_LOCAL rule 20 state related disable
set firewall name WAN_LOCAL rule 20 state invalid enable
set firewall name WAN_LOCAL rule 20 state new disable
set firewall name WAN_LOCAL rule 20 protocol all
set interfaces ethernet eth1 firewall local name WAN_LOCAL
set firewall name WAN_IN description "packets from internet to LAN & WLAN"
set firewall name WAN_IN default-action drop
set firewall name WAN_IN enable-default-log
set firewall name WAN_IN rule 5 action accept
set firewall name WAN_IN rule 5 description "Allow Multicast"
set firewall name WAN_IN rule 5 destination address 224.0.0.0/4
set firewall name WAN_IN rule 10 description "allow established sessions"
set firewall name WAN_IN rule 10 action accept
set firewall name WAN_IN rule 10 state established enable
set firewall name WAN_IN rule 10 state related enable
set firewall name WAN_IN rule 10 state invalid disable
set firewall name WAN_IN rule 10 state new disable
set firewall name WAN_IN rule 10 protocol all
set firewall name WAN_IN rule 15 action accept
set firewall name WAN_IN rule 15 description "Allow 1287/1288 for STB"
set firewall name WAN_IN rule 15 destination port 1287-1288
set firewall name WAN_IN rule 15 protocol tcp
set firewall name WAN_IN rule 15 state new enable
set firewall name WAN_IN rule 20 action accept
set firewall name WAN_IN rule 20 description "Allow UDP to Multicast"
set firewall name WAN_IN rule 20 destination address 224.0.0.0/4
set firewall name WAN_IN rule 20 protocol udp
set firewall name WAN_IN rule 20 state new enable
set firewall name WAN_IN rule 25 action accept
set firewall name WAN_IN rule 25 description "Allow ICMP"
set firewall name WAN_IN rule 25 protocol icmp
set firewall name WAN_IN rule 25 state established enable
set firewall name WAN_IN rule 25 state related enable
set firewall name WAN_IN rule 30 action accept
set firewall name WAN_IN rule 30 description "Allow IGMP"
set firewall name WAN_IN rule 30 protocol igmp
set firewall name WAN_IN rule 100 description "drop invalid state"
set firewall name WAN_IN rule 100 action drop
set firewall name WAN_IN rule 100 state established disable
set firewall name WAN_IN rule 100 state related disable
set firewall name WAN_IN rule 100 state invalid enable
set firewall name WAN_IN rule 100 state new disable
set firewall name WAN_IN rule 100 protocol all
set interfaces ethernet eth1 firewall in name WAN_IN
commit
save
exit

« Modifié: 26 décembre 2016 à 16:33:57 par tivoli »

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 936
  • Toulouse (31)
Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn pour les barbus
« Réponse #1 le: 22 septembre 2014 à 21:40:36 »
  • Recuperer les infos necessaire dans la box actuelle
http://192.168.1.1/api/1.0/?method=system.getInfo
http://192.168.1.1/api/1.0/?method=ftth.getInfo
http://192.168.1.1/api/1.0/?method=wan.getInfo
http://192.168.1.1/api/1.0/?method=lan.getHostsList

  • Modifier le fichier de configuration : lighttpd.conf
Se connecter en SSH a l'ERL et modifier le fichier suivant : /etc/lighttpd/lighttpd.conf en ajoutant les lignes entre Add line (3 en tout)
lighttpd.conf (partie modifié) :
url.rewrite-once = (
# Add line
"^(/api/1.0/.*)" => "$0",
# Add line
        "^(/(lib|media|ws|tests)/.*)" => "$0",
        "^/([^\?]+)(\?(.*))?$" => "/index.php/$1?$3"
)

$HTTP["scheme"] == "http" {
    $HTTP["url"] !~ "^/index.php/error/" {
# Add line
    $HTTP["url"] !~ "^/api/" {
# Add line
        $HTTP["host"] =~ "^(.*)$" {
                url.redirect = (
                        "^(.*)$" => "https://%1$1"
                )
        }
# Add line
    }
# Add line
    }
}

  • Creer le repertoire pour les fichiers de configuration

cd /var/www/htdocs
mkdir api
mkdir api/1.0/
cd /api/1.0/

  • Creer le fichier index.php dans ce repertoire

index.php

<?php
header
('Content-Type: application/xml; charset=utf-8');
if (isset(
$_GET['method'])){
        
$method $_GET['method'];
        switch (
$method) {
                case 
"system.getInfo":
                        echo 
file_get_contents('system.xml');
                        break;
                case 
'lan.getHostsList':
                        echo 
file_get_contents('lan.xml');
                        break;
                case 
'wan.getInfo':
                        echo 
file_get_contents('wan.xml');
                        break;
                case 
'ftth.getInfo':
                        echo 
file_get_contents('ftth.xml');
                        break;
        }
        return;
}
?>


  • Creer le fichier system.xml
(Le plus simple est de remettre le contenu de son fichier original recupere a la premiere etape)


system.xml

<?xml version="1.0" encoding="UTF-8"?>
<rsp stat="ok" version="1.0">
<system product_id="NB6V-SER-r0" mac_addr="xx:xx:xx:xx:xx:xx" net_mode="router" net_infra="ftth" uptime="99999999999999" version_mainfirmware="NB6V-MAIN-R3.3.9" version_rescuefirmware="NB6V-MAIN-R3.3.3" version_bootloader="NB6-BOOTLOADER-R3.3.2" version_dsldriver="NB6V-XDSL-A2pv6F038m" current_datetime="201407080100" refclient=""/>
</rsp>

  • Creer le fichier lan.xml
(Le plus simple est de remettre le contenu de son fichier original recupere a la premiere etape)

lan.xml

<?xml version="1.0" encoding="UTF-8"?>
<rsp stat="ok" version="1.0">
<host type="stb" name="NEUFTVSTB_MA_9440" ip="192.168.1.20" mac="xx:xx:xx:xx:xx:xx" iface="lan1" probe="55" alive="725228" status="online"/>
</rsp>

  • Creer le fichier wan.xml
(Le plus simple est de remettre le contenu de son fichier original recupere a la premiere etape)
wan.xml

<?xml version="1.0" encoding="UTF-8"?>
<rsp stat="ok" version="1.0">       
<wan status="up" uptime="999999" ip_addr="IP_PUBLIQUE" infra="ftth" mode="ftth/routed"/>     
</rsp>

  • Creer le fichier ftth.xml
(Le plus simple est de remettre le contenu de son fichier original recupere a la premiere etape)
ftth.xml

<?xml version="1.0" encoding="UTF-8"?>
<rsp stat="ok" version="1.0">
<ftth status="up" />
</rsp>


  • Configuration IGMP

Pour IGMP (eth0 = LAN, eth1 = ONT, eth2 = Management) :
configure
set protocols igmp-proxy interface eth0 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0 role downstream
set protocols igmp-proxy interface eth0 threshold 1
set protocols igmp-proxy interface eth1 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth1 role upstream
set protocols igmp-proxy interface eth1 threshold 1
set protocols igmp-proxy interface eth2 role disabled
set protocols igmp-proxy interface eth2 threshold 1
commit
save
    Un petit reboot et la TV devrait fonctionner
    « Modifié: 27 septembre 2014 à 20:36:16 par tivoli »

    yrousse

    • Expert
    • Client Bbox fibre FTTH
    • *
    • Messages: 184
    • FTTH Bouygues Telecom 1Gbps sur Paris 18ème
    Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn pour les barbus
    « Réponse #2 le: 15 novembre 2014 à 15:11:39 »
    À noter que la règle WAN_IN 20 :
    set firewall name WAN_IN rule 20 description "Allow UDP to Multicast"
    set firewall name WAN_IN rule 20 destination address 224.0.0.0/4
    set firewall name WAN_IN rule 20 protocol udp
    set firewall name WAN_IN rule 20 state new enable
    est inutile, la règle 5 faisant le job.

    Enfin, ERL passé en 1.6 et aucune modification des élèments essentiels mentionnés ici par Tivoli n'a été nécessaire.

    yrousse

    • Expert
    • Client Bbox fibre FTTH
    • *
    • Messages: 184
    • FTTH Bouygues Telecom 1Gbps sur Paris 18ème
    Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn pour les barbus
    « Réponse #3 le: 06 juillet 2015 à 11:21:37 »
    Rapide post pour signaler qu'il a pas de changements nécessaires des modifs indiquées précédemment pour la toute nouvelle version 1.7 de EdgeOS...

    clean31

    • Client SFR fibre FTTH
    • *
    • Messages: 294
    • Red FTTH - 1000/200 Mb/s - Option Débit+ (31)
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #4 le: 24 décembre 2016 à 15:58:24 »
    [...]
    set firewall options mss-clamp mss 1452
    [...]

    Salut,

    Si j'ai bien suivi l'autre sujet draft de cette conf', cette option n'est pas nécessaire.
    Vous confirmez ?

    Il n'y a pas de PPPoE en fibre chez SFR donc la question de Florian reste pertinente.
    Cette config MSS est probablement un couper/coller d'une version ADSL d'un bypass de box.
    Il faudrait l'enlever.

    Slothy

    • Client Bbox fibre FTTH
    • *
    • Messages: 1 088
    • 2x FTTH 1 Gb/s sur Le Plessis-Trévise (94)
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #5 le: 24 décembre 2016 à 19:45:45 »
    Pas besoin de cette option.

    clean31

    • Client SFR fibre FTTH
    • *
    • Messages: 294
    • Red FTTH - 1000/200 Mb/s - Option Débit+ (31)
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #6 le: 26 décembre 2016 à 13:54:27 »
    Ok, merci.  :)

    tivoli

    • Toulouse (31)
    • Client Bbox fibre FTTH
    • *
    • Messages: 1 936
    • Toulouse (31)
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #7 le: 26 décembre 2016 à 16:35:10 »
    Mis a jour en enlevant la ligne

    DamienC

    • Client Bbox fibre FTTH
    • *
    • Messages: 2 007
    • Brest (29)
      • Damien CUEFF - Portfolio
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #8 le: 26 décembre 2016 à 16:42:45 »
    Bonjour,

    Pour router du 1 Gbps, quel modèle faut-il? J'ai cru lire quelque part que le plus petit modèle ne suffisait pas.

    Merci d'avance,

    Cordialement,
    DamienC

    Hugues

    • AS57199 MilkyWan
    • Expert
    • *
    • Messages: 7 446
    • Paris (15ème)
      • Twitter
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #9 le: 26 décembre 2016 à 17:20:08 »
    un ERL c'est parfait !

    DamienC

    • Client Bbox fibre FTTH
    • *
    • Messages: 2 007
    • Brest (29)
      • Damien CUEFF - Portfolio
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #10 le: 26 décembre 2016 à 17:48:47 »
    un ERL c'est parfait !
    Sûr? Bon je vous fais confiance, c'est commandé :p

    Tsunami2056

    • Client Bbox fibre FTTH
    • *
    • Messages: 45
    • Toulouse 31
    [FTTH] Bypasser la neufbox avec un routeur ubiquiti Edgemax en 5mn
    « Réponse #11 le: 08 mars 2017 à 12:06:20 »
    Salut à tous,

    Je vais migrer vers RED FTTH et je viens d'Orange. Du coup j'aimerais bien continuer d'utiliser mon ERL :)

    Je me posais la question de l'ipv6. Est-ce que ça marche avec la config actuelle proposée en premier post? Ne voyant aucune référence par rapport à ça, je n'en suis pas certain ?

    Merci A+

     

    Mobile View