Auteur Sujet: Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A  (Lu 663 fois)

0 Membres et 1 Invité sur ce sujet

cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« le: 11 avril 2021 à 16:36:51 »
Bonjour,
je suis sur un modem/routeur BT Home HUB 5A en VDSL, en Openwrt en 19.07.7
J'ai suivi le tuto d'ubune ici : https://lafibre.info/remplacer-livebox/remplacement-de-la-livebox-par-un-routeur-openwrt-18-dhcp-v4v6-tv/
J'ouvre un topic a part pour éviter de me mélanger avec les problèmes des autres   ::)

J'ai bien mon IPV4 et mon IPV6 qui remontent.
MAIS J'ai pas la TV  >:( >:( >:( >:( >:(

j'ai un decodeur TV 4, branché sur mon port LAN2 de mon modem, par l'intermediaire de CPL. Avec la LB4 pas de soucis.

Si quelqu'un pouvait m'aider SVP car je ne sais plus ou chercher...et quoi chercher.

La situation actuelle :
Pas de trafic Rx sur le dsl0.840


Ma partie Switch:


Je vois bien le décodeur et mon PC dans le DHCP :


Mon firewall :


un tcpdump sur dsl0.840 me donne ceci lorsque je change une chaine sur la tv:
root@OpenWrt:~# tcpdump -n -i dsl0.840
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on dsl0.840, link-type EN10MB (Ethernet), capture size 262144 bytes
16:11:41.542821 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:41.866750 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:44.562769 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:44.674741 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:45.154755 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:46.090754 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:48.162783 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:48.214766 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 2 group record(s)
16:11:48.842730 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:51.226754 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:51.414745 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:51.766750 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:52.266791 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:54.778772 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:55.374780 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:55.754729 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:56.102766 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:56.162755 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 2 group record(s)
16:11:56.906754 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:11:59.686771 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:12:00.490758 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:12:02.698776 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)
16:12:03.562760 IP 192.168.255.254 > 224.0.0.22: igmp v3 report, 1 group record(s)

je vois des igmp V3 et il me semble qu'il faut du V2 avec le décodeur non ? j'en suis plus certain mais au risque je passe mon /etc/sysctl.conf avec : net.ipv4.conf.all.force_igmp_version=2
ce qui au final me donne ceci maintenant :
root@OpenWrt:~# tcpdump -n -i dsl0.840
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on dsl0.840, link-type EN10MB (Ethernet), capture size 262144 bytes
16:15:16.078881 IP 192.168.255.254 > 232.0.4.58: igmp v2 report 232.0.4.58
16:15:19.084007 IP 192.168.255.254 > 224.0.0.2: igmp leave 232.0.4.58
16:15:19.646775 IP 192.168.255.254 > 232.0.4.58: igmp v2 report 232.0.4.58
16:15:22.648099 IP 192.168.255.254 > 224.0.0.2: igmp leave 232.0.4.58
16:15:23.254834 IP 192.168.255.254 > 232.0.4.58: igmp v2 report 232.0.4.58
16:15:23.950509 IP 192.168.255.254 > 224.0.0.2: igmp leave 232.0.4.58
16:15:24.006892 IP 192.168.255.254 > 232.0.10.93: igmp v2 report 232.0.10.93
16:15:24.330786 IP 192.168.255.254 > 232.0.10.93: igmp v2 report 232.0.10.93
16:15:27.013643 IP 192.168.255.254 > 224.0.0.2: igmp leave 232.0.10.93
16:15:27.566775 IP 192.168.255.254 > 232.0.10.93: igmp v2 report 232.0.10.93
16:15:30.570726 IP 192.168.255.254 > 224.0.0.2: igmp leave 232.0.10.93

Côté eth0.19, un tcpdump me donne ceci :
root@OpenWrt:~# tcpdump -n -i eth0.19
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0.19, link-type EN10MB (Ethernet), capture size 262144 bytes
16:34:31.142807 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:34:34.026763 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:34:37.154691 IP 192.168.19.10 > 239.255.255.250: igmp v2 report 239.255.255.250
16:34:38.634761 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22
16:34:41.638993 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:34:44.522768 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22
16:34:49.683479 IP 192.168.19.10 > 239.255.255.250: igmp v2 report 239.255.255.250
16:34:50.410758 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:34:53.414991 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:34:59.422115 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:34:59.502748 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:35:02.010727 IP 192.168.19.10 > 239.255.255.250: igmp v2 report 239.255.255.250
16:35:02.186759 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22
16:35:08.193225 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:35:09.610738 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:35:14.218739 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22
16:35:17.223002 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:35:18.004804 IP 192.168.19.10 > 239.255.255.250: igmp v2 report 239.255.255.250
16:35:18.467034 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 277
16:35:18.735654 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 323
16:35:18.921238 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 331
16:35:19.084453 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 333
16:35:19.299358 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 341
16:35:19.502298 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 286
16:35:19.523424 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 343
16:35:20.362737 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22
16:35:21.386758 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:35:21.751673 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 331
16:35:21.844004 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 341
16:35:22.483791 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 286
16:35:22.701942 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 323
16:35:22.853080 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 277
16:35:23.003849 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 343
16:35:23.067929 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 333
16:35:25.151953 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 333
16:35:25.699390 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 323
16:35:25.816541 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 331
16:35:26.063581 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 277
16:35:26.215539 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 341
16:35:26.278211 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 343
16:35:26.369434 IP 192.168.19.10.51021 > 239.255.255.250.1900: UDP, length 286
16:35:27.391008 IP 192.168.19.254 > 224.0.0.1: igmp query v2
16:35:28.906751 IP 192.168.19.254 > 224.0.0.2: igmp v2 report 224.0.0.2
16:35:30.602740 IP 192.168.19.254 > 224.0.0.22: igmp v2 report 224.0.0.22

Dans mes LOGS, j'ai des kilomètres de ceci :
Sun Apr 11 16:39:15 2021 user.notice igmpproxy[18413]: RECV Membership query   from 192.168.19.254  to 224.0.0.1
Sun Apr 11 16:39:18 2021 user.notice igmpproxy[18413]: The IGMP message was local multicast. Ignoring.
Sun Apr 11 16:39:18 2021 user.notice igmpproxy[18413]: RECV V2 member report   from 192.168.19.254  to 224.0.0.2
Sun Apr 11 16:39:18 2021 user.notice igmpproxy[18413]: The IGMP message was from myself. Ignoring.
Sun Apr 11 16:39:20 2021 user.notice igmpproxy[18413]: RECV V2 member report   from 192.168.19.254  to 224.0.0.22
Sun Apr 11 16:39:20 2021 user.notice igmpproxy[18413]: The IGMP message was from myself. Ignoring.
Sun Apr 11 16:39:26 2021 user.notice igmpproxy[18413]: RECV Membership query   from 192.168.19.254  to 224.0.0.1
Sun Apr 11 16:39:30 2021 user.notice igmpproxy[18413]: The IGMP message was local multicast. Ignoring.
Sun Apr 11 16:39:33 2021 user.notice igmpproxy[18413]: RECV Membership query   from 192.168.19.254  to 224.0.0.1
Sun Apr 11 16:39:33 2021 user.notice igmpproxy[18413]: RECV V2 member report   from 192.168.19.254  to 224.0.0.22
Sun Apr 11 16:39:33 2021 user.notice igmpproxy[18413]: The IGMP message was from myself. Ignoring.
Sun Apr 11 16:39:34 2021 user.notice igmpproxy[18413]: RECV V2 member report   from 192.168.19.254  to 224.0.0.2
Sun Apr 11 16:39:34 2021 user.notice igmpproxy[18413]: The IGMP message was from myself. Ignoring.
Sun Apr 11 16:39:34 2021 user.notice igmpproxy[18413]: The IGMP message was local multicast. Ignoring.

mon /etc/config/dhcp :
config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option nonwildcard '1'
    option localservice '1'
 
config dhcp 'lan'
   option interface 'lan'
   option leasetime '12h'
   option start '10'
   option limit '100'
   option force '1'
   option ra 'server'
   list dhcp_option '6,192.168.1.1'
 
config dhcp 'wan'
    option interface 'wan'
    option ignore '1'
 
config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'
    option loglevel '4'
 
config dhcp 'vlantv'
    option leasetime '12h'
    option interface 'vlantv'
    option start '10'
    option limit '10'
    list dhcp_option '6,80.10.246.2,80.10.246.129'
    list dhcp_option '15,orange.fr'
    list dhcp_option '125,00:00:0d:e9:24:04:06:YY:YY:YY:YY:YY:YY:05:0f:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:06:09:4c:69:76:65:62:6f:78:20:34'

Mon /etc/config/network :
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdb7:3b5a:e42d::/48'

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'

config dsl 'dsl'
option annex 'a'
option tone 'av'

config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr '34:8a:ae:77:4a:3c'

config device 'wan_dsl0_dev'
option name 'dsl0'
option macaddr '34:8a:ae:77:4a:3d'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '6t 4 0 1'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '832'
option ports '6t'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '6t 2'
option vid '19'
option description 'DECODEUR TV'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option broadcast '192.168.1.255'
option gateway '192.168.1.1'
option ip6assign '64'
option mtu '1500'
list dns '81.253.149.10'
list dns '80.10.246.3'

config interface 'wan'
option ifname 'dsl0.832'
option proto 'dhcp'
option peerdns '1'
option broadcast '1'
option mtu '1500'
option vendorid 'sagem'
option reqopts '1 3 6 15 28 51 58 59 90 119 120 125'
option sendopts '77:2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7834 90:00000000000000000000001a0900000558010341010dxxxxxxxxxxxxxxxxx'

config interface 'wan6'
option ifname 'dsl0.832'
option proto 'dhcpv6'
option reqprefix 'auto'
option reqaddress 'none'
option defaultreqopts '0'
option reqopts '11 17 23 24'
option userclass 'FSVDSL_livebox.Internet.softathome.livebox4'
option vendorclass '0000040e0005736167656d'
option sendopts '11:00000000000000000000001a0900000558010341010dxxxxxxxxxxxxxxxx'
option noclientfqdn '1'
option noacceptreconfig '1'

config interface 'tvorange'
option proto 'static'
option ipaddr '192.168.255.254'
option netmask '255.255.255.255'
option gateway '192.168.255.254'
option ifname 'dsl0.840'
option delegate '0'

config interface 'vlantv'
option proto 'static'
option ipaddr '192.168.19.254'
option netmask '255.255.255.0'
option ifname 'eth0.19'


Mon /etc/config/igmpproxy :
config igmpproxy
    option quickleave 1
    option verbose 2

config phyint
    option network tvorange
    option zone wanTV
    option direction upstream
    list altnet "0.0.0.0/0"

config phyint lan
    option network vlantv
    option zone tv
    option direction downstream

et mon /etc/config/firewall :
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option drop_invalid '1'
option forward 'ACCEPT'
option synflood_protect '1'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'

config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
option input 'DROP'
option forward 'DROP'
list network 'wan'
list network 'tvorange'

config zone
option name 'wanipv6'
option output 'ACCEPT'
option forward 'DROP'
option family 'ipv6'
option input 'DROP'
list network 'wan6'

config rule
option name 'Allow-DHCPv6'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
option src 'wanipv6'

config rule
option name 'Allow-MLD'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
option src 'wanipv6'

config rule
option name 'Allow-ICMPv6-Input'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option src 'wanipv6'

config rule
option name 'Allow-ICMPv6-Forward'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
option src 'wanipv6'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config forwarding
option dest 'wan'
option src 'lan'

config forwarding
option dest 'lan'
option src 'wan'

config rule
option src 'wan'
option proto 'igmp'
option target 'ACCEPT'

config zone
        option name 'tv'
        option output 'ACCEPT'
        option network 'vlantv'
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option family 'ipv4'

config zone
        option name 'wanTV'
        option output 'ACCEPT'
        option masq '1'
        option network 'tvorange'
        option input 'DROP'
        option forward 'DROP'
        option family 'ipv4'

config forwarding
        option dest 'wanTV' #On autorise la box tv à sortir sur le wanTV.
        option src 'tv'
option family 'ipv4'

config forwarding
        option dest 'wan' #On autorise la box tv à atteindre le flux wan classique (Replay/ntp par exemple).
        option src 'tv'
option family 'ipv4'

config rule
        option target 'ACCEPT'
        option name 'igmp' #On autorise le flux IGMP provenant du vlan 840 à destination du routeur.
        option family 'ipv4'
        option proto 'igmp'
        option src 'wanTV'

config rule
        option target 'ACCEPT'
        option name 'multicast' #On autorise le flux multicast provenant du vlan 840 à destination de la zone tv (le vlan TV ou se trouvera le décodeur).
        option family 'ipv4'
        option proto 'udp'
        option src 'wanTV'
        option dest 'tv'
        option dest_ip '224.0.0.0/4'

Voilà donc si quelqu'un peut m'aider !
Merci beaucoup.
« Modifié: 11 avril 2021 à 17:31:31 par cetipabo »

cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #1 le: 11 avril 2021 à 17:42:41 »
J'ai lancé un tcpdump sur les 2 interfaces en simultané et un peu plus longtemps pour la capture : tcpdump -n -i dsl0.840 -vv & tcpdump -n -i eth0.19 -vv

On voit pourtant qu'il se passe des trucs !!!

https://pastebin.com/raw/zC97cKws

renaud07

  • Client Orange adsl
  • *
  • Messages: 2 203
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #2 le: 17 avril 2021 à 00:50:12 »
Salut,

Il n'y aurait pas une coquille dans le tuto d'ubune (typo) ? Je vois dans la conf d'igmpproxy : config phyint lan  hors dans la doc OWRT, c'est config phyint tout court. Comme dans cet exemple :

config igmpproxy
        option quickleave 1

config phyint
        option network wan
        option zone wan # the upstream firewall zone for forward rules
        option direction upstream
        list altnet 0.0.0.0/0 # a description of allowed source addresses for multicast packets

config phyint
        option network lan
        option zone lan #the downstream firewall zone for forward rules
        option direction downstream

Me demande si ça n’empêcherait pas igmpproxy de démarrer ? D'où l'absence de flux.


cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #3 le: 17 avril 2021 à 10:01:54 »
Salut @renaud07
effectivement...pourtant igmpproxy semble démarrer sans indiquer d'erreur...et un cat /etc/igmpproxy.conf me sort bien un :
quickleave

phyint dsl0.840 upstream ratelimit 0 threshold 1
        altnet 0.0.0.0/0

phyint eth0.19 downstream ratelimit 0 threshold 1

je me demande si le problème ne viendrait pas de la lisaison CPL entre le routeur et le decodeur. Jusqu'a il y a quelques jours j'utilisais des Liveplug HD+ Orange (200Mbps). Ces liveplug je les voyais dans la livebox, mais aucune adresse IP n'était affichée...donc je ne sais pas trop comment ils comuniquaient entre eux...par des vlan ? Donc j'en ai acheté des nouveaux (Devolo Magic lan 2) et ceux là ont bien chacun une ip affichée dans la livebox, donc je peux m'y connecter et les parametrer. Mais même avec ces nouveaux CPL le problème est toujours là. Donc je me suis dis que les CPL devaient être hors de cause.

Hier en réfléchissant un peu, je me suis dit que si les CPL ont des IP, ils ont donc un client DHCP...et que dans le tuto d'ubune, à cette étape :
Citer
/etc/config/dhcp =>

config dhcp 'vlantv'
        option leasetime '12h'
        option interface 'vlantv'
        option start '10'
        option limit '10'

        list dhcp_option '6,81.253.149.10,80.10.246.3'
        list dhcp_option '15,orange.fr'
        list dhcp_option '125,00:00:0d:e9:24:04:06:YY:YY:YY:YY:YY:YY:05:0f:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:06:09:4c:69:76:65:62:6f:78:20:34'

Ne permettait d'attribuer qu'une seule IP, alors qu'il y a 2 CPL et 1 Decodeur...

Je viens de passer option limit à 15...on va voir

EDIT:
Bon ben je vois bien tout le monde, mon PC, le décodeur et les 2 CPL maintenant :


J'ai corrigé le typo dans igmpproxy, donc je suis comme ca :
config igmpproxy
    option quickleave 1

config phyint
    option network tvorange
    option zone wanTV # 18.06.02
    option direction upstream
        list altnet "0.0.0.0/0"

config phyint
    option network vlantv
    option zone tv # 18.06.02
    option direction downstream

Mais rien à faire toujours pas de TV...
« Modifié: 17 avril 2021 à 10:44:28 par cetipabo »

cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #4 le: 17 avril 2021 à 12:07:10 »
est-ce que c'est normal ce message lors d'un restart de dnsmasq ?
root@OpenWrt:~# /etc/init.d/dnsmasq restart
udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: no lease, failing

Edit:
Je me répond, oui c'est normal :
https://forum.openwrt.org/t/solved-dnsmasq-restart-shows-dhcp-error/19359
« Modifié: 20 avril 2021 à 17:57:52 par cetipabo »

ubune

  • Client Bbox fibre FTTH
  • *
  • Messages: 187
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #5 le: 17 avril 2021 à 13:12:23 »
Pour info on a corrigé la version d'igmp qui était en V3 par défaut.

ça ne marche toujours pas, uniquement sur le flux igmp, on voit sortir les igmp report mais 0 rep.
En analysant les logs envoyé par cétipabo les flux igmp de la box tv sont émis en DSCP CS4.
Sauf que ceux initiés par le routeur sur le vlan 840 (il agit comme un proxy) sont en CS6.

On va faire d'autres test.
« Modifié: 17 avril 2021 à 15:24:46 par ubune »

cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #6 le: 17 avril 2021 à 14:21:45 »
zoc me confirme ceci:
Citer
sur le VLAN 840, IGMP doit être en priorité 5 (en tout cas chez moi), sinon pas de TV. C'est plutôt de ce coté que je regarderais en priorité.

J'ai testé ça mais pas mieux:
iptables -t mangle -A POSTROUTING -o dsl0.840 -p igmp -j CLASSIFY --set-class 0000:0004
iptables -t mangle -A POSTROUTING -o dsl0.840 -p igmp -j DSCP --set-dscp-class CS4
et
iptables -t mangle -A POSTROUTING -o dsl0.840 -p igmp -j CLASSIFY --set-class 0000:0005
iptables -t mangle -A POSTROUTING -o dsl0.840 -p igmp -j DSCP --set-dscp-class CS5

en regardant la doc ici: https://openwrt.org/docs/guide-user/network/wan/udp_multicast#firewall_settings
ils disent que igmpproxy, au lancement, ajoute des regles au Firewall:
Citer
However current versions insert the rules automatically during start-up of the igmpproxy daemon.
You will see two rules inserted into the appropriate forward chain, in iptables-save format they would look like:
-A zone_wan_forward -d 239.255.255.250/32 -p udp -m comment --comment "!fw3: ubus:igmpproxy[instance1] rule 1" -j zone_lan_dest_DROP
-A zone_wan_forward -d 224.0.0.0/4 -p udp -m comment --comment "!fw3: ubus:igmpproxy[instance1] rule 2" -j zone_lan_dest_ACCEPT

The first rule drops SSDP packets that would cause WAN side services to be advertised on your LAN. The second rule allows forwarding of any other multicast packets. However forwarding will only occur for those packets where igmpproxy will insert routing rules.

est-ce que du coup ca aurait une incidence ?
Quand je restart le firewall on voit bien :
Citer
root@OpenWrt:~# /etc/init.d/firewall restart
Warning: Unable to locate ipset utility, disabling ipset support
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
 * Flushing conntrack table ...
 * Populating IPv4 filter table
   * Rule 'ubus:igmpproxy[instance1] rule 0'
   * Rule 'ubus:igmpproxy[instance1] rule 1'
   * Rule 'ubus:igmpproxy[instance1] rule 2'
   * Rule 'ubus:igmpproxy[instance1] rule 3'


Citer
root@OpenWrt:~# iptables -L | grep igmp
ACCEPT     igmp --  anywhere             anywhere             /* !fw3: ubus:igmpproxy[instance1] rule 3 */
zone_tv_dest_DROP  udp  --  anywhere             239.255.255.250      /* !fw3: ubus:igmpproxy[instance1] rule 1 */
zone_tv_dest_ACCEPT  udp  --  anywhere             base-address.mcast.net/4  /* !fw3: ubus:igmpproxy[instance1] rule 2 */

ACCEPT     igmp --  anywhere             anywhere             /* !fw3: ubus:igmpproxy[instance1] rule 0 */
ACCEPT     igmp --  anywhere             anywhere             /* !fw3: igmp */
ACCEPT     igmp --  anywhere             anywhere             /* !fw3: @rule[15] */
« Modifié: 17 avril 2021 à 15:31:48 par cetipabo »

renaud07

  • Client Orange adsl
  • *
  • Messages: 2 203
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #7 le: 18 avril 2021 à 00:06:55 »
Et si tu bridges le 840 sur le déco ?

Certes c'est un peu crade (c'est ce qu'on faisait au tout début il me semble lorsqu'on connaissait pas l'archi de la LB) mais on pourra vérifier si le problème vient bien d'igmpproxy, enfin en théorie.

cetipabo

  • Client Orange vdsl
  • *
  • Messages: 523
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #8 le: 18 avril 2021 à 00:26:23 »
Et si tu bridges le 840 sur le déco ?

Certes c'est un peu crade (c'est ce qu'on faisait au tout début il me semble lorsqu'on connaissait pas l'archi de la LB) mais on pourra vérifier si le problème vient bien d'igmpproxy, enfin en théorie.
tu fais ca comment ?

j'ai remarqué un truc en lancant wireshark sur mon PC, je capture des paquets igmp envoyés par le decodeur et la livebox, et c'est toujours tagué en DSCP: CS4, jamais en 5...
faudrait tenter un vlanprio.sh en cs4 au lieu de 5 ?
Citer
#!/bin/sh
set -x
for i in 0 1 2 3 4 5 6 7; do
    ip link set eth1.832 type vlan egress $i:$i >/dev/null  ## Chaque file devient en priorité $numdefile
    ip link set eth1.840 type vlan egress $i:4 >/dev/null   ## tout en prio 4 sur le vlan 840

done
    ip link set eth1.832 type vlan egress 1:0 >/dev/null    ## La file (1) était donc en prio 1 on la repasse à 0, ça deviendra (via IPTABLES) la nouvelle file par défaut.
    ip link set eth1.832 type vlan egress 0:6 >/dev/null    ## Tout le flux devient en prio 6 ! sauf le flux qui passera par IPTABLES (donc juste nos requêtes dhcp)

renaud07

  • Client Orange adsl
  • *
  • Messages: 2 203
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #9 le: 18 avril 2021 à 02:46:38 »
tu fais ca comment ?

Pas très compliqué : tu crée une nouvelle interface : Create a bridge over multiple interfaces. Et tu coches le vlan 19 et dsl0.840

j'ai remarqué un truc en lancant wireshark sur mon PC, je capture des paquets igmp envoyés par le decodeur et la livebox, et c'est toujours tagué en DSCP: CS4, jamais en 5...
faudrait tenter un vlanprio.sh en cs4 au lieu de 5 ?

Ça ne coûte rien d'essayer  :)

zoc

  • Client Orange Fibre
  • *
  • Messages: 3 423
  • Antibes (06)
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #10 le: 18 avril 2021 à 08:49:14 »
c'est toujours tagué en DSCP: CS4, jamais en 5...
Ne pas confondre la priorité IP (DSCP), et la priorité 802.1p au niveau des VLAN. La box TV ne peut évidemment pas marquer la priorité au niveau VLAN puisque le flux TV n’est pas transporté dans un VLAN côté LAN de la box.

Côté WAN, les paquets IGMP dans le VLAN 840 ont clairement une priorité 802.1p à 5, on l’a clairement constaté à l’époque en sniffant le trafic sur le port WAN des livebox (facile en FTTH d’intercaler un switch avec port mirroring avec un ONT Ethernet). D’ailleurs, pour la petite histoire, pour le VLAN 851, qui était utilisé pour la téléphonie, la priorité était à 4...

@kgersen avait publié un document qui résumait très bien les différentes priorités assignées par la lb, mais je n’arrive pas à le retrouver.

ubune

  • Client Bbox fibre FTTH
  • *
  • Messages: 187
Openwrt 19.07.7 pas de TV sur un BT Home Hub 5A
« Réponse #11 le: 18 avril 2021 à 09:17:28 »
Du coup si on veut reproduire :

Script pour la cos à 5 sur le vlan 840

et même si la prio L3 est surement non obligatoire, pour reproduire le comportement de la box =>
iptables -t mangle -A POSTROUTING -o dsl0.840 -p igmp -j DSCP --set-dscp-class CS4

ça ne fonctionne pas et pourtant le script est bien exécuté car sinon il n'aurait pas V4/V6.

Difficile de comprendre pourquoi ses flux multicast sont ignorés :/
Cependant dans les traces reçu je ne peux pas voir l'en-tête vlan (802.1Q) sur ethernet (pour vérifier la prio 802.1P).



 

Mobile View