Je crois qu'il faille mettre le bridge en tagged si tu veux faire du routing inter vlan, je ne suis pas sûr que ça soit forcement nécessaire sur le switch dans ton cas.
Ma config: ONT -> CRS309 (vlan832) -> RB5009 -> CRS309 (vlan10) -> vlan20 (home), vlan30 (lab) et vlan40 (guest). Tout le routing intervlan est fait par mon CRS309. Les serveurs DHCPv4 pour le lan sont sur le RB5009, et le CRS309 fait office de relais. C'est aussi le CRS309 qui route IPv6.
Voilà les configs, si ça peut donner de l'inspiration, ou si quelqu'un voit que je fais quelque chose de pas bien :p
RB5009:
/interface bridge add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf name=bridge vlan-filtering=yes
/interface ethernet set [ find default-name=ether1 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether2 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether3 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether4 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether5 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether6 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether7 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=ether8 ] rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=sfp-sfpplus1 ] rx-flow-control=on tx-flow-control=on
/interface wireguard add listen-port=51820 mtu=1420 name=wireguard1
/interface vlan add interface=bridge name=vlan10 vlan-id=10
/interface vlan add interface=bridge name=vlan99 vlan-id=99
/interface vlan add interface=bridge name=vlan832 vlan-id=832
/interface list add comment=defconf name=WAN
/interface list add comment=defconf name=LAN
/interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik
/ip dhcp-client option add code=60 name=vendor-class-identifier value=0x736167656d
/ip dhcp-client option add code=77 name=userclass value=0x2b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e4c697665626f7833
/ip dhcp-client option add code=90 name=authsend value=0x00000000000000000000001aXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
/ip pool add name=vlan20_pool ranges=192.168.20.100-192.168.20.200
/ip pool add name=vlan30_pool ranges=192.168.30.100-192.168.30.200
/ip pool add name=vlan40_pool ranges=192.168.40.100-192.168.40.200
/ip dhcp-server add address-pool=vlan20_pool interface=vlan10 lease-time=12h name=vlan20_dhcp relay=192.168.20.1
/ip dhcp-server add address-pool=vlan30_pool interface=vlan10 lease-time=12h name=vlan30_dhcp relay=192.168.30.1
/ip dhcp-server add address-pool=vlan40_pool interface=vlan10 lease-time=12h name=vlan40_dhcp relay=192.168.40.1
/ipv6 dhcp-client option add code=16 name=class-identifier value=0x0000040e0005736167656d
/ipv6 dhcp-client option add code=11 name=authsend value=0x00000000000000000000001aXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
/ipv6 dhcp-client option add code=15 name=userclass value=0x002b46535644534c5f6c697665626f782e496e7465726e65742e736f66746174686f6d652e6c697665626f78340a
/ipv6 dhcp-server add address-pool=orange_pool interface=vlan10 name=orange_dhcp6
/interface bridge port add bridge=bridge comment=defconf interface=ether1
/interface bridge port add bridge=bridge comment=defconf interface=ether2
/interface bridge port add bridge=bridge comment=defconf interface=ether3
/interface bridge port add bridge=bridge comment=defconf interface=ether4
/interface bridge port add bridge=bridge comment=defconf interface=ether5
/interface bridge port add bridge=bridge comment=defconf interface=ether6
/interface bridge port add bridge=bridge comment=defconf interface=ether7
/interface bridge port add bridge=bridge comment=defconf interface=ether8 pvid=10
/interface bridge port add bridge=bridge comment=defconf interface=sfp-sfpplus1
/interface bridge vlan add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=832
/interface bridge vlan add bridge=bridge tagged=sfp-sfpplus1,bridge vlan-ids=10
/interface bridge vlan add bridge=bridge tagged=bridge vlan-ids=99
/interface list member add interface=vlan832 list=WAN
/interface list member add interface=vlan10 list=LAN
/interface list member add interface=vlan99 list=LAN
/interface wireguard peers add allowed-address=192.168.200.1/32 endpoint-address=XX.XX.XX.XX endpoint-port=51820 interface=wireguard1 public-key="XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX"
/ip address add address=192.168.10.1/24 interface=vlan10 network=192.168.10.0
/ip address add address=192.168.99.1/24 interface=vlan99 network=192.168.99.0
/ip address add address=192.168.200.2/24 interface=wireguard1 network=192.168.200.0
/ip dhcp-client add dhcp-options=hostname,clientid,authsend,userclass,vendor-class-identifier interface=vlan832
/ip dhcp-server network add address=192.168.20.0/24 dns-server=192.168.10.1 domain=lan.xxxx.fr gateway=192.168.20.1
/ip dhcp-server network add address=192.168.30.0/24 dns-server=192.168.10.1 domain=lab.xxxx.fr gateway=192.168.30.1
/ip dhcp-server network add address=192.168.40.0/24 dns-server=192.168.10.1 domain=guest.xxxx.fr gateway=192.168.40.1
/ip dns set allow-remote-requests=yes servers=1.1.1.1,8.8.8.8
/ip firewall address-list add address=192.168.0.0/16 list=local_network
/ip firewall filter add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
/ip firewall filter add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
/ip firewall filter add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
/ip firewall filter add action=accept chain=input comment="defconf: accept to local loopback (for CAPsMAN)" dst-address=127.0.0.1
/ip firewall filter add action=drop chain=input comment="defconf: drop all not coming from LAN" in-interface-list=!LAN
/ip firewall filter add action=accept chain=forward comment="defconf: accept in ipsec policy" ipsec-policy=in,ipsec
/ip firewall filter add action=accept chain=forward comment="defconf: accept out ipsec policy" ipsec-policy=out,ipsec
/ip firewall filter add action=fasttrack-connection chain=forward comment="defconf: fasttrack" connection-state=established,related hw-offload=yes
/ip firewall filter add action=accept chain=forward comment="defconf: accept established,related, untracked" connection-state=established,related,untracked
/ip firewall filter add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
/ip firewall filter add action=drop chain=forward comment="defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat connection-state=new in-interface-list=WAN
/ip firewall nat add action=masquerade chain=srcnat comment="defconf: masquerade" ipsec-policy=out,none out-interface-list=WAN
/ip route add disabled=no dst-address=192.168.0.0/16 gateway=192.168.10.254 routing-table=main suppress-hw-offload=no
/ip service set telnet disabled=yes
/ip service set ftp disabled=yes
/ipv6 dhcp-client add add-default-route=yes dhcp-options=authsend,class-identifier,userclass dhcp-options=authsend,class-identifier,userclass interface=vlan832 pool-name=orange_pool pool-prefix-length=60 rapid-commit=no request=prefix use-interface-duid=yes
/ipv6 firewall address-list add address=::/128 comment="defconf: unspecified address" list=bad_ipv6
/ipv6 firewall address-list add address=::1/128 comment="defconf: lo" list=bad_ipv6
/ipv6 firewall address-list add address=fec0::/10 comment="defconf: site-local" list=bad_ipv6
/ipv6 firewall address-list add address=::ffff:0.0.0.0/96 comment="defconf: ipv4-mapped" list=bad_ipv6
/ipv6 firewall address-list add address=::/96 comment="defconf: ipv4 compat" list=bad_ipv6
/ipv6 firewall address-list add address=100::/64 comment="defconf: discard only " list=bad_ipv6
/ipv6 firewall address-list add address=2001:db8::/32 comment="defconf: documentation" list=bad_ipv6
/ipv6 firewall address-list add address=2001:10::/28 comment="defconf: ORCHID" list=bad_ipv6
/ipv6 firewall address-list add address=3ffe::/16 comment="defconf: 6bone" list=bad_ipv6
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
/ipv6 firewall filter add action=drop chain=input comment="defconf: drop invalid" connection-state=invalid
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept ICMPv6" protocol=icmpv6
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept UDP traceroute" port=33434-33534 protocol=udp
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept DHCPv6-Client prefix delegation." dst-port=546 protocol=udp src-address=fe80::/10
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept ipsec AH" protocol=ipsec-ah
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept ipsec ESP" protocol=ipsec-esp
/ipv6 firewall filter add action=accept chain=input comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
/ipv6 firewall filter add action=drop chain=input comment="defconf: drop everything else not coming from LAN" in-interface-list=!LAN
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept established,related,untracked" connection-state=established,related,untracked
/ipv6 firewall filter add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
/ipv6 firewall filter add action=drop chain=forward comment="defconf: drop packets with bad src ipv6" src-address-list=bad_ipv6
/ipv6 firewall filter add action=drop chain=forward comment="defconf: drop packets with bad dst ipv6" dst-address-list=bad_ipv6
/ipv6 firewall filter add action=drop chain=forward comment="defconf: rfc4890 drop hop-limit=1" hop-limit=equal:1 protocol=icmpv6
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept ICMPv6" protocol=icmpv6
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept HIP" protocol=139
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept IKE" dst-port=500,4500 protocol=udp
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept ipsec AH" protocol=ipsec-ah
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept ipsec ESP" protocol=ipsec-esp
/ipv6 firewall filter add action=accept chain=forward comment="defconf: accept all that matches ipsec policy" ipsec-policy=in,ipsec
/ipv6 firewall filter add action=drop chain=forward comment="defconf: drop everything else not coming from LAN" connection-state=!established in-interface-list=WAN
/ipv6 nd set [ find default=yes ] dns=2606:4700::1111,2001:4860:4860::8888
/snmp set enabled=yes
/system clock set time-zone-name=Europe/Paris
/system note set show-at-login=no
/tool graphing interface add
/tool graphing resource add
/tool mac-server set allowed-interface-list=LAN
/tool mac-server mac-winbox set allowed-interface-list=LAN
CRS309:
/interface bridge add admin-mac=XX:XX:XX:XX:XX:XX auto-mac=no comment=defconf name=bridge vlan-filtering=yes
/interface ethernet set [ find default-name=ether1 ] l2mtu=1592
/interface ethernet set [ find default-name=sfp-sfpplus1 ] l2mtu=1592
/interface ethernet set [ find default-name=sfp-sfpplus2 ] l2mtu=1592
/interface ethernet set [ find default-name=sfp-sfpplus3 ] l2mtu=1592 rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=sfp-sfpplus4 ] l2mtu=1592
/interface ethernet set [ find default-name=sfp-sfpplus5 ] l2mtu=1592 rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=sfp-sfpplus6 ] l2mtu=1592 rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=sfp-sfpplus7 ] l2mtu=1592 rx-flow-control=on tx-flow-control=on
/interface ethernet set [ find default-name=sfp-sfpplus8 ] l2mtu=1592 rx-flow-control=on tx-flow-control=on
/interface vlan add interface=bridge name=vlan10 vlan-id=10
/interface vlan add interface=bridge name=vlan20 vlan-id=20
/interface vlan add interface=bridge name=vlan30 vlan-id=30
/interface vlan add interface=bridge name=vlan40 vlan-id=40
/interface ethernet switch set 0 l3-hw-offloading=yes
/interface lte apn set [ find default=yes ] ip-type=ipv4 use-network-apn=no
/interface wireless security-profiles set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile set [ find default=yes ] html-directory=hotspot
/port set 0 name=serial0
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=ether1 pvid=20
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus1
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus2
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus3
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus4
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus5
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus6 pvid=30
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus7 pvid=30
/interface bridge port add bridge=bridge comment=defconf ingress-filtering=no interface=sfp-sfpplus8 pvid=20
/interface ethernet switch l3hw-settings set ipv6-hw=yes
/ip neighbor discovery-settings set discover-interface-list=!dynamic
/ip settings set max-neighbor-entries=8192
/ipv6 settings set accept-router-advertisements=yes
/interface bridge vlan add bridge=bridge tagged=sfp-sfpplus1,sfp-sfpplus2 vlan-ids=832
/interface bridge vlan add bridge=bridge tagged=bridge,sfp-sfpplus2 vlan-ids=10
/interface bridge vlan add bridge=bridge tagged=bridge untagged=sfp-sfpplus8,ether1 vlan-ids=20
/interface bridge vlan add bridge=bridge tagged=bridge untagged=sfp-sfpplus7,sfp-sfpplus6 vlan-ids=30
/interface bridge vlan add bridge=bridge tagged=bridge,ether1 vlan-ids=40
/interface ethernet switch rule add comment="orange cos6" dst-port=67 mac-protocol=ip new-vlan-priority=6 ports=sfp-sfpplus2 protocol=udp switch=switch1 vlan-id=832
/interface ethernet switch rule add comment="orange cos6" dst-port=547 mac-protocol=ipv6 new-vlan-priority=6 ports=sfp-sfpplus2 protocol=udp switch=switch1 vlan-id=832
/interface ethernet switch rule add comment="drop guest to lab" dst-address=192.168.30.0/24 new-dst-ports="" ports=ether1 switch=switch1 vlan-id=40
/interface ethernet switch rule add comment="drop guest to lan" dst-address=192.168.20.0/24 new-dst-ports="" ports=ether1 switch=switch1 vlan-id=40
/interface ovpn-server server set auth=sha1,md5
/ip address add address=192.168.10.254/24 interface=vlan10 network=192.168.10.0
/ip address add address=192.168.20.1/24 interface=vlan20 network=192.168.20.0
/ip address add address=192.168.30.1/24 interface=vlan30 network=192.168.30.0
/ip address add address=192.168.40.1/24 interface=vlan40 network=192.168.40.0
/ip dhcp-relay add dhcp-server=192.168.10.1 disabled=no interface=vlan20 local-address=192.168.20.1 name=vlan20_relay
/ip dhcp-relay add dhcp-server=192.168.10.1 disabled=no interface=vlan30 local-address=192.168.30.1 name=vlan30_relay
/ip dhcp-relay add dhcp-server=192.168.10.1 disabled=no interface=vlan40 local-address=192.168.40.1 name=vlan40_relay
/ip dns set servers=192.168.10.1
/ip route add disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.10.1 pref-src="" routing-table=main scope=30 suppress-hw-offload=no target-scope=10
/ipv6 address add address=::1 from-pool=pool interface=vlan20
/ipv6 address add address=::1 from-pool=pool interface=vlan30
/ipv6 dhcp-client add add-default-route=yes interface=vlan10 pool-name=pool rapid-commit=no request=prefix use-peer-dns=no
/ipv6 nd set [ find default=yes ] ra-preference=high
/snmp set enabled=yes
/system clock set time-zone-name=Europe/Paris
/system identity set name=CRS309
/system note set show-at-login=no
/system routerboard settings set boot-os=router-os