Auteur Sujet: Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)  (Lu 99936 fois)

0 Membres et 3 Invités sur ce sujet

benoitc

  • Client Orange Fibre
  • *
  • Messages: 180
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #756 le: 04 janvier 2020 à 20:58:15 »
J'ai créer un deuxieme vlan et je souhaiterais avoir l'IPv6 aussi sur celui-ci.  J'ai ajouté dans le fichier `config.gateway.json` la section suivante:


{
  ...
  "eth1": {
         "vif": {
              ...
              "3": {
                            "ipv6": {
                                "dup-addr-detect-transmits": "1",
                                "router-advert": {
                                    "cur-hop-limit": "64",
                                    "link-mtu": "0",
                                    "managed-flag": "false",
                                    "max-interval": "600",
                                    "other-config-flag": "false",
                                    "prefix": {
                                        "::/64": {
                                            "autonomous-flag": "true",
                                            "on-link-flag": "true",
                                            "valid-lifetime": "2592000"
                                        }
                                    },
                                    "reachable-time": "0",
                                    "retrans-timer": "0",
                                    "send-advert": "true"
                                }
                            }
                       }
                }
         }
}

et sur le gateway:

ip addr delete <fullprefix>01::1/64 dev eth1.3

le "01::1" correspond à ETH1_PREFIX dans le fichier radvd.sh.


J'ai maintenant:

# show ipv6 route
Codes: K - kernel route, C - connected, S - static, R - RIPng, O - OSPFv3,
       I - ISIS, B - BGP, * - FIB route.

K>* ::/0 via fe80::ba0:bab, eth0.832
C>* ::1/128 is directly connected, lo
C * <fullprefix>01::/64 is directly connected, eth1.3
C>*<fullprefix>01::/64 is directly connected, eth1
C * fe80::/64 is directly connected, eth0.832
C * fe80::/64 is directly connected, eth0.840
C * fe80::/64 is directly connected, eth1.1
C * fe80::/64 is directly connected, eth1.2
C * fe80::/64 is directly connected, eth1.3
C * fe80::/64 is directly connected, eth0
C>* fe80::/64 is directly connected, eth1
root@ubnt:/config/sbin/dnscrypt-proxy# show interfaces
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface    IP Address                        S/L  Description                 
---------    ----------                        ---  -----------                 
eth0         -                                 u/u  WAN                         
eth0.832     90.24.126.73/23                   u/u  WAN                         
eth0.840     192.168.255.254/24                u/u                             
eth1         192.168.1.1/24                    u/u  LAN                         
             <fullprefix>01::1/64       
eth1.1       -                                 u/u                             
eth1.2       192.168.2.1/24                    u/u                             
eth1.3       192.168.10.1/24                   u/u                             
             <fullprefix>01::1/64       
eth2         -                                 A/D                             
lo           127.0.0.1/8                       u/u                             
             ::1/128       


J'ai relancé radvd et maintenant le vlan 3 se voit bien attribué une Ip v6 mais en faisant un test sur test-ipv6.com il m'insique que cette machine n'a pas d'IP v6 associée. Une idée? Quel prefix faut-il en fait ajouter? Est-ce que la configuration est suffisante?

benoitc

  • Client Orange Fibre
  • *
  • Messages: 180
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #757 le: 04 janvier 2020 à 21:30:08 »
J'ai créer un deuxieme vlan et je souhaiterais avoir l'IPv6 aussi sur celui-ci.  J'ai ajouté dans le fichier `config.gateway.json` la section suivante:


{
  ...
  "eth1": {
         "vif": {
              ...
              "3": {
                            "ipv6": {
                                "dup-addr-detect-transmits": "1",
                                "router-advert": {
                                    "cur-hop-limit": "64",
                                    "link-mtu": "0",
                                    "managed-flag": "false",
                                    "max-interval": "600",
                                    "other-config-flag": "false",
                                    "prefix": {
                                        "::/64": {
                                            "autonomous-flag": "true",
                                            "on-link-flag": "true",
                                            "valid-lifetime": "2592000"
                                        }
                                    },
                                    "reachable-time": "0",
                                    "retrans-timer": "0",
                                    "send-advert": "true"
                                }
                            }
                       }
                }
         }
}

et sur le gateway:

ip addr delete <fullprefix>01::1/64 dev eth1.3

le "01::1" correspond à ETH1_PREFIX dans le fichier radvd.sh.


J'ai maintenant:

# show ipv6 route
Codes: K - kernel route, C - connected, S - static, R - RIPng, O - OSPFv3,
       I - ISIS, B - BGP, * - FIB route.

K>* ::/0 via fe80::ba0:bab, eth0.832
C>* ::1/128 is directly connected, lo
C * <fullprefix>01::/64 is directly connected, eth1.3
C>*<fullprefix>01::/64 is directly connected, eth1
C * fe80::/64 is directly connected, eth0.832
C * fe80::/64 is directly connected, eth0.840
C * fe80::/64 is directly connected, eth1.1
C * fe80::/64 is directly connected, eth1.2
C * fe80::/64 is directly connected, eth1.3
C * fe80::/64 is directly connected, eth0
C>* fe80::/64 is directly connected, eth1
# show interfaces
Codes: S - State, L - Link, u - Up, D - Down, A - Admin Down
Interface    IP Address                        S/L  Description                 
---------    ----------                        ---  -----------                 
eth0         -                                 u/u  WAN                         
eth0.832     90.24.126.73/23                   u/u  WAN                         
eth0.840     192.168.255.254/24                u/u                             
eth1         192.168.1.1/24                    u/u  LAN                         
             <fullprefix>01::1/64       
eth1.1       -                                 u/u                             
eth1.2       192.168.2.1/24                    u/u                             
eth1.3       192.168.10.1/24                   u/u                             
             <fullprefix>01::1/64       
eth2         -                                 A/D                             
lo           127.0.0.1/8                       u/u                             
             ::1/128       


J'ai relancé radvd et maintenant le vlan 3 se voit bien attribué une Ip v6 mais en faisant un test sur test-ipv6.com il m'insique que cette machine n'a pas d'IP v6 associée. Une idée? Quel prefix faut-il en fait ajouter? Est-ce que la configuration est suffisante?


Trouvé mon problème. J'ai modifié le suffixe en "03::1" et ça marche.

Brouno

  • Client Orange Fibre
  • *
  • Messages: 59
  • Saint-Hilarion (78)
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #758 le: 06 janvier 2020 à 10:55:47 »
Bonjour à tous,

Merci pour toutes ces infos, cela m'a également permis de retirer la livebox 4 pour la remplacer par l'USG 3P  ;D
Incroyable bolulot !   :D

J'utilise le "fameux" MC220L de TP-link pour le module SFP ONT issu de ma LB4, sans problème !

Internet IPv4 --> OK
Internet IPv6 --> OK

TV sur le LAN --> OK, mais impossible en wifi. Je me demande si il n'y a pas un paramétrage spécifique (DHCP ?) dans ce cas. Est-ce que quelqu'un a réussit déjà ?
et une autre question boitier TV UHD : est-ce que 2 décodeurs sont possibles ? j'ai systématiquement un écran tout blanc sur le 2ème, aucun message d'erreur. Il a bien pris son adresse sur le DHCP pourtant. Peut-être les parties fixes de la chaine DHCP option 125 sont a modifier pour indiquer un 2ème boitier ?

Il me reste à remettre la livebox pour le téléphone.

J'ai grave galéré avec le DHCP de l'USG sur VLAN, il semblerait que ce soit bien buggé, il y a beaucoup de messages à ce sujet sur le forum de ubiquiti.
Impossible de faire un VLAN spécifique pour la TV, je me suis rabattu sur le LAN général pour la TV

Quelques points par rapport au post #1 :

- Etape 10 : seule la chaine "longue" pour l'authent vlan 832 fonctionne pour moi (send rfc3118-auth xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx; ne fonctionne pas )
Ce qui est généré par le jsfiddle est OK
il faudrait mettre à jour en fonction de ses infos, c'est assez confusant sinon (même il semble que le chaine courte fonctionne pour les anciennes installations)

- Supprimer toute référence au vlan840

- IPv6 : Bien spécifier qu'il faut garder les 2 lignes "option 11" dans le fichier client.conf, c'est pas évident, on pense plutôt à une coquille

- IPv6 : dans le script "script_orange_eth0_IPV6.sh" les réseaux sont nommés WAN_IN-6 , WAN_LOCAL-6 et WAN_OUT-6
  Alors que si on active l'IPv6 dans le controleur ils sont nommés WANv6_IN, WANv6_LOCAL et WANv6_OUT, du coup les règles du scripts ne sont pas prises en compte
  AMHA Il serait plus simple de modifier le script (ce que j'ai fait)

- Enfin j'ajoute (je ne l'ai pas vu dans le sujet) la config du static-mapping des enregistrements DHCP pour la TV sur le LAN général; cela permet d'avoir les DNS orange et l'otion DHCP 125 uniquement pour les boitiers TV UHD et garder d'autre DNS pour le reste du LAN.
N.B. : la technique doit être adaptable pour mettre la LiveBox sur le LAN général pour le téléphone également. Je mettrais à jour quand je l'aurais fait

192.168.XX.XX --> le LAN
YY-YY-YY-YY-YY-YY & YY:YY:YY:YY:YY:YY --> l'adresse MAC du boitier TV UHD (bien garder les notations avec - et : )
la chaine de "option vivso" est la même que celle issue du script de zoc avec
      o   YY:YY:YY:YY:YY:YY  // avec 3 premiers octets de l'adresse MAC de la LIVEBOX codé en hexa
      o   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX  // avec le numéro de série de LIVEBOX codé en hexa.
      o   VV  // par la version LIVEBOX codée en hexa (33 V3, 34 V4)

Cette config est pour le DHCP natif de l'USG (ISC il me semble). Je n'ai pas essayé en passant en dnsmasq, il est probable qu'il faille adapter les 2 options "static-mapping-parameters"

au format "config.gateway.json" (comme toujours valider le config.gateway.json avec https://jsonlint.com après modif)
{
"service": {
"dhcp-server": {
"shared-network-name": {
"net_LAN_eth1_192.168.XX.0-24": {
"subnet": {
"192.168.XX.0/24": {
"static-mapping": {
"YY-YY-YY-YY-YY-YY": {
"host-record": "disable",
"ip-address": "192.168.XX.XX",
"mac-address": "YY:YY:YY:YY:YY:YY",
"static-mapping-parameters": [
"option domain-name-servers 80.10.246.2, 80.10.246.129;",
"option vivso 00:00:0d:e9:24:04:06:YY:YY:YY:YY:YY:YY:05:0f:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:06:09:4c:69:76:65:62:6f:78:20:VV;"
]
}
}

}
}
}
}
}
}
}

au format "configure" directement sur l'USG :
configure
set service dhcp-server shared-network-name net_LAN_eth1_192.168.XX.0-24 subnet 192.168.XX.0/24 static-mapping YY-YY-YY-YY-YY-YY host-record disable
set service dhcp-server shared-network-name net_LAN_eth1_192.168.XX.0-24 subnet 192.168.XX.0/24 static-mapping YY-YY-YY-YY-YY-YY ip-address 192.168.XX.XX
set service dhcp-server shared-network-name net_LAN_eth1_192.168.XX.0-24 subnet 192.168.XX.0/24 static-mapping YY-YY-YY-YY-YY-YY mac-address YY:YY:YY:YY:YY:YY
set service dhcp-server shared-network-name net_LAN_eth1_192.168.XX.0-24 subnet 192.168.XX.0/24 static-mapping YY-YY-YY-YY-YY-YY static-mapping-parameters "option domain-name-servers 80.10.246.2, 80.10.246.129;"
set service dhcp-server shared-network-name net_LAN_eth1_192.168.XX.0-24 subnet 192.168.XX.0/24 static-mapping YY-YY-YY-YY-YY-YY static-mapping-parameters "option vivso 00:00:0d:e9:24:04:06:YY:YY:YY:YY:YY:YY:05:0f:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:06:09:4c:69:76:65:62:6f:78:20:VV;"
commit
save
exit

Jules93

  • Client Orange Fibre
  • *
  • Messages: 10
  • Les Lilas 93170
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #759 le: 08 janvier 2020 à 14:51:50 »
Bonjour à tous

ca fait un moment que je vous lis mais pas simple de tout comprendre.
Mais je me suis lancé car les tutos sont exceptionnels et je dois avouer que j'apprends plein de choses !

J'ai suivi le tuto du post 1 et celui de @Goher car je suis assez proche de de sa configuration. La particularité est que j'ai une Livebox 5...
j'ai changé dans les template, j'ai suivi les indications mais je me connecte pas, l'internet est ko
je n'arrive pas à savoir ou cela bloque.

du coup, je suis revenu a ma config qui me permet de me faire ma compréhension
Livebox --- USG -- switch ubiquiti et decodeur
ca marche mais c est du double NAT donc bof

Toujours pour essayer de comprendre, j'ai 2 décodeurs le 4 et le UHD
dans cette config avec la livebox devant l'USG, si je reboote le décodeur 4 ==> ok probleme
Si je reboote le decodeut UHD :
1) Mauvaise Livebox ==> resolu avec le dhcp vendor specific
2) pas d'attribution d'@IP donc pas de tv

je comprends pas
Merci pour votre aide et mon objectif étant bien de mettre la livebox derriere l'usg et non devant

la67

  • Client Orange Fibre
  • *
  • Messages: 89
  • Eurométropole (67)
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #760 le: 08 janvier 2020 à 18:25:54 »
Pour obtenir une config opérationnelle, la recette est la suivante
- Mettre en place le dhcp client patché (dhclient3) pour la COS6 sur l'USG (la dernière version est la 4.1-ESV-R8)
(voir https://lafibre.info/remplacer-livebox/en-cours-remplacer-sa-livebox-par-un-routeur-ubiquiti-edgemax/msg522426/#msg522426)
- Configurer le WAN dans le contrôleur avec DHCP et VLAN id 832
- Mettre en place le json qui complète ces settings avec les paramètres DHCP non dispo dans le GUI (dont l'identification  client)
(voir https://lafibre.info/remplacer-livebox/le-guide-complet-pour-usgusg-pro-internet-tv-livebox-ipv6/msg692609/#msg692609)
Un reboot et normalement l'USG obtient une @ IP du réseau Orange sur eth0.832.
(La livebox n'a pas d'importance puisqu'elle n'est pas utile à ce step).

Pour la partie TV, le mieux est de créer un VLAN spécifique avec des paramètres DHCP dédiés à la/les box(es) TV à savoir
  • DNS Orange
  • Option 125
Et compléter avec les settings igmp proxy dans le json. Ensuite la TV est opérationnelle.
(voir https://lafibre.info/remplacer-livebox/le-guide-complet-pour-usgusg-pro-internet-tv-livebox-ipv6/msg692609/#msg692609)

Enfin pour la partie téléphone, il faut la livebox. Il faut mettre en place un VLAN 832 côté LAN, tout ce fait au niveau du contrôleur.
  • DNS Orange
  • Option 90/119/120/125
Au reboot de la livebox, elle doit indiquer a Internet OK et Téléphone OK.

Tout cela fonctionne chez moi depuis plus d'un an avec 2 décodeurs TV5 et 0 modifications.

Jules93

  • Client Orange Fibre
  • *
  • Messages: 10
  • Les Lilas 93170
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #761 le: 09 janvier 2020 à 06:37:00 »
a l'étape 10, il y a bien la notion de livebox

set interfaces ethernet eth0 vif 832 dhcp-options client-option "send user-class &quot;\053FSVDSL_livebox.Internet.softathome.Livebox3&quot;;"

set interfaces ethernet eth0 vif 832 dhcp-options client-option "send dhcp-client-identifier 1:YY:YY:YY:YY:YY:YY;"

ou alors je comprends vraiment rien.

Pour la partie décodeur UHD. pour le moment j'en parle en ayant la livebox en frontal puis l'usg. l'UHD refuse de s'identifier.
Si j'utilise l'option 125, le message que le decodeur m'indique qu'il n'y a pas de connexion ethernet

la67

  • Client Orange Fibre
  • *
  • Messages: 89
  • Eurométropole (67)
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #762 le: 09 janvier 2020 à 11:41:42 »
L'option "dhcp-client-identifier" n'est plus utile, on peut s'en passer.
Pour le user class, je pense qu'il faut remonter "Livebox4" plutôt que "Livebox3" si on a une livebox 4 ou 5.

Jules93

  • Client Orange Fibre
  • *
  • Messages: 10
  • Les Lilas 93170
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #763 le: 09 janvier 2020 à 11:49:29 »
j ai fait mais cela ne marche pas

Jules93

  • Client Orange Fibre
  • *
  • Messages: 10
  • Les Lilas 93170
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #764 le: 09 janvier 2020 à 14:54:05 »
pour la petite histoire. Le decodeur affiche : Livebox Fibre avec la livebox 5 alors qu'avec la LB4, le decodeur affiche Livebox 4
mais probleme est peut etre la

benoitc

  • Client Orange Fibre
  • *
  • Messages: 180
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #765 le: 11 janvier 2020 à 09:10:21 »
je lis ici ou là que le marquage de CoS est pas toujours nécessaire, voire plus nécessaire.. est-ce que quelqu’un a essayé recemment sans?

Brouno

  • Client Orange Fibre
  • *
  • Messages: 59
  • Saint-Hilarion (78)
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #766 le: 12 janvier 2020 à 11:37:34 »
Hello,

J'ai une question sur le telephone.

J'ai la livebox sur le port eth2 derrière un USG 3P. j'ai le VLAN 832 OK.

Après config du téléphone, et reboot de la LB4, j'ai bien Internet OK et téléphone OK (et maison connectée OK)

J'ai cependant des soucis avec le téléphone : j'ai bien les appels entrants/sortants qui arrivent, j'arrive à décrocher, mais appels sortant pas d'audio, parfois les entrants aussi. et puis après qques minutes, j'ai "téléphone indisponible" sur la LB4.

Ma config est ok (téléphone OK) avec :
"option Vendor-specific 00:00:05:58:0c:01:0a:00:01:00:00:00:ff:ff:ff:ff:ff;"
"option SIP 00:06:73:62:63:74:33:67:03:56:45:4C:06:61:63:63:65:73:73:11:6f:72:61:6e:67:65:2d:6d:75:6c:74:69:6d:65:64:69:61:03:6e:65:74:00;"

ou

"option Vendor-specific 00:00:05:58:0c:01:0a:00:00:00:00:00:ff:ff:ff:ff:ff;"
"option domain-name &quot;orange.fr&quot;;"
"option domain-search &quot;.VEL.access.orange-multimedia.net.&quot;;"

Mais systématiquement au bouts de qques minutes j'ai "Téléphone indisponible" (et cela revient sans rien faire)

Je pense qu'il y a une config Firewall et/ou NAT ? J'ai ajouté du port forwarding pour le 5060 (pour SIP ?)  il faut aussi les ports RTP ?

Merci de vos lumières
« Modifié: 10 mars 2020 à 16:56:24 par Brouno »

axeit

  • Client Orange Fibre
  • *
  • Messages: 21
  • Versailles (78)
Le guide complet pour USG/USG PRO (Internet, TV, Livebox & IPV6)
« Réponse #767 le: 18 janvier 2020 à 17:14:34 »
Bonjour,

Je viens de recevoir mon USG Pro et en suivant la procédure et vos conseils, j’ai réussi du premier coup la configuration IP v4. Je verrais plus tard pour la partie v6 et je n’ai pas besoin de la TV ni du tel. Comparativement au temps qu’il m’avait fallu pour faire la même chose en suivant un autre fil sur le DD-WRT et l’Asus RT-AC68U, en gros, une semaine, c’est un vrai plaisir ici. Merci à tous pour ce fabuleux travail, c’est génial d’avoir un USG plutôt qu’une Livebox !

 

Mobile View