Auteur Sujet: Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas  (Lu 2916 fois)

0 Membres et 1 Invité sur ce sujet

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Bonjour,

j'ai migré chez Bouygues depuis une semaine pour l'offre Bbox Must Fibre Internet-TV-Téléphonie.

J'ai réussi à me connecter à internet via mon routeur TP-Link TL-WR1043ND v2 en suivant les nombreux sujets sur le forum. Après ne nombreuses heures de recherche je sèche complètement sur la partie TV qui m'affiche la fameuse erreur F3411.

Mon architecture est la suivante:

VLAN 100 sur port dédié pour la connexion fibre
VLAN 1 pour mon réseau local internet (y compris la TV) réseau 192.168.1.0
VLAN 2 sur un port dédié pour un équipement spécifique complètement isolé du reste réseau 192.168.2.0

Voici ma configuration réseau ci-dessous, je pense qu'il y à quelque chose que je doit louper.

En dehors de la TV la box sous Android TV fonctionne correctement (connecté à internet, applis, infos de programme TV, etc.)

/etc/config/network
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd77:5e15:e117::/48'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '6t 3 2 1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '2'
        option ports '6t 4'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 5t'
        option vid '100'

config interface 'wan'
        option ifname 'eth1.100'
        option proto 'dhcp'
        option macaddr '29:9E:FC:D6:0A:F8'
        option broadcast '1'

config interface 'lan1'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.254'
        option type 'bridge'
        option igmp_snooping 1

config interface 'lan2'
        option ifname 'eth0.2'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.254'

/etc/config/firewall:

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option drop_invalid '1'
        option synflood_protect '1'
        option forward 'REJECT'

config include
        option path '/etc/firewall.user'

config zone
        option name 'wan'
        option masq '1'
        option network 'wan'
        option output 'ACCEPT'
        option input 'REJECT'
        option forward 'REJECT'

config zone
        option name 'lan1'
        option network 'lan1'
        option output 'ACCEPT'
        option input 'ACCEPT'
        option forward 'REJECT'

config forwarding
        option dest 'wan'
        option src 'lan1'

config zone
        option name 'lan2'
        option network 'lan2'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config forwarding
        option dest 'wan'
        option src 'lan2'

config redirect
        option dest_port '5001'
        option src 'wan'
        option name 'VIDEOSURVEILLANCE'
        option src_dport '60606'
        option target 'DNAT'
        option dest_ip '192.168.2.100'
        option dest 'lan2'
        list proto 'tcp'

config forwarding                     
        option dest 'lan2'             
        option src 'lan1'             
                                       
config rule                           
        option src 'wan'               
        option name 'Allow-IGMP'       
        option dest 'lan1'             
        option target 'ACCEPT'         
        list dest_ip 'fe80::ee6c:9aff:febf:14c0'
        list dest_ip '192.168.1.159'           
        list proto 'udp'                       
        list proto 'igmp'                       
        option enabled '0'                     
                                               
config rule                                     
        option target 'ACCEPT'                 
        list proto 'igmp'                       
        option src 'wan'                       
                                               
config rule                                     
        option src 'wan'                       
        option target 'ACCEPT'                 
        option dest 'lan1'                     
        list dest_ip '224.0.0.0/4'             
        option family 'ipv4'                   
        list proto 'udp' 

/etc/config/igmpproxy:
config igmpproxy
        option quickleave 1
#       option verbose [0-3](none, minimal[default], more, maximum)

config phyint
        option network wan
        option direction upstream
        list altnet 0.0.0.0/0

config phyint
        option network lan1
        option direction downstream

Ce que je comprend pas dans les config et peut être l'erreur vient de la, on demande de mettre le lan1 en mode bridge, mais pour moi il est birdgé à bien concernant la partie TV, il est uniquement bridgé ç l'interface wifi, alors est-ce que je doit pas créé une interface sur un port dédié pour la TV et la brigé au WAN plutôt ?

Merci d'avance pour votre aide.

Eliott.






mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #1 le: 04 décembre 2020 à 13:13:56 »
Bonjour,
Il manque 2 choses:
- IGMP v2 à forcer dans les variables sysctl
- marquage p3 des paquets IGMP en sortie de l'interface WAN (certains n'en ont pas besoin mais c'est à savoir)

eahlys

  • Expert Bouygues Telecom
  • Client Bbox fibre
  • *
  • Messages: 666
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #2 le: 04 décembre 2020 à 13:28:17 »
Hello,
J'ai un ubiquiti edgerouter chez moi et j'ai tenté exactement la même chose : je n'ai jamais réussi à faire fonctionner la TV. Alors perso pas grave pour moi c'était juste pour le plaisir de bidouiller, je regarde pas la TV en direct. Mais j'y ai passé des heures, ça a JAMAIS marché. L'IGMP a ses raisons que la raison ignore.
Si tu réussis à faire tout marcher nickel, je prends :)

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #3 le: 04 décembre 2020 à 13:44:24 »
La première chose à vérifier reste à vérifier en sortie WAN que les paquets IGMP v2 sont émis et reçus à peu près comme cela:
13:37:48.103073 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > all-routers.mcast.net: igmp leave 239.255.3.22
13:37:48.118924 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > all-routers.mcast.net: igmp leave 239.255.255.251
13:37:50.283431 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.255.251: igmp v2 report 239.255.255.251
13:37:50.793436 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.3.22: igmp v2 report 239.255.3.22
13:37:51.043439 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.3.22: igmp v2 report 239.255.3.22
13:37:52.683444 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.3.22: igmp v2 report 239.255.3.22
13:37:54.193432 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.255.251: igmp v2 report 239.255.255.251
13:38:02.923461 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.255.251: igmp v2 report 239.255.255.251
13:38:19.558452 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
13:38:20.363426 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > all-routers.mcast.net: igmp v2 report all-routers.mcast.net
13:38:20.993434 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > hp-device-disc.mcast.net: igmp v2 report hp-device-disc.mcast.net
13:38:20.993453 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.255.251: igmp v2 report 239.255.255.251
13:38:21.633433 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > igmp.mcast.net: igmp v2 report igmp.mcast.net
13:38:22.273432 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.192.0.0: igmp v2 report 239.192.0.0
13:38:22.363436 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 232.0.64.238: igmp v2 report 232.0.64.238
13:38:22.363445 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.3.22: igmp v2 report 239.255.3.22
13:38:26.593443 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > ntp.mcast.net: igmp v2 report ntp.mcast.net
13:38:28.523427 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.192.152.143: igmp v2 report 239.192.152.143
13:40:24.606700 IP 0.0.0.0 > all-systems.mcast.net: igmp query v2
13:40:25.043427 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 232.0.64.238: igmp v2 report 232.0.64.238
13:40:25.793443 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > igmp.mcast.net: igmp v2 report igmp.mcast.net
13:40:27.073441 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.255.251: igmp v2 report 239.255.255.251
13:40:28.993435 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.192.152.143: igmp v2 report 239.192.152.143
13:40:30.763430 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > all-routers.mcast.net: igmp v2 report all-routers.mcast.net
13:40:31.393426 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.192.0.0: igmp v2 report 239.192.0.0
13:40:32.043450 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > hp-device-disc.mcast.net: igmp v2 report hp-device-disc.mcast.net
13:40:32.673597 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > ntp.mcast.net: igmp v2 report ntp.mcast.net
13:40:33.313438 IP plh29-h01-176-133-x-y.dsl.sta.abo.bbox.fr > 239.255.3.22: igmp v2 report 239.255.3.22
J'ai une imprimante HP et des annonces de serveurs NTP en multicast.

Notez bien l'adresse 0.0.0.0 qui est source chez ByTel.

Le marquage 802.1p3 n'apparaît pas, il faudrait que je remonte un bridge pour le montrer.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #4 le: 04 décembre 2020 à 18:38:33 »
Bonjour merci pour vos réponses.

Pour le IGMP V2 c'est fait, oublis de ma part dans mon premier post: dans /etc/sysctl.conf: net.ipv4.conf.all.force_igmp_version=2

Citer
marquage p3 des paquets IGMP en sortie de l'interface WAN (certains n'en ont pas besoin mais c'est à savoir)

Ca je n'ai aucune idée de ce que c'est, je vais me renseigner.

Pour vérifier le packet igmp il faudrait que je sniff le réseau avec wireshark entre le modem vibre et la bbox ?

Je vois pas trop comment faire vu que j'ai aucun PC avec deux cartes réseau, par contre je dispose d'un autre routeur TPlink 1043 ND qui est sous open wrt.

J'ai également pensé à une solution mais je ne sais pas si c'est possible:

Je créé une nouvelle interface sur un port LAN que je bridge avec le WAN sur laquelle je branche la box, est-ce qu'il me faudra 2 ip, est-ce que mon isp me le permettra ?

Merci pour votre aide.

eahlys

  • Expert Bouygues Telecom
  • Client Bbox fibre
  • *
  • Messages: 666
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #5 le: 04 décembre 2020 à 19:08:26 »
Pour vérifier le packet igmp il faudrait que je sniff le réseau avec wireshark entre le modem vibre et la bbox ?

Le moyen le moins chiant de faire ça c'est avec un switch en mode mirroring. Mettre un PC en coupure entre la box et l'ONT c'est un peu une tannée à faire (et faut deux cartes réseau, yes)

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #6 le: 04 décembre 2020 à 19:43:35 »
Salut,

j'ai remis la BBOX et j'ai fait un partage de connexion entre ethernet de mon mac et carte wifi.

J'ai ensuite connecté la bbox en wifi à mon mac.

Maintenant avec wireshark je vois ce qui passe entre le BBXO et le BOITIER TV.

Si j'ai bien compris je doit chercher de paquets ICMP, faite vous plaisir si cela intéresse certain à me demander ce que vous voulez sniffer, c'est l'occasion...

EDIT:

visiblement les échanges ICMP entre la BBOX et la box TV est depuis l'ip 104.84.70.78

12604   55.411438   104.84.70.78   192.168.3.3   98   ICMP   Echo (ping) reply    id=0x0022, seq=2/512, ttl=52 (request in 12603)

EDIT 2:

côté UDP j'ai ça: fichier en PJ.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #7 le: 04 décembre 2020 à 20:04:55 »
Un capture exhaustive je pense.

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #8 le: 04 décembre 2020 à 22:02:04 »
IGMP v3 c'est pas bon.
Est-ce que la variable sysctl est bien appliquée ?
Chez moi, ça suffit:
net.ipv4.conf.all.force_igmp_version=2
net.ipv4.conf.all.mc_forwarding=1

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #9 le: 04 décembre 2020 à 22:38:57 »
Je n'ai jamais ajouté la ligne "net.ipv4.conf.all.mc_forwarding=1"

Par contre les images viennent de la com entre la BBOX et le boitier TV, mon TP-LINK est off dans ce cas.

Donc c'est le boitier TV qui fait une requête IGMPv3 à 224.0.0.24

Ne faut-il pas forcer l'igmp du TP-LINK en version 3 au lieu de 2 justement ?

Eliott.

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #10 le: 05 décembre 2020 à 00:02:14 »
Il faut regarder entre la bbox et l'ONT les paquets IGMP pour être sûr mais de mon côté, j'ai uniquement vu de l'IGMP v2.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #11 le: 05 décembre 2020 à 01:40:55 »
Par rapport à ton premier message, j'ai fait un tcpdum si ça peu aider, en configuration avec le openwrt branché sur la Bbox TV:

root@OpenWrt:/etc/config# tcpdump -i eth1.100 icmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.100, link-type EN10MB (Ethernet), capture size 262144 bytes
00:37:17.874258 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:17.979244 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64
00:37:18.509410 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > nsabo2.bouyguesbox.fr: ICMP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr udp port 33054 unreachable, length 320
00:37:24.034159 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:24.139290 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64
00:37:30.195758 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:30.300388 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64
00:37:36.353936 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:36.458659 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64
00:37:40.556177 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > nsabo2.bouyguesbox.fr: ICMP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr udp port 61860 unreachable, length 276
00:37:42.513967 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:42.619022 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64
00:37:48.673854 IP i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr > public1.114dns.com: ICMP echo request, id 34818, seq 0, length 64
00:37:48.778596 IP public1.114dns.com > i15-les02-ntr-176-181-167-132.sfr.lns.abo.bbox.fr: ICMP echo reply, id 34818, seq 0, length 64