Auteur Sujet: Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas  (Lu 2997 fois)

0 Membres et 1 Invité sur ce sujet

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #24 le: 05 décembre 2020 à 12:17:45 »
Oui, c'est le paramétrage chez ByTel mais pas forcément pour tout le monde d'après les retours que j'ai pu lire.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #25 le: 05 décembre 2020 à 12:39:53 »
Alors en fait j'ai un peu crier victoire trop tôt.

J'ai que TF1, M6 et CNEWS qui fonctionnent.

Quand la box est démrrée et que je zappe de TF1 à France 2 il me met un message ethernet déconnecté, comme si ça plantait la connextion. Mais je revient sur TF1 ça fonctionne quand même...

EDIT: et TF1 à terminé en erreur

J'ai l'impressions qu'il faudrait que Bouygues donnes des infos précise sur la configuration des BBOX pour pouvoir reproduire un truc fiable avec un autre routeur.

A mon avis je vais laisser tomber et passer par la TNT que je regarde peu la TV et ces chaines me suffisent....

A moins que tu ait encore beaucoup d'autres idées de test à faire ?

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #26 le: 05 décembre 2020 à 13:13:45 »
Il faut faire des tcpdump sur l'interface WAN pour contrôler que les paquets IGMP sont correctement émis et reçus et s'assurer que les règles iptables pour l'IGMP et le multicast UDP sont actives.
Si tu as installé les scripts et configurations donnés, il vaut mieux redémarrer openwrt.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #27 le: 05 décembre 2020 à 13:28:44 »
Voilà un dernier dump, j'ai redémarrer pas mal de fois le routeur et le box entre différentes configs

DUMP sur TF1 qui fonctionne:

root@OpenWrt:/etc/config# tcpdump -i eth1 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
12:23:26.764434 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:23:32.204893 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:23:33.484484 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:23:34.124476 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:23:42.444418 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:23:43.084425 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:23:43.724487 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:23:45.004444 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:23:55.884424 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:23:55.884743 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:23:57.804420 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:23:58.444441 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:24:06.044421 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:24:09.654404 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:24:09.694421 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:24:10.604412 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:24:11.084406 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:24:21.644405 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:24:25.244409 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:24:27.884408 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:24:27.885303 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:24:31.514418 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:24:32.604414 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:24:35.966906 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:24:36.844430 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:24:46.124517 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:24:47.094448 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:24:51.944446 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:24:52.024538 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:24:54.924467 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:24:57.964459 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:25:04.764488 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:25:06.284473 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:25:06.285420 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:25:12.044519 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:25:15.224522 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:25:19.084532 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:25:19.085421 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
12:25:24.844509 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250

DUMP sur FRANCE2 qui fonctionne maintenant:

root@OpenWrt:/etc/config# tcpdump -i eth1 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
12:26:48.694753 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
12:26:49.814747 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
12:26:58.044895 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:26:59.884916 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
12:27:01.484880 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:27:01.485595 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:27:09.244965 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:27:13.005011 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
12:27:13.645028 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:27:14.285034 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:27:18.115051 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:27:19.005080 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:27:21.165098 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:27:23.245113 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202

DUMP sur FRANCE3 qui fonctionne pas:

listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
12:27:52.045415 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
12:27:53.334925 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.66.73
12:28:03.245494 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:28:03.565526 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:28:08.685534 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:28:10.605542 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:28:13.085572 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:28:18.285603 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
12:28:22.125633 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
12:28:22.605641 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
12:28:27.885697 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251


mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #28 le: 05 décembre 2020 à 13:39:58 »
Il faut faire un tcpdump sur au moins 5 minutes et vérifier que 0.0.0.0 émet un paquet IGMP toutes les 2 à 3 minutes et analyser le fichier pcap de tcpdump pour vérifier le marquage p3.

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #29 le: 05 décembre 2020 à 16:21:36 »
J'ai laissé tourné cette commande pendant 20 minutes:

root@OpenWrt:/etc/perso# tcpdump -i eth0 igmp -w /etc/perso/dump.pcap
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes

Il n'y à aucun paquet qui est passé, il y à bien une entête en binaire mais si je l'ouvre avec wireshark il est vide.

Vu que j'ai fait pas mal de config (notamment la création d'une interface iptv dédiée) je remet les fichier de config peut être que une erreur c'est glissée. Là en gros j'ai quelque chaines qui fonctionnement pendant 5 minutes et puis ça coupe.

Interface:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd77:5e15:e117::/48'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '6t 2 1'

config switch_vlan
option device 'switch0'
option vlan '2'
option vid '2'
option ports '6t 4'

config switch_vlan
option device 'switch0'
option vlan '3'
option ports '0t 5t'
option vid '100'

config interface 'wan'
option ifname 'eth1.100'
option proto 'dhcp'
option macaddr '28:9E:FC:D6:0A:F8'
option vendorid 'BYGTELIAD'
option clientid '289EFCD60AF8'

config interface 'lan1'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.1.254'
option type 'bridge'

config interface 'lan2'
option ifname 'eth0.2'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.2.254'

config interface 'iptv'
option type 'bridge'
option delegate '0'
option proto 'static'
option igmp_snooping '1'
option ipaddr '192.168.3.254'
option netmask '255.255.255.0'
option ifname 'eth1.3'
option force_link '0'

config switch_vlan
option device 'switch0'
option vlan '4'
option ports '0t 3'
option vid '3'

Firewall:

config zone
option name 'wan'
option masq '1'
option output 'ACCEPT'
option forward 'DROP'
option input 'REJECT'
option network 'wan'

config zone
option name 'lan1'
option output 'ACCEPT'
option input 'ACCEPT'
option forward 'DROP'
option network 'lan1'

config forwarding
option dest 'wan'
option src 'lan1'

config zone
option name 'lan2'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'DROP'
option network 'lan2'

config forwarding
option dest 'wan'
option src 'lan2'

config rule
option src 'wan'
option proto 'udp'
option family 'ipv4'
option target 'ACCEPT'
option dest 'iptv'
option name 'IPTV'

config rule
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
option dest 'iptv'
option name 'IGMP'

config zone
option input 'ACCEPT'
option name 'iptv'
option output 'ACCEPT'
option forward 'DROP'
option network 'iptv'

config forwarding
option dest 'wan'
option src 'iptv'

IGMPPROXY:

config phyint
option network wan
option direction upstream
list altnet 0.0.0.0/0

config phyint
option network iptv
option zone iptv
option direction downstream

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #30 le: 05 décembre 2020 à 16:28:27 »
Voilà l'extrait du tcp dump quand je passe d'un chaine à l'autre (un chaine qui fonctionne à celle qui fonctionne pas):

On vois bien les paquet UPD qui s'arrêtent.

16:26:40.956788 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.957643 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.958548 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.958661 IP 89.86.97.6.49152 > 232.0.64.202.8202: UDP, length 1344
16:26:40.959416 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.960358 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.961169 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.962027 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.962929 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.963789 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.964683 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.965536 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.966445 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.966548 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.64.202
16:26:40.967319 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.968777 IP OpenWrt.lan > 232.0.64.202: igmp query v2 [gaddr 232.0.64.202]
16:26:40.969250 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.969346 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.970331 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.970440 IP 89.86.97.6.49152 > 232.0.64.202.8202: UDP, length 1344
16:26:40.971309 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.971995 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.972744 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.973439 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.974363 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.975207 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.976094 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.976967 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:40.977818 IP 89.86.97.6.49152 > 232.0.64.202.8200: UDP, length 1328
16:26:41.049221 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:26:44.079048 IP OpenWrt.lan > 232.0.64.202: igmp query v2 [gaddr 232.0.64.202]
16:26:45.285378 IP6 fe80::12fe:edff:fee6:7c04 > ip6-allrouters: HBH ICMP6, multicast listener reportmax resp delay: 0 addr: ip6-allrouters, length 24
16:26:45.969443 IP Bouygtel4K-272011032208462.lan.5353 > 224.0.0.251.5353: 0 PTR (QM)? _googlecast._tcp.local. (40)
16:26:45.971278 IP Bouygtel4K-272011032208462.lan.5353 > 224.0.0.251.5353: 0*- [0q] 1/0/3 PTR Bouygtel4K-796f1090b4244f7044b7a4057a51bdf0._googlecast._tcp.local. (344)
16:26:47.269118 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:26:50.091775 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.66.73
16:26:50.092462 IP OpenWrt.lan > 232.0.66.73: igmp query v2 [gaddr 232.0.66.73]
16:26:50.247931 IP Bouygtel4K-272011032208462.lan.43352 > mrs09s09-in-f8.1e100.net.443: Flags [P.], seq 229953572:229954419, ack 2749090393, win 65535, options [nop,nop,TS val 167977 ecr 2393472855], length 847
16:26:50.256679 IP mrs09s09-in-f8.1e100.net.443 > Bouygtel4K-272011032208462.lan.43352: Flags [.], ack 847, win 65535, options [nop,nop,TS val 2393593789 ecr 167977], length 0
16:26:50.267173 IP mrs09s09-in-f8.1e100.net.443 > Bouygtel4K-272011032208462.lan.43352: Flags [P.], seq 1:625, ack 847, win 65535, options [nop,nop,TS val 2393593800 ecr 167977], length 624
16:26:50.267459 IP Bouygtel4K-272011032208462.lan.43352 > mrs09s09-in-f8.1e100.net.443: Flags [.], ack 625, win 65535, options [nop,nop,TS val 167979 ecr 2393593800], length 0
16:26:50.947751 IP Bouygtel4K-272011032208462.lan.39312 > mrs09s09-in-f14.1e100.net.443: Flags [P.], seq 547690241:547691292, ack 1030795730, win 65535, options [nop,nop,TS val 168047 ecr 3568701629], length 1051
16:26:50.956896 IP mrs09s09-in-f14.1e100.net.443 > Bouygtel4K-272011032208462.lan.39312: Flags [.], ack 1051, win 65535, options [nop,nop,TS val 3568813871 ecr 168047], length 0
16:26:50.979592 IP mrs09s09-in-f14.1e100.net.443 > Bouygtel4K-272011032208462.lan.39312: Flags [P.], seq 1:486, ack 1051, win 65535, options [nop,nop,TS val 3568813893 ecr 168047], length 485
16:26:50.979878 IP Bouygtel4K-272011032208462.lan.39312 > mrs09s09-in-f14.1e100.net.443: Flags [.], ack 486, win 65535, options [nop,nop,TS val 168051 ecr 3568813893], length 0
16:26:52.399838 IP Bouygtel4K-272011032208462.lan.42123 > OpenWrt.lan.53: 38260+ A? mabbox.bytel.fr. (33)
16:26:52.409634 IP OpenWrt.lan.53 > Bouygtel4K-272011032208462.lan.42123: 38260 NXDomain 0/1/0 (114)
16:26:52.409984 IP Bouygtel4K-272011032208462.lan.63778 > OpenWrt.lan.53: 61096+ A? mabbox.bytel.fr.lan. (37)
16:26:52.410428 IP OpenWrt.lan.53 > Bouygtel4K-272011032208462.lan.63778: 61096 NXDomain 0/0/0 (37)
16:26:52.422599 IP Bouygtel4K-272011032208462.lan.41027 > OpenWrt.lan.53: 50992+ A? gestionbbox.lan. (33)
16:26:52.423058 IP OpenWrt.lan.53 > Bouygtel4K-272011032208462.lan.41027: 50992 NXDomain 0/0/0 (33)
16:26:52.423348 IP Bouygtel4K-272011032208462.lan.54580 > OpenWrt.lan.53: 49827+ A? gestionbbox.lan.lan. (37)
16:26:52.423790 IP OpenWrt.lan.53 > Bouygtel4K-272011032208462.lan.54580: 49827 NXDomain 0/0/0 (37)
16:26:53.095487 IP OpenWrt.lan > 232.0.66.73: igmp query v2 [gaddr 232.0.66.73]
16:26:55.445329 ARP, Request who-has Bouygtel4K-272011032208462.lan tell OpenWrt.lan, length 28
16:26:55.445835 ARP, Reply Bouygtel4K-272011032208462.lan is-at ec:6c:9a:bf:14:c0 (oui Unknown), length 46
16:26:56.098948 IP OpenWrt.lan > 232.0.66.73: igmp query v2 [gaddr 232.0.66.73]
^C

Et j'ai bien des requêtes IGMP qui passent de temps  à autre.

16:26:26.774700 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.775630 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.775812 IP OpenWrt.lan > all-systems.mcast.net: igmp query v2
16:26:26.776484 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.777365 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.778228 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.779118 IP 89.86.97.6.49152 > 232.0.64.201.8202: UDP, length 1344
16:26:26.779232 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.779510 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
16:26:26.780071 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328
16:26:26.780842 IP 89.86.97.6.49152 > 232.0.64.201.8200: UDP, length 1328

Ce qui est bizarre sur le WAN c'et que je vois bien les réponses IGMP (j'en ait pas mal sur les chaines qui fonctionnent pas et au changement de chaine, moins sur une chaine établie) mais je vois pas les query du wan:

root@OpenWrt:/etc/perso# tcpdump -i eth1 igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
16:40:00.231261 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:00.371209 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:03.184910 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.66.73
16:40:03.361259 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
16:40:06.071344 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
16:40:08.391255 IP Bouygtel4K-272011032208462.lan > 232.0.64.202: igmp v2 report 232.0.64.202
16:40:10.007445 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.64.202
16:40:10.101323 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:10.551329 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
16:40:12.711333 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:15.191321 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:16.231370 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
16:40:18.791385 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
16:40:19.138728 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.66.73
16:40:21.221384 IP Bouygtel4K-272011032208462.lan > 232.0.33.1: igmp v2 report 232.0.33.1
16:40:25.351415 IP Bouygtel4K-272011032208462.lan > 232.0.33.1: igmp v2 report 232.0.33.1
16:40:28.391368 IP Bouygtel4K-272011032208462.lan > 232.0.33.1: igmp v2 report 232.0.33.1
16:40:30.267710 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.33.1
16:40:30.631370 IP Bouygtel4K-272011032208462.lan > 239.255.255.250: igmp v2 report 239.255.255.250
16:40:36.071396 IP Bouygtel4K-272011032208462.lan > 239.255.3.22: igmp v2 report 239.255.3.22
16:40:37.451401 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:39.271407 IP Bouygtel4K-272011032208462.lan > 224.0.0.251: igmp v2 report 224.0.0.251
16:40:45.031430 IP Bouygtel4K-272011032208462.lan > 232.0.66.73: igmp v2 report 232.0.66.73
16:40:46.502188 IP Bouygtel4K-272011032208462.lan > all-routers.mcast.net: igmp leave 232.0.66.73
16:40:46.691472 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
16:40:48.551414 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201
16:40:51.911415 IP Bouygtel4K-272011032208462.lan > 232.0.64.201: igmp v2 report 232.0.64.201

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #31 le: 05 décembre 2020 à 16:57:20 »
Est-ce que les paquets IGMP sont bien marqués p3 en sortie sur l'interface WAN ?

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #32 le: 05 décembre 2020 à 17:05:39 »
Le problème c'est qu'il me semble pas voir les packet IGMP en provenance du WAN, je vois que la réponse de la BBOX.

Voilà mon dump fait avec la commande "tcpdump -i eth1 igmp -w /etc/perso/dump.pcap"

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #33 le: 05 décembre 2020 à 17:10:04 »
En regardant sur toutes les interfaces j'ai réussi à voir de l'IGMP depuis mon WAN (de mon IP publique visiblement)

Mais rien en source 0.0.0.0. et pas de champ 802.1Q ...

"tcpdump -i any igmp -w /etc/perso/dump.pcap"


mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 128
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #34 le: 05 décembre 2020 à 17:19:22 »
Il faut uniquement faire un tcpdump sur le wan sans le vlan (eth0 ici) et regarder si une priorité 802.1p est ajoutée si ce n'est pas le cas:
- soit il y a un problème de configuration
- soit le matériel ne le permet pas (j'avais réussi sur un ER-X mais avec un sacrifice des performances).

Eliott

  • Client Bbox fibre
  • *
  • Messages: 23
Remplacer Bbox par routeur TP-LINK sous Open WRT, TV ne fonctionne pas
« Réponse #35 le: 05 décembre 2020 à 17:32:44 »
je confirme que mon wan est bien "eth1" et je vois aucun paquet attendu comme sur ta capture.

Par contre vu que la BBOX répond c'est un mystère pour moi.

visiblement avec Openwrt les VLAN sont par défaut en 802.1Q:

Citer
Name   Type                   Required   Default   Description
type           VLAN Type   no           802.1q   VLAN type, possible values: 8021q or 8021ad