Auteur Sujet: Exigences TV  (Lu 4273 fois)

0 Membres et 1 Invité sur ce sujet

bulle21

  • Client Bbox fibre
  • *
  • Messages: 44
Exigences TV
« Réponse #36 le: 22 septembre 2020 à 17:42:54 »
sudo tcpdump -i eth1.52 -n igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1.52, link-type EN10MB (Ethernet), capture size 262144 bytes
17:41:27.797728 IP 10.0.10.1 > 224.0.0.1: igmp query v2
17:41:29.500008 IP 10.0.10.52 > 239.255.3.22: igmp v2 report 239.255.3.22
17:41:29.899691 IP 10.0.10.52 > 239.255.255.250: igmp v2 report 239.255.255.250
17:41:33.537161 IP 10.0.10.1 > 233.89.188.1: igmp v2 report 233.89.188.1
17:41:35.457147 IP 10.0.10.1 > 224.0.0.2: igmp v2 report 224.0.0.2
17:41:38.017139 IP 10.0.10.1 > 224.0.0.22: igmp v2 report 224.0.0.22
^C
6 packets captured
6 packets received by filter
0 packets dropped by kernel
« Modifié: 22 septembre 2020 à 18:14:55 par bulle21 »

mirtouf

  • Client Bbox fibre
  • *
  • Messages: 1 119
  • FTTH (Must) sur Chelles (77)
    • L'antre de la bête
Exigences TV
« Réponse #37 le: 22 septembre 2020 à 17:58:10 »
Je ne me souvenais plus que les règles étaient suffisantes pour avoir l'IGMP qui fonctionne.

bulle21

  • Client Bbox fibre
  • *
  • Messages: 44
Exigences TV
« Réponse #38 le: 22 septembre 2020 à 18:12:23 »
L'IGMP c'est du multicast. Je ne dis pas c'est la bonne façon de faire.
sudo tcpdump -i eth0.100 -vv :
18:05:24.301520 IP (tos 0xe0, ttl 63, id 18215, offset 0, flags [none], proto UDP (17), length 73)
    176-144-x-y.abo.bbox.fr.49153 > nsabo1.bouyguesbox.fr.domain: [udp sum ok] 22826+ AAAA? time-a.timefreq.bld
18:05:24.301804 IP (tos 0xe0, ttl 63, id 58154, offset 0, flags [none], proto UDP (17), length 73)
    176-144-x-y.abo.bbox.fr.49153 > nsabo2.bouyguesbox.fr.domain: [udp sum ok] 22826+ AAAA? time-a.timefreq.bld
18:05:24.304727 IP (tos 0x80, ttl 250, id 18215, offset 0, flags [none], proto UDP (17), length 147)
    nsabo1.bouyguesbox.fr.domain > 176-144-x-y.abo.bbox.fr.49153: [udp sum ok] 22826 q: AAAA? time-a.timefreq.b
18:05:24.741020 IP (tos 0x0, ttl 64, id 10175, offset 0, flags [DF], proto UDP (17), length 73)
    176-144-x-y.abo.bbox.fr.57386 > nsabo1.bouyguesbox.fr.domain: [udp sum ok] 44375+ PTR? 22.124.144.176.in-ad
18:05:24.745689 IP (tos 0x80, ttl 59, id 11531, offset 0, flags [none], proto UDP (17), length 113)
    nsabo1.bouyguesbox.fr.domain > 176-144-x-y.abo.bbox.fr.57386: [udp sum ok] 44375 q: PTR? 22.124.144.176.in-
18:05:24.747107 IP (tos 0x0, ttl 64, id 10176, offset 0, flags [DF], proto UDP (17), length 73)
    176-144-x-y.abo.bbox.fr.55454 > nsabo1.bouyguesbox.fr.domain: [udp sum ok] 19980+ PTR? 10.122.158.194.in-ad
18:05:24.750805 IP (tos 0x80, ttl 250, id 10176, offset 0, flags [none], proto UDP (17), length 108)
    nsabo1.bouyguesbox.fr.domain > 176-144-x-y.abo.bbox.fr.55454: [udp sum ok] 19980 q: PTR? 10.122.158.194.in-
18:05:24.752067 IP (tos 0x0, ttl 64, id 10177, offset 0, flags [DF], proto UDP (17), length 73)
    176-144-x-y.abo.bbox.fr.41881 > nsabo1.bouyguesbox.fr.domain: [udp sum ok] 2766+ PTR? 15.122.158.194.in-add
18:05:24.755300 IP (tos 0x80, ttl 59, id 16779, offset 0, flags [none], proto UDP (17), length 108)
    nsabo1.bouyguesbox.fr.domain > 176-144-x-y.abo.bbox.fr.41881: [udp sum ok] 2766 q: PTR? 15.122.158.194.in-a
18:05:25.714798 IP (tos 0x0, ttl 63, id 0, offset 0, flags [DF], proto TCP (6), length 107)
    176-144-x-y.abo.bbox.fr.51231 > 216.218.230.212.8002: Flags [P.], cksum 0xde4e (correct), seq 3379178099:33
18:05:25.779126 IP (tos 0x0, ttl 64, id 10217, offset 0, flags [DF], proto UDP (17), length 74)
    176-144-x-y.abo.bbox.fr.34928 > nsabo1.bouyguesbox.fr.domain: [udp sum ok] 12867+ PTR? 212.230.218.216.in-a
18:05:25.811980 IP (tos 0x80, ttl 59, id 11597, offset 0, flags [none], proto UDP (17), length 131)
- ll 1/289 0%

sudo tcpdump -i eth0.100 -n igmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0.100, link-type EN10MB (Ethernet), capture size 262144 bytes
18:35:47.998797 IP 176.144.x-y > 224.0.0.2: igmp leave 232.0.64.206   
18:35:48.027114 IP 176.144.x-y > 232.0.64.206: igmp v2 report 232.0.64.206   
18:35:55.617146 IP 176.144.x-y > 232.0.64.206: igmp v2 report 232.0.64.206   
18:36:05.217166 IP 176.144.x-y > 232.0.64.206: igmp v2 report 232.0.64.206   
18:36:15.723767 IP 0.0.0.0 > 224.0.0.1: igmp query v2
18:36:16.357129 IP 176.144.x-y > 239.255.250.250: igmp v2 report 239.255.250.250   
18:36:18.817128 IP 176.144.x-y > 233.89.188.1: igmp v2 report 233.89.188.1   
18:36:20.177140 IP 176.144.x-y > 239.255.255.250: igmp v2 report 239.255.255.250   
18:36:21.857131 IP 176.144.x-y > 239.255.3.22: igmp v2 report 239.255.3.22   
18:36:24.417127 IP 176.144.x-y > 239.255.255.246: igmp v2 report 239.255.255.246   
18:36:24.417271 IP 176.144.x-y > 232.0.64.206: igmp v2 report 232.0.64.206   
^C
11 packets captured
11 packets received by filter
0 packets dropped by kernel
« Modifié: 22 septembre 2020 à 18:39:28 par bulle21 »

glok

  • Client Bbox fibre
  • *
  • Messages: 3
  • Fenain 59
Exigences TV
« Réponse #39 le: 29 décembre 2020 à 20:43:45 »
Bonjour,

De mon côté, rien à faire.
J'arrive a diffuser quelques chaines mais pas toutes.
De plus même en ayant fait le marquage COS3 avec mon cisco SG250 le flux se coupe au bout de 5min.

J'ai pourtant bien suivi les *Exigences* mais ca veut pas :(

Voici ma conf :

Cisco SG250
config-file-header
cisco
v2.5.5.47 / RTESLA2.5.5_930_364_286
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0.............
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
bridge multicast filtering
vlan database
vlan 100
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
bonjour interface range vlan 1
qos advanced
qos advanced-mode trust cos
mac access-list extended "vlan100"
permit any any vlan 100 ace-priority 1
exit
ip access-list extended IGMP
permit igmp any any ace-priority 1
exit
class-map TV
match access-group IGMP
match access-group "vlan100"
exit
policy-map bbox
class TV
set cos 3
exit
exit
hostname cisco
username blabla password encrypted blabla privilege 15
ip ssh server
ip ssh password-auth
ip ssh-client username admin
encrypted ip ssh-client password blabla
ip ssh-client server authentication
clock timezone J 1
clock source browser
!
interface vlan 1
 ip address 192.168.1.8 255.255.255.0
 no ip address dhcp
!
interface vlan 100
 name Internet
!
interface GigabitEthernet1
 description interco
!
interface GigabitEthernet2
 description router-eth1
!
interface GigabitEthernet3
 description router-eth5
 switchport mode trunk
 switchport access vlan none
 switchport trunk native vlan none
 switchport trunk allowed vlan 100
 switchport customer vlan 100
!
interface GigabitEthernet4
 description ONT
 service-policy output bbox default-action permit-any
 switchport mode trunk
 switchport access vlan none
 switchport general pvid 100
 switchport trunk native vlan none
 switchport trunk allowed vlan 100
!
interface GigabitEthernet5
 switchport mode trunk
 switchport access vlan none
 switchport general pvid 100
 switchport trunk native vlan none
 switchport trunk allowed vlan 100
!
interface GigabitEthernet8
 description Borne-wifi-room
!
exit
ip igmp snooping
ip igmp snooping vlan 1
ip igmp snooping vlan 1 immediate-leave
ip igmp snooping vlan 1 querier


Routeur ubnt ER6
firewall {
    all-ping enable
    broadcast-ping disable
    ipv6-receive-redirects disable
    ipv6-src-route disable
    ip-src-route disable
    log-martians enable

    name WAN_IN {
        default-action drop
        description "WAN to internal"
        enable-default-log
        rule 20 {
            action accept
            description IPTV
            destination {
                address 224.0.0.0/4
                group {
                }
            }
            log disable
            protocol all
        }
        rule 30 {
            action accept
            description "Allow Multicast UDP"
            destination {
                address 224.0.0.0/4
            }
            log disable
            protocol udp
            state {
                established disable
                invalid disable
                new enable
                related disable
            }
        }
        rule 40 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 50 {
            action drop
            description "Drop invalid state"
            log enable
            state {
                invalid enable
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        enable-default-log
        rule 20 {
            action accept
            description IPTV
            destination {
                address 224.0.0.0/4
                group {
                }
            }
            log disable
            protocol all
        }
        rule 30 {
            action accept
            description BBOX
            log disable
            protocol all
            source {
                address 192.168.2.123
            }
        }
        rule 40 {
            action accept
            description BBOX2
            destination {
                address 192.168.2.123
            }
            log disable
            protocol all
        }
        rule 50 {
            action accept
            description VPN-XYZ
            log disable
            protocol all
            source {
                address 192.168.42.0/24
            }
        }
        rule 60 {
            action accept
            description OPENVPN
            destination {
                port 1194
            }
            log disable
            protocol udp
            source {
            }
        }
        rule 70 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 80 {
            action drop
            description "Drop invalid state"
            log enable
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        duplex auto
        speed auto
    }
    ethernet eth1 {
        address 192.168.1.1/24
        description Local
        duplex auto
        speed auto
    }
    ethernet eth2 {
        address 192.168.2.1/24
        description IPTV
        duplex auto
        poe {
            output off
        }
        speed auto
    }
    ethernet eth3 {
        duplex auto
        speed auto
    }
    ethernet eth4 {
        duplex auto
        speed auto
    }
    ethernet eth5 {
        address dhcp
        description Internet
        duplex full
        speed 1000
        vif 100 {
            address dhcp
            description INTERNET
            dhcp-options {
                client-option "send vendor-class-identifier "BYGTELIAD";"
                default-route update
                default-route-distance 210
                name-server update
            }
            firewall {
                in {
                    name WAN_IN
                }
                local {
                    name WAN_LOCAL
                }
            }
            mtu 1500
        }
    }
    loopback lo {
    }
    openvpn vtun0 {
        mode server
        server {
            name-server 192.168.1.1
            push-route 192.168.1.0/24
            push-route 192.168.42.0/24
            subnet 10.255.2.0/24
        }
        tls {
            ca-cert-file /config/auth/cacert.pem
            cert-file /config/auth/server2.pem
            dh-file /config/auth/dh.pem
            key-file /config/auth/server2.key
        }
    }
}
port-forward {
    auto-firewall enable
    hairpin-nat enable
    lan-interface eth1
    lan-interface eth2
    rule 1 {
        description "xxx http"
        forward-to {
            address 192.168.1.254
            port 9988
        }
        original-port 9988
        protocol tcp_udp
    }
    rule 2 {
        description "xxx https"
        forward-to {
            address 192.168.1.254
            port 9989
        }
        original-port 9989
        protocol tcp_udp
    }
    rule 3 {
        description Bbox4k_1
        forward-to {
            address 192.168.2.123
            port 1234
        }
        original-port 1234
        protocol udp
    }
    rule 4 {
        description Bbox4k_2
        forward-to {
            address 192.168.2.123
            port 8002
        }
        original-port 8002
        protocol udp
    }
    rule 5 {
        description Bbox4k_3
        forward-to {
            address 192.168.2.123
            port 8000
        }
        original-port 8000
        protocol udp
    }
    rule 6 {
        description Bbox4K_4
        forward-to {
            address 192.168.2.123
            port 20000-30000
        }
        original-port 20000-30000
        protocol udp
    }
    wan-interface eth5.100
}
protocols {
    igmp-proxy {
        interface eth1 {
            role disabled
            threshold 1
        }
        interface eth2 {
            alt-subnet 0.0.0.0/0
            role downstream
            threshold 1
        }
        interface eth5.100 {
            alt-subnet 0.0.0.0/0
            role upstream
            threshold 1
        }
    }
    static {
        route 192.168.11.0/24 {
            next-hop 192.168.42.1 {
                description OPENVPN
                distance 1
            }
        }
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN1 {
            authoritative enable
            subnet 192.168.1.0/24 {
                default-router 192.168.1.1
                dns-server 194.158.122.10
                dns-server 194.158.122.15
                domain-name xyz.lan
                lease 86400
                start 192.168.1.90 {
                    stop 192.168.1.150
                }
            }
        }
        shared-network-name LAN2 {
            authoritative disable
            description TV
            subnet 192.168.2.0/24 {
                default-router 192.168.2.1
                dns-server 194.158.122.10
                dns-server 194.158.122.15
                lease 86400
                start 192.168.2.100 {
                    stop 192.168.2.149
                }
                static-mapping Bouygtel4K-1234567890 {
                    ip-address 192.168.2.123
                    mac-address blabla
                }
            }
        }
        static-arp disable
        use-dnsmasq enable
    }
    dns {
        forwarding {
            cache-size 4000
            listen-on eth1
            listen-on eth2
            name-server 208.67.222.222
            name-server 208.67.220.220
            name-server 208.67.222.220
            options dhcp-vendorclass=set:bbox,stb_bytel
            options dhcp-option=tag:bbox,42,194.158.119.97
            options dhcp-option=tag:bbox,15,lan
            options dhcp-option=tag:bbox,58,150
            options dhcp-option=tag:bbox,59,262
            options dhcp-option=tag:bbox,125,00:00:00....
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            log disable
            outbound-interface eth5.100
            protocol all
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
    unms {
        connection wss://192.168.1.11:443+.....
    }
}
system {
    analytics-handler {
        send-analytics-report false
    }
    crash-handler {
        send-crash-report false
    }
    domain-name xyz.lan
    flow-accounting {
        disable-memory-table
        ingress-capture post-dnat
        interface eth1
        netflow {
            enable-egress {
                engine-id 1
            }
            engine-id 0
            mode daemon
            server 192.168.1.11 {
                port 2055
            }
            timeout {
                expiry-interval 60
                flow-generic 60
                icmp 60
                max-active-life 60
                tcp-fin 10
                tcp-generic 60
                tcp-rst 10
                udp 60
            }
            version 9
        }
        syslog-facility daemon
    }
    host-name Router
    login {
        banner {
            post-login "Now You are logged on Edge-MAX router !\n"
            pre-login "*************************************************************\n*                                                           
.........................
*\n*************************************************************\n"
        }
        user admin {
            authentication {
                encrypted-password ****************
            }
            level admin
        }
    }
    name-server 127.0.0.1
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    offload {
        hwnat disable
        ipsec enable
        ipv4 {
            forwarding enable
            vlan enable
        }
        ipv6 {
            forwarding enable
            vlan enable
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
        host 192.168.1.11:5514 {
            facility all {
                level info
            }
        }
    }
    time-zone Europe/Paris
    traffic-analysis {
        dpi enable
        export enable
    }
}
vpn {
    ipsec {
        allow-access-to-local-interface disable
        auto-firewall-nat-exclude enable
        esp-group FOO0 {
            compression disable
            lifetime 3600
            mode tunnel
            pfs enable
            proposal 1 {
                encryption aes128
                hash sha1
            }
        }
        ike-group FOO0 {
            ikev2-reauth no
            key-exchange ikev1
            lifetime 28800
            proposal 1 {
                dh-group 14
                encryption aes128
                hash sha1
            }
        }
        site-to-site {
            peer abcd.com {
                authentication {
                    mode pre-shared-secret
                    pre-shared-secret ****************
                }
                connection-type initiate
                description VPN
                ike-group FOO0
                ikev2-reauth inherit
                local-address any
                tunnel 1 {
                    allow-nat-networks disable
                    allow-public-networks disable
                    esp-group FOO0
                    local {
                        prefix 192.168.1.0/24
                    }
                    remote {
                        prefix 192.168.42.0/24
                    }
                }
                tunnel 2 {
                    allow-nat-networks disable
                    allow-public-networks disable
                    esp-group FOO0
                    local {
                        prefix 192.168.1.0/24
                    }
                    remote {
                        prefix 192.168.11.0/24
                    }
                }
            }
        }
    }
}


Il doit manquer un truc quelque part...

Pour infos, je n'utilise pas le port eth0 du routeur mais le port eth5 avec un module Ubnt RJ45 1G pour la connection avec l'ONT.
Surtout parce que je l'avait en stock chez moi :)

glok

  • Client Bbox fibre
  • *
  • Messages: 3
  • Fenain 59
Exigences TV
« Réponse #40 le: 29 décembre 2020 à 21:08:25 »
Pour ceux qui utilise un SG250/350 il n'y avait que la priorité et le protocol à selectionner dans l'ACL ipv4 ?

Je tiens à préciser que j'ai suivi le tuto de Pinomat concernant la COS sur Cisco.
Merci dailleurs a Mirtouf, bulle et tous les autres pour leur super boulot sur le sujet.