Auteur Sujet: LAN n'a pas d'IPV6 via PfSense  (Lu 3468 fois)

0 Membres et 1 Invité sur ce sujet

marcoIT

  • Abonné SFR fibre FttH
  • *
  • Messages: 1
  • Paris 13ème (13)
LAN n'a pas d'IPV6 via PfSense
« le: 16 janvier 2020 à 15:55:48 »
Salut les fibrés !

Je sollicite vos connaissances en configuration IPV6 via PfSense.

En effet, j'ai depuis peu l'IPV6 avec SFRBusiness. Et je vous dis pas le temps que j'ai du attendre pour l'avoir .....  :o
Il m'ont livré leur routeur Cisco dont bien entendu je n'ai pas accès. Je me suis tout de même assuré que leur routeur est en mode bridge.
Et puis SFR m'a donné les informations de configuration pour l'IPV6 dont les voici :

2A02:XXXX:XXXX/48
2A02:XXXX:XXXX ::/64


Dernière le routeur SFR j'ai une machine avec PfSense en version 2.4.4-RELEASE-p3.

J'ais déja un WAN et LAN en IPv4 qui fonctionne sans soucis. Mais la configuration du réseau en IPV6 foire honteusement  :-[ ...

(J'ai joins des captures d'écran de ma config PfSense.)

Visiblement mon WAN récupère bien une IPV6 via DHCP6.
Le LAN, lui, est en mode Track Interface et devrait normalement récupérer un préfixe et s'attribuer ensuite une addresse automatiquement. Malheureusement, ça ne fonctionnement pas, mais pas du tout !  :(

Si une âme charitable pouvais me donner un coup de main, je lui serais d'une reconnaissance éternelle  ;D

Fyr

  • Abonné Free fibre
  • *
  • Messages: 642
  • Talissieu 01
LAN n'a pas d'IPV6 via PfSense
« Réponse #1 le: 17 janvier 2020 à 01:26:26 »
Je crois que tu lances pas de serveur DHCPv6 sur ton interface LAN. La case n'est pas cochée. C'est pour ça qu'il y a un 2eme onglet "Router Advertisement" parce que le DHCPv6 ne donne pas de route par défaut, et cet onglet ne contient rien pour indiquer le prefixe qu'il récupère etc. Là je ne vois aucune configuration pour que le LAN obtienne son préfixe.

Es-tu certains de vouloir un DHCPv6 server sur l'interface LAN ou bien un simple vrai Router Advertisement (rtadvd) qui balance prefixe+dns+default route ?

https://docs.netgate.com/pfsense/en/latest/book/services/ipv6-dhcp-server-and-router-advertisements.html#services-ipv6-ra

Celui là avec les screenshots qui vont vous aider
https://forum.netgate.com/topic/135524/sanity-check-on-my-ipv6-settings-56-pd-dhcp6-enabled/5

kgersen

  • Modérateur
  • Abonné Bbox fibre
  • *
  • Messages: 9 099
  • Paris (75)
LAN n'a pas d'IPV6 via PfSense
« Réponse #2 le: 17 janvier 2020 à 02:23:25 »
Et puis SFR m'a donné les informations de configuration pour l'IPV6 dont les voici :

2A02:XXXX:XXXX/48
2A02:XXXX:XXXX ::/64



ils ont rien précisé d'autre niveau config ou donné plus de détails sur ces 2 lignes ? mentionnent'il DHCPv6-PD par exemple ? (c'est en principe ce qu'on fait).

Le /64 indiqué (2eme ligne) fait partie du /48 (1ere ligne) ou n'a rien a voir ? (en gros: tes XXXX:XXXX sont les memes sur les 2 lignes?)

Parce que en l'état ca ne peut pas trop marcher, avec un seul /64 s'il est affecté au WAN. Y'a bien a priori un /48 mais tu ne demande qu'un /64.

Si SFR fait du DHCPv6-PD tu as 2 choix:

A:  - coche "Request only an IPv6 Prefix". Ton PfSense va faire une demande DHCPv6-PD mais ne pas utiliser le prefix /64 recu pour se configurer une IPv6 WAN. De coup ce prefix est disponible pour le LAN via le 'Track Interface'.

B:  - met 48 (ou moins mais au plus 63) dans la ligne "DHCPv6 Prefix Delegation Size": Dans ce cas le 1er /64 ira pour le WAN, et le 2eme /64 pour LAN via "Track Interface".

Tu peux aussi faire A+B dans ce cas tu auras tout le /48 de disponible pour le renvoyer sur des sous-réseaux ou des VMs. Il est de toute façon mieux que ton interface WAN n'ai pas d'IPv6 public c'est plus safe et plus simple (en plus d'économiser un /64).. donc A+B est ce que je recommanderai.

Si SFR ne fait pas du DHCPv6, il faut plus d'info de leur part.

Là je ne vois aucune configuration pour que le LAN obtienne son préfixe.

Il est en mode 'Track Interface' justement, c'est sensé se faire automatiquement (obtention du prefix via DHCPv6-PD sur l'interface trackée (WAN) puis activation d'un RADVD sur le LAN avec ce prefix). Sauf que la a priori il n'obtient pas de prefix du tout ou alors un seul prefix /64 qui est utilisé par le WAN du coup le LAN n'a pas de prefix pour lui.
« Modifié: 17 janvier 2020 à 02:48:43 par kgersen »