Auteur Sujet: Optimisation de la QoS sur openwrt  (Lu 1158 fois)

0 Membres et 1 Invité sur ce sujet

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 551
Optimisation de la QoS sur openwrt
« le: 10 octobre 2019 à 01:56:25 »
Bonsoir,

Ayant maintenant 2 lignes SIP, je voudrais faire un peu de QoS sur mon  ADSL histoire que ça ne soit pas tout haché lorsque je lance un téléchargement. J'avais déjà essayé il y a quelques mois, et il me semble que ça fonctionnait à peu près. Mais après divers upgrade/downgrade de firmware je ne l'avais pas remis en place.

Cette fois j'ai réinstallé le bouzin, mais j'ai toujours quelques ratés, par exemple lorsque un téléchargement débute (ou lors d'un speedtest), le son est haché un bref instant, puis ça revient. Ensuite ça à l'air de faire le job puisque la "qualité" sur linphone ne bouge pas et reste à 5 et le son est nickel. Si je ne l'active pas, ça se dégrade sévère avec des microcoupures quasi constantes.

J'ai essayé de baisser le débit (pour être sûr que la ligne ne soit pas saturée), ce qui fonctionne, mais cette coupure brève est toujours là.

Pour le moment, j'ai des règles sommaires (j'ai juste ajouté pour mon VPN et la livebox) :
config interface 'wan'
option classgroup 'Default'
option upload '800'
option overhead '1'
option enabled '1'
option download '12000'

config classify
option target 'Priority'
option ports '22,53'
option comment 'ssh, dns'

config classify
option target 'Normal'
option proto 'tcp'
option ports '20,21,25,80,110,443,993,995'
option comment 'ftp, smtp, http(s), imap'

config classify
option target 'Express'
option dsthost '2001:470:x:x::x'
option comment 'VPN wireguard'

config default
option target 'Express'
option proto 'udp'
option pktsize '-500'

config reclassify
option target 'Priority'
option proto 'icmp'

config default
option target 'Bulk'
option portrange '1024-65535'

config classgroup 'Default'
option classes 'Priority Express Normal Bulk'
option default 'Normal'

config class 'Priority'
option packetsize '400'
option avgrate '10'
option priority '20'

config class 'Priority_down'
option packetsize '1000'
option avgrate '10'

config class 'Express'
option packetsize '1000'
option avgrate '50'
option priority '10'

config class 'Normal'
option packetsize '1500'
option packetdelay '100'
option avgrate '10'
option priority '5'

config class 'Normal_down'
option avgrate '20'

config class 'Bulk'
option avgrate '1'
option packetdelay '200'

config classify
option target 'Express'
option srchost '192.168.32.2'
option proto 'udp'
option comment 'SIP LB'


Peut-être faut-il jouer avec la taille des paquets vu que je suis en PPPoE ?

Merci d'avance