Auteur Sujet: Évolution serveur/NAS  (Lu 1702 fois)

0 Membres et 1 Invité sur ce sujet

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 954
Évolution serveur/NAS
« le: 25 février 2019 à 16:05:33 »
Bonjour à tous,

Mon NAS commençant à être bien plein, je réfléchis à la manière de le faire évoluer. Actuellement il tourne avec 2 HDD de 1 To (principal/sauvegarde) + un SSD de 32 Go avec une debian minimale qui fait tout. Il est sur une base Asrock Q1900-ITX.

Liste des évolutions envisagées :

-ajouter de la RAM (2 Go actuellement, passage à 6 ou 8 Go)
-installer proxmox
-séparer la partie web/DHCP/DNS de la partie NAS (avec openmediavault) + un windows server (pour faire mumuse avec AD et Wsus principalement)
-séparer encore plus les services dans des containers ?
-ajouter des ports SATA (6-8 disques, je pense monter à 6 voir 8 To)
-faire un RAID
-ajouter une carte réseau sur le mini PCI-E (agrégation, 2Gb/s en tout)

Pour les ports SATA, bien que limité par l’unique PCI-E x1, je pense mettre une carte avec 4 ports pour avoir 1Gb/s par disque, vu que les HDD même les plus performants sont aux alentours des 100 Mo/s ça devrait passer, non ? Et vu que tous les ports seront pris, je passerais par l’USB3 pour le système, pas trop pénalisant ?

Pour le RAID, j’hésite. Étant donné qu’on a des HDD de plus en plus gros, le risque de panne lors d’une (longue) reconstruction d’un RAID 5 par exemple n’est pas négligeable. Mais en même temps avec un RAID 50 + l’agrégation y’a moyen de faire quelque chose qui dépote (pour peu que j’investisse aussi dans un switch 10G, ça va revenir cher tout ça  :P) J’ai aussi envisagé le RAID 10, moins stressant en cas de reconstruction mais on gâche 50 % de l’espace, c’est dommage au vu de la somme investie. Ou alors je pars sur ZFS, qui est apparemment plus rapide pour reconstruire d’après un test que j’ai lu. BTRFS est hors course puisque le mode RAID5/6 est toujours instable (dommage).

Autre interrogation : l’emplacement des données. Actuellement tout est sur les HDD y compris mes sites web. Hors, je remarque que lors du premier accès, genre après un reboot, que le disque gratte à fond et les sites mettent plusieurs secondes pour s’afficher, ce qui est assez pénible alors qu’on est en local. Du coup, vaudrait-il mieux que je les migre sur le SSD ? Ou c’est simplement dû au fait que le HDD est plein à 90 % (donc fragmentation en hausse) ?

Les sauvegardes : Pour la partie data, ce sera  répliqué sur un disque externe (voir dans un futur - probablement lointain - sur un second NAS)  par contre je ne sais pas comme organiser la partie VM… Faire une backup sur le SSD est un peu stupide. Leur réserver un dossier sur les HDD me paraît pas mal, seul problème, si j’attache un partage NFS, lorsqu’il faudra sauvegarder OMV, ça va coincer…

Que faire ? Dédier une partition ? (mais pas sûr que je puisse si les disques sont en passtrough sur OMV ?) Utiliser un disque supplèmentaire ?

Voilà voilà, vos avis sont bienvenus  :)

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 954
Évolution serveur/NAS
« Réponse #1 le: 27 février 2019 à 02:02:17 »
Ayant un SSD de 120 Go en attente pour ma tour, je l'ai finalement pris pour installer proxmox (et j'ai bien fait de garder l'autre), car les premiers essais ne sont pas très concluants surtout avec les sites web qui sont horriblement lents, mais vraiment, il a fallut que j'attende plus de 3 minutes pour  que le backend de prestashop s'affiche !! Pareil avec wordpress  qui a mis "que" 30 sec, quelle réactivité  ::)

Au début, je pensais que ça venait des droits sur les fichiers (qui ont été modifiés lors de la copie), mais non. C'est d'autant plus frustrant qu'ils sont sur le SSD. J'ai également testé en montant un partage NFS à partir du HDD mais c'est exactement pareil...

Je n'arrive pas à comprendre d'où peut venir cette lenteur extrême... ni la RAM ni le CPU sont saturés pourtant. Maigre consolation, l'affichage de l’accueil des sites est à peu près aussi rapide que d'habitude (qq secondes tout au plus). Ce n'est à priori pas non plus un problème de BDD puisque qu'il n'y a eu aucune erreur lors de la restauration.

Hormis cette anomalie, les VM en elles-mêmes tournent correctement, un boot en 15 sec chrono, pas de ralentissement notable.

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 934
  • Toulouse (31)
Évolution serveur/NAS
« Réponse #2 le: 27 février 2019 à 09:39:59 »
Pour etre sur d'avoir bien compris :
Avant tu etais sans proxmox (en bare métal) avec 2 GO de ram
Ton second test est avec proxmox et combien de ram ?

Il faut savoir que l'hyperviseur (proxmox) te coute en resources ce qui peut etre anodin sur une machine bien taillée mais catastrophique si tu es deja limité en resource (RAM par exemple)

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 954
Évolution serveur/NAS
« Réponse #3 le: 27 février 2019 à 14:23:27 »
Je n'ai pas encore rajouté la RAM, donc toujours 2 Go. Effectivement proxmox me prend environ 700 Mo et ça swap légèrement sur le SSD.

Je viens de tester en désactivant la swap et en allouant 768 Mo à la VM. Bilan : toujours pareil et la RAM n'est pas pleine (environ 300 Mo utilisés).

Ayant un autre proxmox en service, sur une machine encore plus ancienne (athlon X2 5400B) avec 4 Go de RAM, certes, et 1 Go attribué à la VM, le nextcould installé dessus n'est pas aussi lent... Il faudrait que je compare.

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 934
  • Toulouse (31)
Évolution serveur/NAS
« Réponse #4 le: 27 février 2019 à 16:15:35 »
Tu ne perds pas qu'en RAM en ajoutant un hyperviseur, tu perds aussi en acces disque si tu n'a pas VT-d activé (tous les proc ne le supportent pas)
C'est pour cela que j'avais abandonné mes N54L pour passer sur d'autres machines, mais je sais que le xeon sur gen8 le supporte

kazyor

  • Expert SFR
  • Expert
  • *
  • Messages: 612
  • Lyon 7ème (69)
Évolution serveur/NAS
« Réponse #5 le: 27 février 2019 à 16:18:57 »
Tu ne perds pas qu'en RAM en ajoutant un hyperviseur, tu perds aussi en acces disque si tu n'a pas VT-d activé (tous les proc ne le supportent pas)
C'est pour cela que j'avais abandonné mes N54L pour passer sur d'autres machines, mais je sais que le xeon sur gen8 le supporte

Même avec un passthrough sur un ESXi ?

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 954
Évolution serveur/NAS
« Réponse #6 le: 27 février 2019 à 16:36:39 »
Je veux bien perdre en perfs, mais de là à autant ralentir le truc c'est un peu étonnant quand même.

Enfin, si c'est réellement la cause (le J1900 ne supporte pas le VT-d apparemment), et bien tant pis, je repasserais sur ma bonne vieille Debian  qui me donne entière satisfaction (et stabilité) depuis 3 ans, même si pour certaines tâches, j'aurais préféré avoir une interface web conviviale (pour la partie NAS notamment)... Webmin aide bien, mais c'est pas encore ça niveau intuitivité.

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 934
  • Toulouse (31)
Évolution serveur/NAS
« Réponse #7 le: 27 février 2019 à 18:21:34 »
Même avec un passthrough sur un ESXi ?
Le passthrough sous esxi n'a pas ce probleme effectivement mais la on parle de proxmox

tivoli

  • Toulouse (31)
  • Client Bbox fibre FTTH
  • *
  • Messages: 1 934
  • Toulouse (31)
Évolution serveur/NAS
« Réponse #8 le: 27 février 2019 à 18:23:11 »
Je veux bien perdre en perfs, mais de là à autant ralentir le truc c'est un peu étonnant quand même.

Enfin, si c'est réellement la cause (le J1900 ne supporte pas le VT-d apparemment), et bien tant pis, je repasserais sur ma bonne vieille Debian  qui me donne entière satisfaction (et stabilité) depuis 3 ans, même si pour certaines tâches, j'aurais préféré avoir une interface web conviviale (pour la partie NAS notamment)... Webmin aide bien, mais c'est pas encore ça niveau intuitivité.
De memoire avec mon N54L j'avais une degradation terrible, genre 20mo/s sur un HDD, seul le SSD avait une performance qui devenait moyenne

kazyor

  • Expert SFR
  • Expert
  • *
  • Messages: 612
  • Lyon 7ème (69)
Évolution serveur/NAS
« Réponse #9 le: 27 février 2019 à 19:31:28 »
Le passthrough sous esxi n'a pas ce probleme effectivement mais la on parle de proxmox
Juste que j’hésitai à passer sous proxmox sur mon N54L pour tester.
Là tu me donnes une bonne raison de ne pas le faire :)

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 954
Évolution serveur/NAS
« Réponse #10 le: 27 février 2019 à 21:18:55 »
De memoire avec mon N54L j'avais une degradation terrible, genre 20mo/s sur un HDD, seul le SSD avait une performance qui devenait moyenne

Pour le coup, en transfert de fichiers sur OMV (avec les disques en passthrough), c'est pas trop dégueulasse, environ 50 Mo/s avec SMB. j'ai à peine plus avec ma debian aux petits oignons (environ 60 Mo/s). Pas testé NFS encore.

EDIT : Me voilà déçu : NFS est moins rapide que SMB (45 contre 55 Mo/s) alors qu'avec ma debian c'est l'inverse, NFS atomise SMB, le gigabit étant "presque" à fond (entre 80 et 90 Mo/s)  :(

Je crois qu'on peut dire que ce test de proxmox est un échec. Je tenterais bien ESXi mais si c'est pour aboutir au même résultat...
« Modifié: 27 février 2019 à 21:47:00 par renaud07 »

Thornhill

  • Client SFR fibre FTTH
  • *
  • Messages: 2 501
  • Saint-Médard-en-Jalles (33)
Évolution serveur/NAS
« Réponse #11 le: 27 février 2019 à 21:48:05 »
Le passthrough sous esxi n'a pas ce probleme effectivement mais la on parle de proxmox

Proxmox c'est du KVM, je suis surpris que les perfs I/O soient si dégradées : les drivers paravirtualisés (virtio) ont bien été utilisés ?

 

Mobile View