Auteur Sujet: pi-hole : blocage noms de domaine et HSTS  (Lu 197 fois)

0 Membres et 1 Invité sur ce sujet

renaud07

  • Client Orange adsl
  • *
  • Messages: 1 910
pi-hole : blocage noms de domaine et HSTS
« le: 08 août 2019 à 03:12:51 »
Bonsoir,

Système : Ubuntu 18.04.2

Je viens d'installer pi-hole pour voir son efficacité, et en m’amusant à bloquer certains noms de domaine, j'ai au bout d'un moment une erreur HSTS qui me dit détecter une erreur de certificat. En regardant le détail, je vois qu'il est émis par VMware. J'ai testé avec le lecteur web de Spotify en bloquant les domaines suivants :

-api.spotify.com
-gew-spclient.spotify.com
-weblb-wg.dual-gslb.spotify.com

Serait-ce parce que pi-hole renvoie 0.0.0.0 ? Et vu que j'ai VMware worksation installé y'aurait un potentiel conflit ? Surtout que ça le fait uniquement lorsque je démarre une VM windows 10 en NAT, une fois éteinte le site revient (mais en indiquant "une erreur s'est produite" vu que j'ai bloqué des domaines essentiels au fonctionnement).

Pi-hole est en VM sur virtualbox.

Je suis curieux de savoir comment est géré le truc pour provoquer ce genre de cas farfelu. C'est du même acabit que la Livebox 4 et le 1.1.1.1 ?

Merci d'avance.
« Modifié: 08 août 2019 à 03:34:31 par renaud07 »

TheNewbieNetwork

  • Client Orange Fibre
  • *
  • Messages: 86
  • Mulhouse (68)
pi-hole : blocage noms de domaine et HSTS
« Réponse #1 le: 08 août 2019 à 12:06:16 »
Bonjour,

essaye de désactiver la fonction de partage des VM, par défaut vmware Worksation utilise le port 443 afin de faire tourner le serveur de partage, du coup potentiel conflit ?


renaud07

  • Client Orange adsl
  • *
  • Messages: 1 910
pi-hole : blocage noms de domaine et HSTS
« Réponse #2 le: 08 août 2019 à 15:48:51 »
Merci beaucoup pour ta réponse.

On dirait bien que c'est la source du problème. Car une fois désactivé firefox m'indique connexion refusée, et en réactivant le serveur, j'ai de nouveau l'erreur HSTS.

Par contre, et je ne l'avais pas remarqué hier open.spotify.com est un alias de weblb-wg.dual-gslb.spotify.com qui est bloqué. C'est donc normal que j'ai une connexion échouée, mais je n'explique pas pourquoi le site s'affichait quand même, peut-être le cache ?

En tout cas, mystère résolu  :)

 

Mobile View