Auteur Sujet: Incendie dans le datacenter Maxnod: 13h aprés, le forum est de retour !  (Lu 14129 fois)

0 Membres et 1 Invité sur ce sujet

Paul

  • Abonné Orange Fibre
  • *
  • Messages: 4 270
  • Vannes (56)
    • Twitter
Le forum est de retour !
« Réponse #72 le: 02 avril 2023 à 17:47:59 »
Je suis surpris, sans directive sur que faire d'un mail venant d'une IP interdite par le SPF, je pensais que le serveur de réception serait paumé et que c'est ça qui expliquait le résultat aléatoire. Je ne pensais pas que les mails d'un domaine sans DMARC pouvaient fonctionner durablement.

vivien

  • Administrateur
  • *
  • Messages: 47 699
    • Twitter LaFibre.info
Le forum est de retour !
« Réponse #73 le: 02 avril 2023 à 21:49:53 »
J'ai toujours des erreurs de SPF (plus avec Google qui est en IPv6).

Mon serveur a une IPv4 10.1.1.62 avant d'avoir son IPv4 publique 80.67.167.77

Voici le fichier /etc/network/interfaces :
auto lo
iface lo inet loopback
post-up ip addr add 80.67.167.77/32 dev lo

auto eth0
iface eth0 inet static
address 10.1.1.62/30
gateway 10.1.1.61 src 80.67.167.77

iface eth0 inet6 static
address 2a0b:cbc0:10:1af1:b2e::42/64
gateway 2a0b:cbc0:10:1af1:b2e::1
        dns-nameservers 2a0b:cbc0:42::42 2001:4860:4860::8888

Il faudrait que je rajoute 10.1.1.62 dans le SPF ?

Hugues

  • AS2027 MilkyWan
  • Modérateur
  • *
  • Messages: 12 574
  • Lyon (69) / St-Bernard (01)
    • Twitter
Le forum est de retour !
« Réponse #74 le: 02 avril 2023 à 21:52:36 »
si tu tcpdump, tu sors avec quelle ip tes mails ? normalement la .77

vivien

  • Administrateur
  • *
  • Messages: 47 699
    • Twitter LaFibre.info
Le forum est de retour !
« Réponse #75 le: 02 avril 2023 à 22:06:10 »
Je vais regarder, en attendant, je vais demande plus de souplesse pour les mails et certains pouraient ne plus rejetter le SPF qui ne correspond pas, j'ai demandé le "safe mode"

SPF avant :
600 IN TXT "v=spf1 ip4:80.67.167.77 ip6:2a0b:cbc0:10:1af1:b2e::42 include:mx.ovh.com -all"

SPF modifié à l'instant :
600 IN TXT "v=spf1 ip4:80.67.167.77 ip6:2a0b:cbc0:10:1af1:b2e::42 include:mx.ovh.com ~all"



NekoXeno

  • Abonné OVH
  • *
  • Messages: 171
Le forum est de retour !
« Réponse #76 le: 03 avril 2023 à 00:55:05 »
Vous m'avez manqué <3

Pour l'instant, lafibre.info est chez moi, dans mon bureau !

Bravo à toi et à Milkywan ! ;)

vivien

  • Administrateur
  • *
  • Messages: 47 699
    • Twitter LaFibre.info
Le forum est de retour !
« Réponse #77 le: 03 avril 2023 à 13:44:33 »
Problématique des mails envoyés en IPv4 résolue

La cause ?

L'utilisation d'un mauvais DNS !


En effet, j'utilisais un DNS qui fait du DNS64 et qui répond un AAAA à tous les domaines IPv4 only, y compris les MX.

L'IPv6 est renvoyé vers une plateforme NAT64 MilkyWan qui a une autre adresse IPv4 que celle du SPF, d'où le refus.

Je suis repassé sur un DNS standard et un SPF strict :

600 IN TXT "v=spf1 a include:mx.ovh.com -all"

cali

  • Officiel Ukrainian Resilient Data Network
  • Fédération FDN
  • *
  • Messages: 2 407
    • Ukrainian Resilient Data Network
Le forum est de retour !
« Réponse #78 le: 03 avril 2023 à 15:34:20 »
Les mails sont envoyés et reçus via un relai OVH ?

C'est moche, en plus ils ne savent pas faire de v6.

simon

  • Abonné Orange Fibre
  • *
  • Messages: 935
Le forum est de retour !
« Réponse #79 le: 03 avril 2023 à 16:56:12 »
L'IPv6 est renvoyé vers une plateforme NAT64 MilkyWan qui a une autre adresse IPv4 que celle du SPF, d'où le refus.

Une solution alternative serait de mettre l'adresse IPv4 de la passerelle NAT64 dans ton record SPF.

vivien

  • Administrateur
  • *
  • Messages: 47 699
    • Twitter LaFibre.info
Le forum est de retour !
« Réponse #80 le: 03 avril 2023 à 17:54:44 »
Une solution alternative serait de mettre l'adresse IPv4 de la passerelle NAT64 dans ton record SPF.
Dans ce cas-là je n'ai pas de reverse-DNS qui correspond (je ne sais pas si c'est encore important de nos jours, il y a 10 ans, cela l'était)

Les mails sont envoyés et reçus via un relai OVH ?

C'est moche, en plus ils ne savent pas faire de v6.
Non, les mails sont envoyés par le forum, directement en IPv6 quand c'est possible.

Par contre, quand j'envoie des mails @lafibre.info via Thunderbird, c'est avec les MX OVH, mais je vais devoir changer ça pour rajouter DKIM.

Lucien

  • Abonné Sosh fibre
  • *
  • Messages: 3 300
Le forum est de retour !
« Réponse #81 le: 03 avril 2023 à 18:03:07 »
Depuis l'incident, je ne reçois plus les mails de notification.

vivien

  • Administrateur
  • *
  • Messages: 47 699
    • Twitter LaFibre.info
Le forum est de retour !
« Réponse #82 le: 03 avril 2023 à 18:37:38 »
Oui, les serveurs de mails qui sont en IPv4 only ne fonctionnement toujours pas (ok en IPv6).

Maintenant, postfix utilise bien l'IPv4 du forum, sauf qu'elle a une protection anti-DDOS qui a pour effet collatéral de bloquer les mails.

Hugues va trouver une solution...

Optix

  • AS41114 - Expert OrneTHD
  • Abonné Orne THD
  • *
  • Messages: 4 809
  • WOOHOO !
    • OrneTHD
Le forum est de retour !
« Réponse #83 le: 03 avril 2023 à 19:03:16 »
Hugues va trouver une solution...

Passez vos serveurs mails en IPv6, la vie n'en sera que plus belle  :D