Auteur Sujet: Remplacer sa livebox par un routeur Cisco IOS  (Lu 31405 fois)

0 Membres et 1 Invité sur ce sujet

pinomat

  • Abonné Orange Fibre
  • *
  • Messages: 140
  • THIONVILLE 57
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #48 le: 27 août 2020 à 09:54:50 »
Le tracert ne me donne que "délai d'attente de la demande dépassée"
Hello,

Voici mes constatations d'après ton post :
1) Dans ta config, je vois une incohérence :
ip dhcp pool CLIENT_LAN
 network 192.168.30.0 255.255.255.0
 dns-server 8.8.8.8
default-router 192.168.0.254
Si ton PC est sur LAN 192.168.30.0/24 --> ta passerelle doit être sur le même réseau.

2) Je ne vois pas les adresses IP du routeur sur les différents VLAN ou LAN. Tu dois avoir une IP pour ton routeur pour chaque LAN/VLAN/pool DHCP ou si tu préféres pour chaque interface.
3) Je ne distingue pas clairement la configuration des VLAN, on voit bien le 835 mais ce ne serait pas plutôt pour l'interaace WAN ?
4) Je ne vois pas de configuration firewall, ce qui est assez inquiétant niveau sécurité. Cisco pourrait aussi, par défaut, tout bloquer ?!

Le mieux serait pour moi :
1) 1 seul LAN + 1 seul pool DHCP (attention, si le LAN ADMIN est configuréré par défaut, il ne faut surtout pas le supprimer, sinon tu risques de perdre l'accès au routeur)
2) vérifier les adresses du routeur dans le pool DHCP (l'adresse IP doit être configuré sur la bonne interface.)
3) tester
 
Bon courage !

atalec

  • Abonné Orange vdsl
  • *
  • Messages: 7
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #49 le: 27 août 2020 à 10:08:31 »
Merci pour ton temps,

J'ai revu ma conf

Building configuration...

Current configuration : 2415 bytes
!
! Last configuration change at 06:19:19 UTC Thu Aug 27 2020
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
warm-reboot
boot-end-marker
!
!
!
no aaa new-model
!
no ipv6 cef
ipv6 spd queue min-threshold 62
ipv6 spd queue max-threshold 63
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 192.168.0.250 192.168.0.254
!
ip dhcp pool CLIENTS
 network 192.168.0.0 255.255.255.0
 default-router 192.168.0.254
 dns-server 8.8.8.8 8.8.4.4
 domain-name ataworld.fr
!
!
ip domain name ataworld.fr
ip host ataworld.fr ns Router.ataworld.fr
ip host Router.ataworld.fr 192.168.0.254
ip host PC.ataworld.fr 192.168.0.10
ip name-server 8.8.8.8
ip name-server 8.8.4.4
ip name-server 80.10.246.2
ip name-server 80.10.246.129
multilink bundle-name authenticated
!
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO2901/K9 sn FCZ1749C153
!
!
!
!
controller VDSL 0/0/0
 operating mode vdsl2
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description LINE
 ip address 192.168.0.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 duplex auto
 speed auto
 ntp disable
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 description adsl
 no ip address
 shutdown
 no atm ilmi-keepalive
 hold-queue 224 in
!
interface Ethernet0/0/0
 mtu 1508
 no ip address
!
interface Ethernet0/0/0.835
 encapsulation dot1Q 835
 pppoe enable group global
 pppoe-client dial-pool-number 1
 pppoe-client ppp-max-payload 1500
!
interface Dialer1
 description vdsl ppp orange
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ppp chap hostname fti/xxxxx
 ppp chap password 0 xxxxx
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip route 0.0.0.0 0.0.0.0 193.253.160.3
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 0.0.0.0 255.255.255.0
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end
« Modifié: 27 août 2020 à 11:12:40 par atalec »

slyworld

  • Abonné Orange Fibre
  • *
  • Messages: 13
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #50 le: 08 octobre 2020 à 18:58:31 »
Et bien ca sera sans !

Il me prend pas les options de ip dhcp class :
Router(config-dhcp-class)#?
DHCP class configuration commands:
  exit    Exit from DHCP class configuration mode
  no      Negate a command or set its defaults
  relay   Enter relay agent information option configuration submode
  remark  Specify a remark for this class

Router(config-dhcp-class)#
Cisco IOS Software [Everest], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 16.6.3, RELEASE SOFTWARE (fc8)

Bonjour,
Je me permet de déterrer ce sujet car j'ai trouvé une info qui va probablement intéresser les possesseurs de la dernière génération de routeur Cisco :

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/xe-16-10/dhcp-xe-16-10-book/config-dhcp-client-xe.html

en résumé, depuis la version 16.9.1 (Fuji) je cite :
"The DHCP Client supports configuration of all 1-254 options."

donc la récupération d'une IP sur le VLAN 832 doit être possible !  ;D

(malheureusement, ça n'est pas pour moi avec mon 2911 mais bon...  :-\ )

bon tests à ceux qui tenterons le coup !

petrus

  • Expert AS206155
  • Expert
  • *
  • Messages: 1 054
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #51 le: 08 octobre 2020 à 21:48:44 »
Ah, intéressant en effet, mauvaise nouvelle cela dit pour les propriétaires de routeurs trop vieux...

Noscarius

  • Abonné Orange adsl
  • *
  • Messages: 2
  • Albi 81
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #52 le: 20 décembre 2020 à 20:06:55 »
Pour ce qui est options ip dhcp class absentes sur un 2911, j'ai été surpris de les voir présentes sur mon c897va Version 15.9(3)M1 :

Home_Router(config)#ip dhcp cla
Home_Router(config)#ip dhcp class ?
  LINE  Class name

Home_Router(config)#ip dhcp class ont
Home_Router(config-dhcp-class)#?
DHCP class configuration commands:
  exit    Exit from DHCP class configuration mode
  no      Negate a command or set its defaults
  option  Raw DHCP options
  relay   Enter relay agent information option configuration submode
  remark  Specify a remark for this class

Home_Router(config-dhcp-class)#option ?
  <0-254>  DHCP option code

Par contre je peux pas vérifier si ça marche, je suis dans une résidence des années 60, la gaine technique est en vrac, alors que tout le quartier est fibré depuis un an  >:(
Reste l'inconnue de la compatibilité du sfp.
Je verrai bien l'an prochain en déménageant sur Toulouse.

slyworld

  • Abonné Orange Fibre
  • *
  • Messages: 13
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #53 le: 20 décembre 2020 à 20:46:34 »
Pour ce qui est options ip dhcp class absentes sur un 2911, j'ai été surpris de les voir présentes sur mon c897va Version 15.9(3)M1 :

Home_Router(config)#ip dhcp cla
Home_Router(config)#ip dhcp class ?
  LINE  Class name

Home_Router(config)#ip dhcp class ont
Home_Router(config-dhcp-class)#?
DHCP class configuration commands:
  exit    Exit from DHCP class configuration mode
  no      Negate a command or set its defaults
  option  Raw DHCP options
  relay   Enter relay agent information option configuration submode
  remark  Specify a remark for this class

Home_Router(config-dhcp-class)#option ?
  <0-254>  DHCP option code

Par contre je peux pas vérifier si ça marche, je suis dans une résidence des années 60, la gaine technique est en vrac, alors que tout le quartier est fibré depuis un an  >:(
Reste l'inconnue de la compatibilité du sfp.
Je verrai bien l'an prochain en déménageant sur Toulouse.

.....sauf que la commande "ip dhcp class" ne concerne pas le CLIENT DHCP mais le SERVEUR DHCP (le RELAY aussi je crois)......donc inutilisable pour le cas de la config orange fibre en dhcp.....je le sais car sur mon 2911, ces commandes sont également présentes....et ne m'ont servi à rien :/

Noscarius

  • Abonné Orange adsl
  • *
  • Messages: 2
  • Albi 81
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #54 le: 20 décembre 2020 à 21:34:30 »
Bon ok du coup je lorgne sur l'isr C1111X-8P, fanless et poe, parfait pour usage perso, à moins que t'aies une recommendation.

slyworld

  • Abonné Orange Fibre
  • *
  • Messages: 13
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #55 le: 20 décembre 2020 à 23:02:47 »
Bon ok du coup je lorgne sur l'isr C1111X-8P, fanless et poe, parfait pour usage perso, à moins que t'aies une recommendation.

il me semble avoir lu que ce modèle était effectivement capable de soutenir les vitesses de la fibre (ce que ton Cisco actuel ne devait pas pouvoir soutenir je pense ) donc, pourquoi pas ;) il tourne sous IOS-XE Fuji ou Gibraltar donc, a priori, pas de soucis pour pouvoir le connecter à la fibre Orange en DHCP....si j'avais le budget, je tenterais c'est sur ! :D

slyworld

  • Abonné Orange Fibre
  • *
  • Messages: 13
Remplacer sa livebox par un routeur Cisco IOS
« Réponse #56 le: 21 décembre 2020 à 11:18:42 »
Bon ok du coup je lorgne sur l'isr C1111X-8P, fanless et poe, parfait pour usage perso, à moins que t'aies une recommendation.

Page 28 de ce PDF, tu trouveras des infos sur le modèle qui t'intéresse :
https://www.ciscolive.com/c/dam/r/ciscolive/emea/docs/2019/pdf/BRKARC-2005.pdf

attention, ce sont des données en IMIX ! donc avec des packets de 409 Octets selon les "normes" Cisco indiqué par exemple dans ce PDF à la page 4 :
http://anticisco.ru/pubs/ISR_G2_Perfomance.pdf

Donc, a priori, tu peux atteindre le Gb/s en version "IP Base" à condition de ne pas encrypter ton traffic (limite à 50 Mb/s dans ce cas en version basique)