Auteur Sujet: [Resolu] Remplacer la box SFR par un routeur CISCO  (Lu 4022 fois)

0 Membres et 1 Invité sur ce sujet

victorc

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 6
  • Lille - 59
[Resolu] Remplacer la box SFR par un routeur CISCO
« le: 03 juillet 2021 à 02:23:19 »
Bonjour,

Je lance le sujet car je n'y arrive pas tout seul.
J'ai pourtant essayé plusieurs configurations sur un routeur CISCO ISR 1111.

Par exemple :
interface GigabitEthernet0/0/0
 ip dhcp client client-id ascii neufbox_NB6VAC
 ip dhcp client class-id neufbox_NB6VAC
 ip dhcp client hostname neufbox_NB6VAC
 ip dhcp client option 60 ascii neufbox_NB6VAC
 ip address dhcp
 negotiation auto
end

Rien à faire, la négociation DHCP ne se fait pas

Auriez-vous quelques idées ?
Je sais qu'il faut renseigner un "mot de passe" dans la section Fibre de la NB6VAC-FXC-r0. Y a t'il un rapport ?

Merci d'avance
« Modifié: 10 juillet 2021 à 00:18:36 par victorc »

Fratakesse

  • Abonné SFR / RED 4G/5G
  • *
  • Messages: 9
Remplacer la box SFR par un routeur CISCO
« Réponse #1 le: 03 juillet 2021 à 10:44:12 »
Je n'utilise pas ce routeur mais dans l'option Class-identifier (option 60) j'ai "neufbox6"
et dans Client-identifier (option 61), j'ai rien du tout.
Rien d'autre...
...et cela fonctionne pour moi

victorc

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 6
  • Lille - 59
Remplacer la box SFR par un routeur CISCO
« Réponse #2 le: 03 juillet 2021 à 13:40:22 »
Bonjour,
J'ai essayé d'en mettre le minimum mais dans les traces debug il envoie de toute façon un hostname, client-id, class-id avec des valeurs cisco.
J'ai donc mis la totale avec neufbox6 sans plus de succès :
ip dhcp class neufbox6
 option 60 neufbox6
!
interface GigabitEthernet0/0/0
 ip dhcp client request option 43
 ip dhcp client client-id ascii neufbox6
 ip dhcp client class-id neufbox6
 ip dhcp client hostname neufbox6
 ip dhcp client option 60 ascii neufbox6
 ip address dhcp
 negotiation auto
 spanning-tree portfast
!

Log debug dhcp detail :
*Jul  3 11:38:17.223: DHCP: Try 23 to acquire address for GigabitEthernet0/0/0
*Jul  3 11:38:17.226: DHCP: No configured hostname - not including Hostname option
*Jul  3 11:38:17.226: DHCP: allocate request
*Jul  3 11:38:17.226: DHCP: new entry. add to queue, interface GigabitEthernet0/0/0
*Jul  3 11:38:17.226: DHCP: MAC address specified as  0000.0000.0000 (0 0). Xid is 2106
*Jul  3 11:38:17.227: DHCP: SDiscover attempt # 1 for entry:
*Jul  3 11:38:17.227: Temp IP addr: 0.0.0.0  for peer on Interface: GigabitEthernet0/0/0
*Jul  3 11:38:17.227: Temp  sub net mask: 0.0.0.0
*Jul  3 11:38:17.227:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul  3 11:38:17.227:    DHCP transaction id: 2106
*Jul  3 11:38:17.227:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Jul  3 11:38:17.227:    Next timer fires after: 00:00:04
*Jul  3 11:38:17.227:    Retry count: 1   Client-ID: neufbox6
*Jul  3 11:38:17.227:    Client-ID hex dump: 6E657566626F7836
*Jul  3 11:38:17.227:    Hostname: neufbox6
*Jul  3 11:38:17.227: DHCP: SDiscover placed class-id option: 6E657566626F7836
*Jul  3 11:38:17.227: DHCP: SDiscover: sending 296 byte length DHCP packet
*Jul  3 11:38:17.227: DHCP: SDiscover 296 bytes
*Jul  3 11:38:17.228:             B'cast on GigabitEthernet0/0/0 interface from 0.0.0.0
*Jul  3 11:38:20.977: DHCP: SDiscover attempt # 2 for entry:
*Jul  3 11:38:20.977: Temp IP addr: 0.0.0.0  for peer on Interface: GigabitEthernet0/0/0
*Jul  3 11:38:20.977: Temp  sub net mask: 0.0.0.0
*Jul  3 11:38:20.977:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul  3 11:38:20.978:    DHCP transaction id: 2106
*Jul  3 11:38:20.978:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Jul  3 11:38:20.978:    Next timer fires after: 00:00:04
*Jul  3 11:38:20.978:    Retry count: 2   Client-ID: neufbox6
*Jul  3 11:38:20.978:    Client-ID hex dump: 6E657566626F7836
*Jul  3 11:38:20.978:    Hostname: neufbox6
*Jul  3 11:38:20.978: DHCP: SDiscover placed class-id option: 6E657566626F7836
*Jul  3 11:38:20.978: DHCP: SDiscover: sending 296 byte length DHCP packet
*Jul  3 11:38:20.978: DHCP: SDiscover 296 bytes
*Jul  3 11:38:20.978:             B'cast on GigabitEthernet0/0/0 interface from 0.0.0.0
*Jul  3 11:38:24.976: DHCP: SDiscover attempt # 3 for entry:
*Jul  3 11:38:24.977: Temp IP addr: 0.0.0.0  for peer on Interface: GigabitEthernet0/0/0
*Jul  3 11:38:24.977: Temp  sub net mask: 0.0.0.0
*Jul  3 11:38:24.977:    DHCP Lease server: 0.0.0.0, state: 3 Selecting
*Jul  3 11:38:24.977:    DHCP transaction id: 2106
*Jul  3 11:38:24.977:    Lease: 0 secs,  Renewal: 0 secs,  Rebind: 0 secs
*Jul  3 11:38:24.977:    Next timer fires after: 00:00:04
*Jul  3 11:38:24.977:    Retry count: 3   Client-ID: neufbox6
*Jul  3 11:38:24.977:    Client-ID hex dump: 6E657566626F7836
*Jul  3 11:38:24.977:    Hostname: neufbox6
*Jul  3 11:38:24.977: DHCP: SDiscover placed class-id option: 6E657566626F7836
*Jul  3 11:38:24.978: DHCP: SDiscover: sending 296 byte length DHCP packet
*Jul  3 11:38:24.978: DHCP: SDiscover 296 bytes
*Jul  3 11:38:24.978:             B'cast on GigabitEthernet0/0/0 interface from 0.0.0.0
*Jul  3 11:38:28.978: DHCP: QScan: Timed out Selecting state%Unknown DHCP problem.. No allocation possible
*Jul  3 11:38:37.712: DHCP: Waiting for 60 seconds on interface GigabitEthernet0/0/0

victorc

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 6
  • Lille - 59
Remplacer la box SFR par un routeur CISCO
« Réponse #3 le: 05 juillet 2021 à 21:09:18 »
Bonjour,

Voici la config qui fonctionne.

interface GigabitEthernet0/0/1
 ip dhcp client class-id neufbox_NB6VAC
 ip address dhcp
 negotiation auto
 spanning-tree portfast
end

Bonne journée,

Victor

victorc

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 6
  • Lille - 59
Remplacer la box SFR par un routeur CISCO
« Réponse #4 le: 10 juillet 2021 à 00:17:45 »
Pour compléter ma réponse précédente, voici une config complète (avec serveur DHCP) sur Routeur CISCO fonctionnel en remplacement de la Box de SFR :
! Serveur DHCP
ip dhcp pool 192.168.1.0
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
 dns-server 8.8.8.8

! Interface WAN
interface GigabitEthernet0/0/1
 ip dhcp client class-id neufbox_NB6VAC
 ip address dhcp
 ip nat outside
 negotiation auto
 spanning-tree portfast

! Vlan LAN
interface Vlan1
 ip address pool 192.168.1.0
 ip nat inside

! Route
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1 dhcp

! NAT
access-list 10 permit 192.168.1.0 0.0.0.255
ip nat inside source list 10 interface GigabitEthernet0/0/1 overload

xp25

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 4 712
  • ↓ 1Gbps | ↑ 500Mbps
[Resolu] Remplacer la box SFR par un routeur CISCO
« Réponse #5 le: 10 juillet 2021 à 00:46:31 »
Merci ça peut servir  ;)

Nic01as

  • Abonné SFR fibre FttH
  • *
  • Messages: 4
[Resolu] Remplacer la box SFR par un routeur CISCO
« Réponse #6 le: 15 décembre 2021 à 00:40:14 »
Merci pour les explications, cela fonctionne, cependant le flux TV ne passe pas. Une idée ?

victorc

  • Abonné RED by SFR fibre FttH
  • *
  • Messages: 6
  • Lille - 59
[Resolu] Remplacer la box SFR par un routeur CISCO
« Réponse #7 le: 15 décembre 2021 à 10:14:19 »
J'ai tenté de configurer mais n'y suis pas arrivé.
Je ne connais pas la configuration technique requise pour cela (VLAN, DHCP...).
En effet, la Box TV requiert des paramètres spécifiques afin d'accepter de se connecter.

Nic01as

  • Abonné SFR fibre FttH
  • *
  • Messages: 4
[Resolu] Remplacer la box SFR par un routeur CISCO
« Réponse #8 le: 17 décembre 2021 à 14:40:52 »
Visiblement de ce que j'ai lu sur les autres posts :

Pour pouvoir activer la TV, il faut pouvoir rediriger les demandes de flux multicast du réseau local vers le réseau SFR
Configurer un IGMP proxy
Puis ensuite activer l'IGMP Proxy sur l'interface LAN

Si tu as une idée des commandes :)

Merci