Auteur Sujet: IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom  (Lu 8868 fois)

0 Membres et 1 Invité sur ce sujet

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #84 le: 25 janvier 2020 à 14:47:53 »
Ca devient intéressant !

Ce qu'on voit avec le PC Windows c'est que tout fonctionne comme on pouvait l'espérer :
- Le PC reçoit une adresse IPv6 only semble-t-il (bizarre par contre pour la passerelle et le DNS qu'il reçoive une adresse mais possible que ce soit lié à un bail obtenu précédemment).
- L'IPv6 fonctionne complètement en natif.
- L'IPv4 fonctionne via NAT64/DNS64.
- Il n'y a pas d'implémentation du 464XLAT ce qui explique pourquoi via l'IP littérale en IPv4 ça ne fonctionne pas.

Par contre sur Android tu constates exactement la même chose que ce que j'avais constaté : il semblerait que le téléphone reçoive de l'IPv4 et de l'IPv6 mais comme l'IPv4 ne fonctionne pas...

Du coup, est-ce que tu peux essayer ceci ?
- Désactiver DHCP sur le routeur.
- Redémarrer le téléphone et refaire les tests (normalement il devrait prendre que de l'IPv6 et tu devrais obtenir la même chose que le PC).

denjy

  • Client SFR / RED 4G
  • *
  • Messages: 4
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #85 le: 27 janvier 2020 à 20:58:42 »
Bonjour,
Sans IP statique sur le téléphone, le téléphone n'arrive pas à se connecter au router sans DHCP.
Ca indique "Récupération de l'adresse IP..." sans jamais y arriver.
Et voici la copie d'écran.
Ne peut-on pas indiquer une adresse statique IPV6 locale pour que ça marche ?

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #86 le: 27 janvier 2020 à 23:23:05 »
Ça fonctionne en fait puisque tu as des adresses IPv6 en "2a04"  ;)

C'est juste Android qui semble misérer en IPv6 only.
T'as testé les sites pour voir ?

denjy

  • Client SFR / RED 4G
  • *
  • Messages: 4
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #87 le: 28 janvier 2020 à 11:30:32 »
Je persiste sur ma réponse, ça indique "Récupération de l'adresse IP..." sans jamais y arriver.
Et quand j'ai fais la copie d'écran, je n'étais pas connecté au réseau.

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #88 le: 28 janvier 2020 à 12:37:10 »
Du coup ça voudrait dire que Android ne fonctionne pas en Wifi IPv6 only ?

Ce serait étonnant mais sûrement une piste à creuser.
« Modifié: 28 janvier 2020 à 13:14:39 par Cryptage »

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #89 le: 29 janvier 2020 à 00:14:46 »
Ça m'intriguait cette affaire donc j'ai vérifié par moi-même et je confirme que le problème semble bien provenir d'Android et non du routeur.

En Wifi Android paraît incapable de se débrouiller s'il n'a que de l'IPv6 et pas d'IPv4... C'est vraiment super bien fait ! :o

Bref j'ai trouvé un moyen de faire fonctionner assez simplement, même si ce n'est pas très optimal :
- Dans les propriétés de la connexion Wifi, mettre en statique et non DHCP et forcer une IP quelconque. Ne pas mettre de passerelle ni de masque.
- Installer DnsPipe et le configurer pour l'IPv6 (mettre un DNS64 comme celui de Google ou de Cloudflare par exemple).
- Dans DnsPipe, cocher la case pour activer automatiquement son lancement à la connexion Wifi.

A partir de maintenant quand Android se connectera au Wifi il dira à la première visite de page qu'il n'y a pas d'Internet et demandera de garder ou non ce réseau.
Si on le garde tout fonctionne parfaitement, sauf les IP littérales IPv4 (il n'active pas CLAT) mais ce n'est pas forcément un problème.

Ce n'est pas génial mais ça permet de proposer une solution avec les routeurs TP-Link MRx00.
Il faudrait voir s'il y a mieux comme solution mais au moins on a l'explication...

Edit : bon bah c'est pas parfait... Le Playstore n'arrive pas à s'en sortir.
C'est quand même assez hallucinant venant d'une boite comme Google...

Edit 2 : https://dan.drown.org/android/clat/ (on ne sait pas de quand date la dernière MAJ par contre).

Can I use clat/464xlat with a wifi connection?

Android does not (yet) support IPv6-only wifi connections, and this software was not designed to offer CLAT services via a wifi connection.
It can be made to work by giving CLAT an IP to use in the config file, along with answering ND for that IP on the handset (set the proxy_ndp sysctl and use ip -6 neighbor add proxy ...).
Please note that running this CLAT implementation requires IPv6 forwarding turned on, so if you're relying on RA autoconfiguration (SLAAC) you'll need to configure a static IPv6 global address on the wifi interface.
Also note that multiple handsets running 464xlat on the same wifi network will result in IPv6 address conflicts if you don't make sure each one has a unique hostid for its clat function.
« Modifié: 29 janvier 2020 à 00:47:11 par Cryptage »

manchot

  • Client OVH
  • *
  • Messages: 17
  • Dauphin 04
    • Montagne-Cool
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #90 le: 02 février 2020 à 14:09:11 »
Ce sujet m'intéresse fortement car un collègue est confronté à ces problèmes.

Il a prit à la base un modem Huawei B715s-23c et un forfait b&you avec l’illimité le we.
La connexion fonctionne bien mais impossible d'avoir une connexion avec le pc pro (peut être une restriction sur le matériel avec l'antivirus / parefeu)

Il a donc pris un tplink archer mr600 et là la connexion ne fonctionne pas.
Après avoir parcouru ce fil, je lui ai fait testé en configurant l'apn en ipv6 seulement, la carte sim est passé en connected mais pour le moment rien sur le pc.

je lui ai demandé  de tester en configurant le tunnel ipv6, j'attends son retour.
Mais ensuite il faut que ça fonctionne avec son pc pro sur lequel on ne peut pas installer ce que l'on veut, par contre il est sous windows 10 et d'après vos retours ça devrait fonctionner.

Si vous avez d'autre idées

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #91 le: 02 février 2020 à 18:52:21 »
Sur le B715s ça devrait fonctionner.
On peut généralement forcer en IPv4 only pour simplifier les choses ou en IPv6 only et utiliser NAT64/DNS64 pour accéder aux sites IPv4.

Avec les TP-Link de ce qu'on a vu c'est moins évident car la couche IPv4 ne sait pas forcément faire le lien avec la couche IPv6 (côté routeur).
Sur les Huawei c'est grâce à CLAT que la couche IPv4 ne pose pas de problème mais il n'y a visiblement pas d'équivalent sur les TP-Link.

D'après les tests précédents ça semble fonctionner nativement avec Windows.
Pour Android c'est plus compliqué car il faut bypasser l'IPv4 si on veut avoir de la connectivité.

Sur un PC Pro ça devrait pouvoir fonctionner du moment qu'il arrive à obtenir une adresse IPv6 via RA/ND.
A confirmer en effet avec un PC Perso avant.

manchot

  • Client OVH
  • *
  • Messages: 17
  • Dauphin 04
    • Montagne-Cool
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #92 le: 03 février 2020 à 20:58:45 »
Pour le B715s ça marche sur les pc et autres matériels perso, je confirme, sans aucun problème ou configuration spécifique sauf que sur la partie pc pro non, on arrive à accéder au modem en désactivant les sécurités firewall mais on ne peut le faire que pendant une minute normalement pour se connecter à un portail d'hotel ou autre... et ensuite ça ne fonctionne pas, pas d'accès internet, la passerelle n'est pas accessible... donc je pense qu'il doit y avoir possiblement une blackliste sur lequel on a pas la main.

D'où le changement de modem, mais là sur les pc et autres matériels perso ça n'a pas fonctionné de suite, il restait en connecting sur l'interface du tplink.
Puis en mettant les paramètres en ipv6, il est arrivé à se connecter, mais pas d'accès internet.
Après avoir fait les manip pour le tunnel ipv6, il m'a dit qu'il avait pas de connexion internet puis je lui ai fait redémarrer le pc et ça a fonctionné.
Pareil pour un raspi sous rasbian, après redémarrage ça a fonctionné.

Maintenant il reste le test du pc pro demain, à voir si cela fonctionne avec cette astuce de tunnel ipv6 et pas de blocage.

Dans tous les cas toutes les informations ici sont intéressantes et ont permis au moins d'avancer. Merci du partage

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #93 le: 03 février 2020 à 21:44:54 »
C'est étonnant car ça ne correspond pas vraiment à ce qu'on a vu jusque-là... Pas simple sans le matos !
Autant pour les Huawei je peux essayer d'aider car j'en ai mais les TP-Link non...

Je n'ai pas forcément envie d'en acheter un car je ne l'utiliserai pas (car 100 Mbps, sauf éventuellement le MR600 en Gbps mais beaucoup trop cher).

Les retours sont les bienvenus en tout cas, n'hésite-pas :).

manchot

  • Client OVH
  • *
  • Messages: 17
  • Dauphin 04
    • Montagne-Cool
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #94 le: 04 février 2020 à 21:37:22 »
Je comprends, déjà que je n'ai pas le matos sous la main de mon coté et que je guide plus ou moins et attends les retours.

Pour le tplink, ça ne fonctionne pas plus sur le pc pro, le résultat est différent, adresse ip défini mais impossible d'atteindre le domaine du vpn.

Par contre il a toujours le huawei actuellement et comme je le pensais il est plus puissant et capte mieux que le tplink.
Mais par contre sur le pc pro, il est vraiment bloqué avec.

Il y a Symantec endpoint protection.
Il peut le désactiver quelques minutes normalement pour se connecter à un hotspot, dans ce cas la connexion fonctionne, mais dès qu'il est réactivé cela le déconnecte.
Je ne pensais pas qu'il pouvait y avoir des restrictions de ce type.
Est-ce qu'il y a moyen de passer outre ? de changer un paramètre dans le modem qui puisse le faire fonctionner ?

Est-ce que si je lui conseille de prendre un erx (meme si pour le coup il utilisera réellement les fonctionnalités de celui-ci) cela pourra fonctionner ?

Car il n'a pas d'autre moyen d'avoir une connexion exploitable (adsl en dessous de 2 mega) mais pas d'autre offre disponible.

Dans tous les cas toutes les pistes sont bonnes à prendre.

Cryptage

  • Client Free fibre
  • *
  • Messages: 191
  • Dijon
IPv6 sur les 4Gbox et routeurs 4G chez Bouygues Telecom
« Réponse #95 le: 04 février 2020 à 22:19:29 »
Je serais curieux de tester un TP-Link pour voir le comportement sous Windows car un précédent message indiquait que ça fonctionnait "nativement".

Le TP-Link délivre une IPv4 via son DHCP interne et une IPv6 via RA/ND.
Je ne sais pas comment fait Windows mais logiquement il doit essayer la passerelle IPv4 pour les sites V4 et utiliser la couche IPv6 pour les sites qui le supportent.

Le problème c'est que la couche IPv4 semble inopérante sur TP-Link en mode WAN IPv6 (le cas de Bouygues) ce qui explique pourquoi sous Android on se fait jeter (contrairement aux Huawei qui implémentent 464XLAT via CLATD).
Sous Windows on devrait d'ailleurs assez logiquement obtenir le même genre de résultat mais peut-être qu'il procède différemment ? Là aussi il me faudrait du matériel pour essayer.

Si l'idée est d'utiliser un VPN, il est pratiquement sûr qu'en mode IPv6 only ça n'aboutira pas. La plupart des VPNs ne gèrent pas (ou mal) ce protocole.
Il existe bien sûr des exceptions donc à voir en fonction...

Du coup la solution de repli est probablement d'utiliser le routeur Huawei et de forcer l'APN en mode "IPv4" qui est le seul qui permet d'obtenir une connectivité IPv4 native (ne fonctionne pas sur le TP-Link).

Par contre c'est assez étonnant que Endpoint Protection bloque l'accès.
Est-ce qu'il y a des règles "entreprises" qui empêcheraient l'accès à telle ou telle plage d'adresses par exemple ?

Peut-être essayer de mettre le routeur dans une autre plage DHCP (genre 192.168.213.x) pour voir si ça change quelque chose. Ou mieux, si le réseau de l'entreprise est en 192.168.x.x utiliser la même.

Au niveau fonctionnement c'est du classique : les clients récupèrent une adresse IPv4 via DHCP (DNS et passerelle = le routeur) cela devrait donc fonctionner car ce n'est ni plus ni moins que du routage.

Concernant l'ER-X ça n'offre pas de connectivité 4G donc c'est à mettre derrière le routeur et ça complexifierait fortement les choses en terme de gestion.
Sans aller jusque-là pour tester (c'est un peux luxueux) et pour écarter le routeur, si tu as possibilité de mettre une machine virtuelle Linux, un Raspberry Pi ou quelque chose du genre ça peut permettre de confirmer.

La mise en oeuvre se résume en gros à :
- Désactiver le DHCP du routeur Huawei.
- Mettre la VM, le Pi ou autre équipement dans le même subnet via IP fixe et définir le Huawei comme passerelle (DNS soit le routeur soit un public genre 8.8.8.8 ).
- Mettre un serveur DHCP sur cette même machine qui délivre pour le subnet avec comme passerelle la VM, le Pi... et en DNS un public genre 8.8.8.8.
- Activer le routage "echo 1 > /proc/sys/net/ipv4/ip_forward" ou via sysctl.
- Activer le masquerading "iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE" (adapter eth0 par l'interface qui est reliée au routeur).

Et si je n'oublie rien ça doit pouvoir fonctionner.
Tester en RJ45 (branché sur le routeur Huawei) et pas en Wifi pour l'instant car il n'est pas certain que ça fonctionne.

Si jamais ça ne change rien, il pourrait être intéressant de mettre une IP virtuelle sur la VM, le Pi... dans le même réseau que celui de l'entreprise et de fournir du DHCP sur ce réseau (pour by-passer Endpoint Protection).

J'ai hâte d'avoir la suite maintenant...  ;D

 

Mobile View