Auteur Sujet: BYTEL modem LTE banni ?!  (Lu 759 fois)

0 Membres et 1 Invité sur ce sujet

gartox

  • Abonné Bbox fibre
  • *
  • Messages: 21
  • Ronchin 59
BYTEL modem LTE banni ?!
« le: 22 octobre 2022 à 15:35:31 »
Bonjour,

J'avais depuis quelques années mis en place un secours 4G pour ma connexion fibre BYTEL.
La solution est basée sur un modem LTE à base de Qualcomm MDM9200 mais OEM en carte NGFF. Le tout mis en boitier USB et attaché à un petit SBC type raspberry sous armbian.
J'y ai mis ma SIM en option Multi-SIM associé à mon forfait mobile.
Ca fonctionnait plutot bien depuis environ 2 ans peut-être plus.

Depuis cet été j'ai remarqué que ca ne marchait plus et c'est seulement maintenant que j'ai un peu de temps pour debug ce problème.

Résultat des constatations :

Ma SIM BYTEL dans mon boitier Modem LTE => marche pas : ca bloque à l'étape 4/8 : Registration (network timeout).
Ma SIM BYTEL dans un autre tel/tablette => marche OK
Une SIM SFR dans mon boitier Modem LTE => marche OK : j'arrive jusqu'à l'étape 8 et j'obtiens une IP.

J'en conclu que le combo mon modem + LTE Bouygues ne fonctionne plus... alors qu'avec un autre opérateur c'est OK.
2 options :
- BYTEL a blacklisté mon modem à tel point qu'il ne me répond même plus lors de l'enregistrement sur le réseau ! pourtant mon IMEI ne semble pas être dans les blacklists de tel volé ou autre...

- BYTEL a changé dans les 6 derniers mois des options sur le réseau 4G que peut être mon modem viellissant ne supporterai pas ce qui bloque le register.

Clairement, j'ai pas de pistes, et je connais pas assez l'infra radio/LTE pour comprendre ce qu'il se passe. C'est dingue ! ca a marché pendant des années !

Est-ce que quelqu'un à déjà rencontré ce problème ? par où est que je pourrais aborder le problème sur un aure angle ?
Merci pour vos suggestions.

simon

  • Abonné Orange Fibre
  • *
  • Messages: 287
BYTEL modem LTE banni ?!
« Réponse #1 le: 22 octobre 2022 à 17:40:53 »
Si l'IMEI était blacklisté, je m'attendrai à ce que tu recoives un registration failed (access denied) ou quelque chose comme ca, pas un timeout.

Es-tu sûr que les bandes supportées par ce modem sont compatibles avec celles utilisées par Bouygues ? Peux-tu tenter une association en 2/3G pour voir ce que ca donne ?

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 551
BYTEL modem LTE banni ?!
« Réponse #2 le: 22 octobre 2022 à 18:02:30 »
Le MDM9200 fait 1/3/7/8/20, ça devrait marcher normalement.

buddy

  • Expert
  • Abonné Bbox fibre
  • *
  • Messages: 13 859
  • Alpes Maritimes (06)
BYTEL modem LTE banni ?!
« Réponse #3 le: 22 octobre 2022 à 18:07:00 »
Bonjour,

ton modem sait gérer le 464XLAT sur la 4G Bouygues ?
https://lafibre.info/bboost/arrivee-de-lipv6-sur-un-routeur-huawei-b715s-23c/msg688045/#msg688045

SFR distribue encore IPv4 + IPv6 là où Bouygues doit tenter IPv6 + 464XLAT sur ton modem/routeur 4G ..

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 551
BYTEL modem LTE banni ?!
« Réponse #4 le: 22 octobre 2022 à 18:10:34 »
Ah oui c'est vrai que BT ne distribue plus que de l'ipv6, faudrait vérifier les réglages de l'APN (basculer en v6 ou v4+v6 au moins), en espérant que le modem soit compatible (enfin je pense plutôt que c'est le soft dernière qui joue).

Pour le 464XLAT : https://lafibre.info/ipv6/clatd/

gartox

  • Abonné Bbox fibre
  • *
  • Messages: 21
  • Ronchin 59
BYTEL modem LTE banni ?!
« Réponse #5 le: 22 octobre 2022 à 18:43:46 »
En fait, avant même d'essayer d'obtenir une IP faudrait déjà que j'arrive à register sur le réseau de l'opérateur.
Donc le problème intervient avant même la négociation de l'APN.

J'ai testé avec une SIM SFR mon setup et ca fonctionne. J'arrive à l'étape 8, il me jette si j'ai pas le bon APN, et avec le bon APN il me donne une IP.

Quand mon install marchait avec BYTEL, il m'allouait une IP privée, donc après pour l'accès Internet je passait forcément par le CGNAT, ca fonctionnait correctement.

J'avait pensé à un problème lié un update d'armbian (modemmanager ou libqmi) mais du coup j'ai tout upgradé dans la dernière armbian mais ca bloque toujours à l'enregistrement sur le réseau 4G. Et comme dit, si c'était lié à mon setup, ca ne fonctionnerai pas sur SFR.

L'idée de tenter en 2G/3G est intéressante. J'ai jamais limité les réseaux sur le modem, donc s'il est pas trop bête et que la 4G est pas dispo dans le quartier il basculerai de lui même en 2G/3G.
Je crois pas trop au problème de couverture. Suis en zone urbaine, j'ai 3 antennes entre 450m et 900m.

Merci pour les idées en tout cas !  ;)

renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 551
BYTEL modem LTE banni ?!
« Réponse #6 le: 22 octobre 2022 à 19:20:37 »
En vrai essaies car au moins niveau IP y'a des diff entre 3G et 4G. Exemple avec orange, en 4G j'ai une ipv4 only et en 3G j'ai une dualstack. Ça m'étonnerais pas qu'il y ai d'autres paramètres qui changent et qui font que ça bloque.

Sinon as-tu essayé avec ta SIM principale ?


gartox

  • Abonné Bbox fibre
  • *
  • Messages: 21
  • Ronchin 59
BYTEL modem LTE banni ?!
« Réponse #7 le: 22 octobre 2022 à 19:59:53 »
Salut,

Good news !

Finalement, j'ai fouillé pour la n-ième fois les forums tous azimuts. Et suis tombé sur ce post :
https://stackoverflow.com/questions/57586605/modemmanager-gsm-registration-timeout

C'était bien la piste de l'APN.

Sauf que mon APN était bien configuré au niveau du NetworkManager.
J'ai du configurer mon APN au niveau du modem directement avec une commande AT. Chose que je ne faisait pas avant. Et hop, le register est passé.
> AT+CGDCONT=1,"IPV4V6","mmsbouygtel.com"
Cette config semble perdurer même après reboot du modem.

Soit ByTel a changé un truc pour sécuriser l'entrer sur son réseau.
Soit ce paramétrage a sauté sur mon modem, mais j'ai pas souvenir d'avoir fait cette config auparavent.
Soit il y a eu un changement de comportement du couple ModemManager/NetworkManager sous linux.

Bref, j'ai pu établir la connexion avec la 4G BouygTel !

Je vais remettre tout çà au carré dans mon setup d'origine.
Je donnerai un retour prochainement.

Merci pour vos idées !


renaud07

  • Abonné Orange adsl
  • *
  • Messages: 2 551
BYTEL modem LTE banni ?!
« Réponse #8 le: 22 octobre 2022 à 20:07:35 »
Super !

Et du coup tu reçois quoi comme IP ?

Sinon t'as essayé ebouygtel.com ? C'est en théorie l'APN par défaut pour le multi-SIM.

Dans mon cas si je fais l'inverse et que mets  ebouygtel.com sur la sim principale j'ai plus de net, enfin plus exactement ça a fonctionné quelques minutes puis bouyuges a dit stop.

gartox

  • Abonné Bbox fibre
  • *
  • Messages: 21
  • Ronchin 59
BYTEL modem LTE banni ?!
« Réponse #9 le: 05 novembre 2022 à 16:15:07 »
Salut,

Quand ca marche je reçoit une ip privée en 10.quelquechose. Mais c'est pas anormal, ca a toujours fonctionné comme çà.
Par contre, je pensait le problème résolu, mais au final, ca ne marche toujours pas bien.
Quand je bidouille l'APN, après quelques reboot et tentatives de connexion en manuel, hop ca connecte... mais genre 1/20...
Je crains, un problème hardware, c'est étrange cette config fonctionnait nickel depuis 2 ans et là ca devient aléatoire et incompréhensible... ca sent le bug ou que le modem fatigue...

Je donnerai des nouvelles si je rétablis mais pour l'instant c'est KO.

gartox

  • Abonné Bbox fibre
  • *
  • Messages: 21
  • Ronchin 59
BYTEL modem LTE banni ?!
« Réponse #10 le: 04 décembre 2022 à 21:40:13 »
Hello,

J'avais promis des nouvelles.

Il s'avère que c'est a priori un problème de couverture ou d'antenne.
En forcant en 3G ca fonctionne à peu près bien, seulement 50% de niveau de signal et une bande passante pas terrible (latence variable entre 70ms et 250ms) :  :'(
Donc a priori le network timeout en 4G c'est parce que le modem capte rien ou trop peu.

C'est assez dingue, ca fonctionnait bien avant en 4G entre 10M et 30M et 50 à 70ms de latence.
Soit mon install a pris un coup au niveau des cables d'antenne voire l'antenne en elle-même, soit la couverture est devenue bizarre peut-être avec le déploiement de la 5G...

merci pour vos réponses en tout cas.