Auteur Sujet: Perte de connection pppoe  (Lu 370 fois)

0 Membres et 1 Invité sur ce sujet

aljarreau

  • Client Maroc Telecom
  • *
  • Messages: 117
  • Casablanca
Perte de connection pppoe
« le: 11 mars 2017 à 20:29:45 »
Bonsoir,
Ayant une ip dynamique, que l'opérateur change au moins une fois par jour, avec mon ancienne config passant par son modem/routeur l'option "Always" dans la config pppoe était cochée et à chaque changement d'ip il y avait reconnection et donc, pas de coupure.
Depuis que je suis passé à la config  ONT+ERL (qui s'occupe de la connection pppoe) à chaque changement d'ip, je suis obligé de tuer la connection et la relancer avec "connect interface pppoe0"
Est-ce qu'à votre avis en changeant dans le fichier "options" dans /etc/ppp comme suit, la connection resterait up même en cas de changement d'ip?
Citer
# Exit once a connection has been made and terminated. This is the default,
# unless the `persist' or `demand' option has been specified.
#nopersist

# Do not exit after a connection is terminated; instead try to reopen
# the connection.
persist

# Initiate the link only on demand, i.e. when data traffic is present.
# With this option, the remote IP address must be specified by the user on
# the command line or in an options file.  Pppd will initially configure
# the interface and enable it for IP traffic without connecting to the peer.
# When traffic is available, pppd will connect to the peer and perform
# negotiation, authentication, etc.  When this is completed, pppd will
# commence passing data packets (i.e., IP packets) across the link.
#demand
Ou bien y at-il une autre config?
Merci pour vos retours

 

thenico

  • Expert.
  • Client Orange Fibre
  • *
  • Messages: 768
  • FTTH >500 Mb/s et FTTLA 100 Mb/s (13)
Perte de connection pppoe
« Réponse #1 le: 11 mars 2017 à 20:33:29 »
Chez Orange FTTH en config ONT + ERLite, la session PPoE tombe tous les ~7 jours et prends 2-3 minutes à être rétabli automatiquement.

aljarreau

  • Client Maroc Telecom
  • *
  • Messages: 117
  • Casablanca
Perte de connection pppoe
« Réponse #2 le: 11 mars 2017 à 20:38:02 »
Chez Orange FTTH en config ONT + ERLite, la session PPoE tombe tous les ~7 jours et prends 2-3 minutes à être rétabli automatiquement.

Bonsoir @thenico j'ai oublié de préciser que je suis chez Maroc Telecom :) et donc c'est moins commode une session qui tombe au moins une fois par jour, surtout quand on est en pleine production :)

aljarreau

  • Client Maroc Telecom
  • *
  • Messages: 117
  • Casablanca
Perte de connection pppoe
« Réponse #3 le: 19 mars 2017 à 22:13:42 »
Bonsoir,
Je reviens vers vous car, je suis toujours dans l'impasse face à cet désagrèment de coupure quotidienne toutes les 24 heures, à la seconde près je précise. Maintenant pour cerner le problème, j'aurai bien voulu savoir si c'est à cause du FAI qui change l'ip, de l'ERL qui n'arrive pas à renouveler la connection pppoe automatiquement (car j'ai remarqué qu'à l'heure où se produit cet événement -hier et aujourd'hui à 19H00- l'ERL ne fait rien et ne réagit pas (ou du moins ce que j'ai conclu) en essayant de reconnecter l'interface pppoe par exemple et le voyant de mon eth0 reste coincé sur vert allumé, jusqu'à ce que je déconnecte et re connecte manuellement l'interface à 2 ou trois reprises), Alors qu'il continue à discuter avec l'ONT avec ces lignes à l'infini:
LCP terminated by peer
ipcp: down
Connect time 1447.6 minutes.
Sent 686348169 bytes, received 4112163239 bytes.
Script /etc/ppp/ip-down started (pid 2309)
sent [LCP TermAck id=0x3]
Connection terminated: no multilink.
Modem hangup
LCP: Down event in state 1!
Script /etc/ppp/ip-down finished (pid 2309), status = 0x0
Connected to aa:bb:cc:dd:ee:ff via interface eth0.881
using channel 2
Using interface ppp0
Connect: ppp0 <--> eth0.881
sent [LCP ConfReq id=0x2 <mru 1492> <magic 0xf2cd6b33>]
rcvd [LCP ConfAck id=0x2 <mru 1492> <magic 0xf2cd6b33>]
rcvd [LCP ConfReq id=0x2 <mru 1492> <auth chap MD5> <magic 0xb05174e9>]
lcp_reqci: returning CONFACK.
sent [LCP ConfAck id=0x2 <mru 1492> <auth chap MD5> <magic 0xb05174e9>]
IPCP: Up event in state 2!
rcvd [CHAP Challenge id=0x1 <3784ab562d2657b6051cf35015b2836e>, name = "le serveur distant"]
sent [CHAP Response id=0x1 <0ce28aca5cd359180a1e6ec7946a0119>, name = "mon username"]
rcvd [LCP ConfReq id=0x3 <mru 1492> <auth chap MD5> <magic 0x96a713d2>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
lcp_reqci: returning CONFACK.
sent [LCP ConfAck id=0x3 <mru 1492> <auth chap MD5> <magic 0x96a713d2>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
sent [LCP ConfReq id=0x3 <mru 1492> <magic 0xf42acee8>]
......
je précise qu'à moins que j'intervienne manuellement la ligne "connect time" rapporte tous les jours la même valeur.

Ou tout simplement un bug dans la configuration de ce dernier.
En fait, je ne sais même pas si à l'heure que j'ai citée il y a effectivement changement d'ip ou tout simplement une perte de connection, ni comment comprendre et trouver une solution à ce désagrèment.
Encore merci pour votre aide.

P.S. Est-ce qu'il y aurait dans la config de l'ERL quelque chose qui évoquerait un lease time de dns avec le FAI ou un réglage (comme dans le l'ONT configuré modem) où il y a les options always, on demand et manual connected, alors que sur l'ERL je ne vois dans le config-tree que l'option "connect-on-demand" et sur le fichier config cette option n'y configure même pas?
 

 

Mobile View