Pages:
Actions
  • #1 par patrick1501 le 19 Mar 2017
  • Bonjour,

    J'ai une Livebox Orange connectée à la fibre, que j'ai installée dans mon bureau. Le décodeur est quant à lui dans le salon, à l'étage en dessous.
    Au départ, j'avais tiré 2 câbles Ethernet entre le bureau et le salon, dont un spécifiquement dédié au décodeur TV. Cà marche sans problème, après quelques petits déboires (voir ce fil).

    Mais je voudrais modifier mon réseau pour arriver à ceci :



    L'idée est d'utiliser les 2 câbles Ethernet entre le bureau et le salon four faire du "link aggregation", c'est-à-dire avoir une ligne de 2 Gb/s. Dans cette nouvelle configuration, le décodeur TV est relié à la Livebox par 2 switches, qui sont des Netgear GS108T v2.
    Pour que ça marche, il faut utiliser des VLAN. Mais j'ai les questions suivantes (pour commencer) :
    • Est-ce que je dois mettre un câble entre la Livebox et switch 1, de sorte qu'il y a ait sur Switch 1 un port dédiée à ce(s) VLAN(s) ?
    • Quels sont les VLAN à utiliser ? J'ai vu dans les réglages de la Livebox que les VLAN 838 et 840 étaient à utiliser, y en a-t-il d'autres ?
    • Quel est la configuration à mettre en place au niveau des switches ?

    Merci pour votre aide,
    Patrick
  • #2 par zoc le 19 Mar 2017
  • Les VLAN 838 et 840 sont uniquement utilisés sur le port WAN de la livebox. Du côté LAN il n'y a aucun VLAN.

    Comme les flux TV sont en multicast, il va être difficile d'intercaler un routeur (tu n'en parles pas dans ton message mais il est sur le schéma) entre la livebox et le décodeur TV, à moins que ce routeur puisse faire office de proxy/querier IGMP.

    Sans routeur intermédiaire ça doit fonctionner sans avoir quoi que ce soit de spécial à faire. Il faudra par contre bien activer l'IGMP snooping sur les switchs afin d'éviter que le flux multicast ne bave sur tous les ports.
  • #3 par patrick1501 le 19 Mar 2017
  • Les VLAN 838 et 840 sont uniquement utilisés sur le port WAN de la livebox. Du côté LAN il n'y a aucun VLAN.

    Comme les flux TV sont en multicast, il va être difficile s'intercaler un routeur (tu n'en parles pas dans ton message mais il est sur le schéma) entre la livebox et le décodeur TV, à moins que ce routeur puisse faire office de proxy/querier IGMP.

    Sans routeur intermédiaire ça doit fonctionner sans avoir quoi que ce soit de spécial à faire. Il faudra par contre bien activer l'IGMP snooping sur les switchs afin d'éviter que le flux multicast ne bave sur tous les ports.

    Oui, j'ai oublié de préciser, le routeur est un Linksys EA8500. Je me doutais que ce serait compliqué de faire passer ça par le routeur, d'où mon idée de relier la Livebox à Switch 1 par un câble Ethernet.

    Ce que j'aimerais faire ressemble un peu à ce que fait un VPN : que le multicast de la Livebox soit envoyé sur un port dédiée de Switch 1 (la Livebox étant connectée à ce port), qu'il transite entre les 2 switches en étant en quelque sorte "encapsulé", et ressorte à l'identique sur un port dédié de Switch 2, auquel est connecté le décodeur TV.

    Est-ce possible ?
  • #4 par zoc le 19 Mar 2017
  • Ok, donc l'idée c'est effectivement de dédier un port du switch 1 et d'y connecter la livebox directement, sans passer par le routeur. Ce port doit être dans un VLAN (peu importe son id) différent du VLAN par défaut, non taggué.

    Le VLAN doit être transporté "taggué" sur le LAG entre les 2 switchs.

    Sur le switch 2, le décodeur doit être sur un port dans le même VLAN que le port du switch 1 décrit ci-dessus.

    Reste à configurer tout celà, mais là clairement je ne pourrai pas aider, je ne connais pas ces switchs et ce genre de configuration est généralement tres différente d'une marque à l'autre...
  • #5 par patrick1501 le 19 Mar 2017
  • Je vais tester ça de suite  :)
  • #6 par patrick1501 le 19 Mar 2017
  • Il y a du bon, mais ce n'est pas encore ça...

    Voici ce que j'ai fait :

    Sur le switch 1 :
    • Création d'un VLAN id = 5
    • Association du VLAN 5 au port 1, où est connectée la LB, en mode Untagged
    • Association de VLAN 5 au lag 1, en mode tagged
    • Activation de IGMP snooping

    Sur le switch 2 :
    • Création d'un VLAN id = 5
    • Association du VLAN 5 au port 3, où est connectée le décodeur TV, en mode Untagged
    • Association de VLAN 5 au lag 1, en mode tagged
    • Activation de IGMP snooping

    Le test

    Je n'ai plus le message "Erreur de connexion à la Livebox" comme lors de mes premiers essais  :)

    Voici ce qui se passe :
    • Le message "Vérification de la version logicielle" apparait
    • Le message "Mise à jour des ressources logicielles" apparait, mais la barre de progression se bloque à environ 75%
    • Le message "Problème de connexion serveur. Le service TV d'Orange n'est pas accessible" apparait, code S04-03

    J'ai l'impression d'être proche du but, mais qu'est-ce qui cloche ?
  • #7 par patrick1501 le 19 Mar 2017
  • En fait, la TV marche. Il y avait une erreur sur la déclaration de mon LAG sur le Switch 2, qui n'était pas déclaré en LACP.

    Donc je peux voir la TV, mais par contre, les machines qui sont connectées sur Switch 2, et qui sont normalement sur le sous-réseau 192.168.1.x, ne sont plus accessibles, elles ne répondent même pas au ping  :(
  • #8 par zoc le 19 Mar 2017
  • il faut peut-être tagguer également le VLAN par défaut (1 j'imagine) sur le LAG.
  • #9 par patrick1501 le 19 Mar 2017
  • Ca fonctionne !!!
    Un grand merci zoc pour ton aide. Je vais maintenant essayer de me documenter en détail sur les VLAN, histoire de comprendre ce que je viens de faire  :D
Pages:
Actions